PowerStore:如果在 java 更新後未重新啟動見證服務,Metro 磁碟區極化會失敗
Summary: 在見證伺服器上進行 java 更新後,如果見證服務尚未重新啟動,Metro 磁碟區的兩極化可能會失敗。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
如果已設定 Witness,且 java 已更新而未重新啟動服務,則兩個 PowerStore 叢集上的 Metro 磁碟區可能無法兩極化。
這會影響 Witness 服務版本 1.0.0。
這會影響 Witness 服務版本 1.0.0。
Cause
安裝在獨立伺服器上的 Witness 服務使用 Java 11。某些系統變數僅在服務啟動期間讀取。
如果未重新啟動服務,Metro 卷的極化請求可能會失敗。這會導致兩個 PowerStore 叢集上的 Metro 磁碟區進入系統降級狀態 (離線)
如果未重新啟動服務,Metro 卷的極化請求可能會失敗。這會導致兩個 PowerStore 叢集上的 Metro 磁碟區進入系統降級狀態 (離線)
Resolution
在未來版本中,java 升級後,dell-witness-service 會自動重新啟動。
在 Witness 伺服器上執行 java 或作業系統更新後,請重新啟動 witness 服務:
sudo systemctl restart dell-witness-service
若要確認自上次見證服務啟動後 java 是否已更新,請將安裝的 java 版本與見證服務的執行路徑進行比較。
在此範例中,已安裝 java 11.0.23,且見證已在此版本上重新開機:
如果偏好和非偏好的 PowerStore 叢集上的 Metro 磁碟區都已關閉,請在兩個叢集其中一個上手動升級 Metro 磁碟區。
如有需要,請聯絡 Dell 技術支援 部門以取得更多指引。
在 Witness 伺服器上執行 java 或作業系統更新後,請重新啟動 witness 服務:
sudo systemctl restart dell-witness-service
若要確認自上次見證服務啟動後 java 是否已更新,請將安裝的 java 版本與見證服務的執行路徑進行比較。
在此範例中,已安裝 java 11.0.23,且見證已在此版本上重新開機:
[witness@test-pwrstr-witness01 ~]$ java -version openjdk version "11.0.23" 2024-04-16 LTS OpenJDK Runtime Environment (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS) OpenJDK 64-Bit Server VM (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS, mixed mode, sharing) [witness@test-pwrstr-witness01 ~]$ ps -eaf | grep witness-service-fat | grep -v grep root 1126 922 0 May10 ? 00:00:00 sudo /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jar root 1673 1126 0 May10 ? 01:20:16 /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jar如果執行中的服務參考較舊的 java 版本,請重新啟動見證服務。
如果偏好和非偏好的 PowerStore 叢集上的 Metro 磁碟區都已關閉,請在兩個叢集其中一個上手動升級 Metro 磁碟區。
警告:如果遠端系統連線並提供 I/O,升級可能會導致資料損壞。如果目前系統與遠端系統之間的連線已中斷,請確認遠端系統已不再連線。
如有需要,請聯絡 Dell 技術支援 部門以取得更多指引。
Affected Products
PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200Q, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9200TArticle Properties
Article Number: 000225384
Article Type: Solution
Last Modified: 28 May 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.