Unisphere voor PowerMax niet toegankelijk vanwege REST API-probleem Te veel geopende bestanden
Summary: Unisphere voor PowerMax is niet toegankelijk.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- REST API-aanroepen zijn gecontroleerd volgens de installatiehandleiding Unisphere voor PowerMax . Aan alle criteria is voldaan.
- Het probleem is niet opgelost door een nieuwe image van containers te maken.
- Opnieuw opstarten van beheercontainers lost het probleem voor enkele dagen op.
- Alle diensten waren operationeel.
- Fouten in run.log:
ERROR [em.spa.SPA] (EJB default - 13) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Too many open files
- Fouten in symapi.log:
04/03/2024 00:21:34.858 19033 27 EMC:UNIVMAX emcSymDBLoad pdsDbOpen() failed [/var/symapi/db/symapi_db.bin] ([PDS/File] Error opening file [Errno: 24 - Too many open files])
Cause
Er werd ontdekt dat het externe script dat werd gebruikt om de RESTAPI-oproepen uit te voeren en te controleren, de HTTPS-verbinding niet na elke RESETPI-oproep sloot.
Here 10.x.y.z is the REST API client, but it does not appear to be closing the HTTPS connection to Unisphere DMF IP 172.18.64.7: java 19033 19951 root 3835u IPv6 6326647 0t0 TCP 172.18.64.7:pcsync-https->10.x.y.z:52042 (ESTABLISHED)
Resolution
Er werd ontdekt dat het externe script dat werd gebruikt om de RESTAPI-oproepen uit te voeren en te controleren, de HTTPS-verbinding niet na elke RESETPI-oproep sloot.
Het externe script werd aangepast om de HTTPS-verbinding na elke RESTAPI-aanroep te verbreken en het probleem werd opgelost.
Het externe script werd aangepast om de HTTPS-verbinding na elke RESTAPI-aanroep te verbreken en het probleem werd opgelost.
Additional Information
Kijk voor "Too many open files" in LSOF.txt (LiSt of Open Files):
Dit bestand is te vinden in EMC Grabs onder de map Host.
Het IP-adres van de REST API-client vindt u in:
Unisphere->Supportacties > - >Bronnen voor beheerde server
Affected Products
Unisphere for PowerMaxArticle Properties
Article Number: 000225588
Article Type: Solution
Last Modified: 20 Jan 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.