PowerStore: Could not connect to SMTP host

Summary: This article addresses an issue in which the PowerStore SMTP configuration test fails because it could not connect to an SMTP host.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During SMTP configuration, the Test Email fails with an error similar to this:
Failed Alert Notifier Email test, Reason: Could not connect to SMTP host: 10.10.10.60, port: 25, response: 554 (0xE0F0101D000F) 
The system encountered unexpected backend errors. Please contact support. (0xE0101001000C)

This error is displayed in the graphical interface:
GUI screenshot showing error Failed Alert Notifier Email test, Reason: Could not connect to SMTP host: 10.10.10.60, port: 25, response: 554 (0xE0F0101D000F)
 
 

Cause

PowerStore sends SMTP events through the Cluster IP, Appliance IP, and Node IP. This error occurs if one or more of these addresses cannot reach the SMTP server on TCP port 25 or 587.

Resolution

  1. Confirm that all PowerStore IP addresses can access the SMTP server on TCP port 25 or 587.
  2. Ensure that all IP addresses in the cluster are added to the SMTP server's allowlist.
  3. For a multi-appliance cluster, follow steps 1 and 2 for all appliances and all nodes.


After these steps are performed, the SMTP configuration test email should succeed.

Affected Products

PowerStore
Article Properties
Article Number: 000225644
Article Type: Solution
Last Modified: 08 Aug 2024
Version:  2
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