Windows Server : Erreur lors du test du canal sécurisé de l’émulateur PDC : « Le domaine n’existe pas ou n’a pas pu être contacté »
Summary: Le test du canal sécurisé sur un contrôleur de domaine (DC) Active Directory (AD) qui détient le rôle d’émulateur PDC entraîne une erreur. Cette erreur indique que le domaine n’existe pas ou qu’il n’a pas pu être contacté. Cela n’indique pas un problème avec le canal sécurisé. ...
Symptoms
Le Test-ComputerSecureChannel La commande PowerShell renvoie l’erreur « Le domaine spécifié n’existe pas ou n’a pas pu être contacté » lorsqu’elle est exécutée sur l’émulateur PDC.
D’autres commandes permettant de tester le canal sécurisé, telles que nltest /sc_query, nltest /sc_verifyet netdom verify, renvoient également des erreurs similaires sur l’émulateur PDC.
Cause
La cause n’est pas connue. Ce comportement est cohérent, mais le problème sous-jacent ne semble être documenté nulle part.
Resolution
Ces erreurs sont attendues lorsque ces commandes sont exécutées sur l’émulateur PDC. Ils n’indiquent pas à eux seuls un problème avec le canal sécurisé.
Si l’on soupçonne la rupture d’un canal sécurisé, d’autres moyens doivent être utilisés pour le confirmer. En règle générale, si la réplication AD est fonctionnelle entre les contrôleurs de domaine et que les différentes consoles AD ne renvoient pas d’erreurs, le canal sécurisé est intact. Plusieurs erreurs indiquent généralement la rupture d’un canal sécurisé :
- Le nom principal cible est incorrect.
- Le nom du compte cible est incorrect.
- La relation d’approbation entre cette station de travail et le domaine principal a échoué.
- La base de données de sécurité sur le serveur ne dispose pas d’un compte d’ordinateur pour cette relation de confiance de station de travail.
La réparation d’un canal sécurisé défaillant n’entre pas dans le cadre de cet article.