Авамар: Кроки для перевірки збоїв збору сміття на Avamar

Summary: Нижче наведено кроки для перевірки збоїв збору сміття (GC) на Avamar.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Що таке збір сміття?

Збір сміття (GC) — це процес видалення невикористаних фрагментів із резервних копій, термін дії яких закінчився. Це звільняє ємність на сервері Avamar.

За замовчуванням збір сміття запускається один раз на день, починаючи з початку вікна обслуговування.

Загальні симптоми несправності:

Ось найпоширеніші симптоми, що вказують на проблему з ГК:
  • MSG_ERR_DDR_ERROR
  • MSG_ERR_DISKFULL
  • MSG_ERR_MISC
  • MSG_ERR_TRYAGAINLATER
  • MSG_ERR_BADTIMESYNC

Cause

Поширені причини поломок ГК:

MSG_ERR_DDR_ERROR
  • Існує багато основних проблем, які можуть спричинити збій GC з MSG_ERR_DDR_ERROR. Деякі з цих причин включають:
    • Помилки мережі або підключення
    • Проблеми з файловою системою Data Domain
    • Пристрій Data Domain стає заповненим
    • Термін дії або неправильний пароль користувача DD Boost
    • Занадто багато контрольних точок (Avamar) або знімків (Data Domain). Зазвичай це поєднується з hfscheck невдачі, що не дозволяють «звалити» старі КПП і знімки.
MSG_ERR_MISC або MSG_ERR_TRYAGAINLATER
  • Починаючи з Avamar v.7, резервні копії можуть виконуватися одночасно зі збором сміття.
  • Іноді процес, який називається «Розбиття індексної смуги», відбувається, коли нові дані додаються з резервних копій.
  • Оскільки цей процес «Поділ індексної смуги» не може виконуватися під час збирання сміття, повідомляється про одну з наведених вище помилок.
    • Індексні смуги на сітці мають тенденцію розщеплюватися приблизно в один і той же період часу, що і одна одна на різних вузлах.
    • Іноді це може зайняти кілька днів.
    • Avamar працює так, як було задумано. Обхідний шлях полягає в тому, щоб не запускати резервні копії під час GC.
MSG_ERR_BADTIMESYNC
  • Це рідкісна проблема, яка спостерігається лише на багатовузлових сітках. Помилка виникає, коли час не синхронізується між одним або декількома вузлами даних Avamar і вузлом утиліти.
  • Цілком ймовірно, що всі завдання з обслуговування (ГК, КПП і hfscheck) повідомляють про ту саму помилку. 

Resolution

Визначення останнього статусу збору сміття:

Інформацію про останнє збирання сміття можна переглянути за допомогою інтерфейсу CLI, AUI або сервера консолі керування (MCS).

З CLI:

AVAMAR GC Статус GIF

  • Відкрийте сеанс SSH (наприклад, putty) на сервері Avamar і увійдіть як 'admin'. Виконайте наступні команди:
status.dpn
avmaint gcstatus
  • Наступні приклади показують успішний збір сміття:
Last GC: finished Tue Jul  9 00:00:23 2024 after 00m 03s >> recovered 199.88 KB (OK)
Last GC: finished Wed Jun  5 09:20:46 2024 after 00m 12s >> recovered 0.00 KB (OK)
  • Якщо статус показує щось, крім (OK), існує потенційна проблема зі збиранням сміття:
Last GC: finished Mon Jun 17 09:02:41 2024 after 01m 51s >> recovered 14.98 MB (MSG_ERR_DDR_ERROR)
Last GC: finished Thu Jun 13 07:06:54 2024 after 03m 41s >> recovered 0.00 KB (MSG_ERR_DISKFULL)
Last GC: finished Mon Jun 10 19:04:58 2024 after 01m 01s >> recovered 0 KB (MSG_ERR_MISC)
Last GC: finished Thu Jun  16:21:12 2024 after 00m 25s >> recovered 0 KB (MSG_ERR_BADTIMESYNC)

Від САУІ:

Статус AUI GC
  • Перегляньте статус "Останній збір сміття". Якщо статус показує щось , крім (OK), існує потенційна проблема зі збиранням сміття.

З інтерфейсу MCS:

Збій статусу збору сміття - Avamar MCS UI
  • Якщо в розділі "Останній збір сміття" є червоний "x", як показано вище, існує потенційна проблема зі збиранням сміття, і потрібен подальший аналіз.

Якщо збір сміття продовжує не працювати через справжню проблему (як підтверджено за допомогою наведених вище кроків), виберіть відповідні параметри у формі відповіді на сповіщення, щоб передати запит на обслуговування агенту підтримки.

Additional Information

Визнання помилок після вирішення проблеми:

З CLI:

  1. Щоб знайти Непідтверджені події, виконайте такі дії:
mccli event show --unack
  1. Підтвердьте або єдиний код, ввівши унікальний ідентифікатор, або всі коди помилок:
mccli event show --id-

Подяка CLI

Від САУІ:

  1. Увійдіть в AUI та перегляньте дашборд: 
Визнання AUI
  1. Натисніть на знак оклику, і на екрані з'явиться щось схоже на наступне:
Визнання AUI
  1. Натисніть «Непідтверджені події», і на екрані з'явиться щось подібне до наведеного нижче:
Визнання AUI
  1. Виберіть подію (як показано вище) і натисніть Підтвердити.

Визначення того, як довго ГК виходить з ладу:

Найпростіший спосіб визначити, як довго GC не працював, це використовувати CLI (хоча ця інформація також доступна як в AUI, так і в MCS UI).

Наступна команда показує всі збої збору сміття за останні 30 днів:

dumpmaintlogs --types=gc --days=30 |grep "failed garbage collection"
2024/05/27-16:32:18.55893 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/05/28-16:32:37.92920 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/05/29-16:31:51.62962 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/05/30-16:31:55.18969 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/06/20-01:19:09.97961 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR

Affected Products

Avamar Server
Article Properties
Article Number: 000226150
Article Type: Solution
Last Modified: 28 Aug 2025
Version:  31
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.