Avamar:Avamarでガベージ コレクションの失敗を検証する手順

Summary: Avamarでガベージ コレクション(GC)の障害を検証する手順は次のとおりです。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

ガベージ コレクションとは何ですか?

ガベージ コレクション(GC)は、有効期限が切れたバックアップから未使用のチャンクを削除するプロセスです。これにより、Avamar Serverの容量が解放されます。

デフォルトでは、ガベージ コレクションは、メンテナンス ウィンドウの開始時から1日1回実行されます。

一般的な障害の症状:

以下は、GCの問題を示す最も一般的な症状です。
  • MSG_ERR_DDR_ERROR
  • MSG_ERR_DISKFULL
  • MSG_ERR_MISC
  • MSG_ERR_TRYAGAINLATER
  • MSG_ERR_BADTIMESYNC

Cause

GC障害の一般的な原因:

MSG_ERR_DDR_ERROR
  • GCが失敗する原因となる根本的な問題は多数あります。 MSG_ERR_DDR_ERRORの詳細を確認してください。これらの理由には、次のようなものがあります。
    • ネットワークまたは接続エラー
    • Data Domainファイル システムに関する問題
    • Data Domainアプライアンスがいっぱいになる
    • 期限切れまたは不正なDD Boostユーザー パスワード
    • チェックポイント(Avamar)またはスナップショット(Data Domain)が多すぎます。これは通常、 hfscheck 古いチェックポイントとスナップショットを「ロールオフ」できない障害。
MSG_ERR_MISC または MSG_ERR_TRYAGAINLATER
  • Avamar v.7以降では、バックアップをガベージ コレクションと同時に実行できます。
  • バックアップから新しいデータが追加されると、「インデックス ストライプ スプリット」と呼ばれるプロセスが発生することがあります。
  • ガベージ コレクションの実行中は、この「Index Stripe Splitting」プロセスを実行できないため、上記のエラーのいずれかが報告されます。
    • グリッド上のインデックス ストライプは、さまざまなノードで同じ期間に分割される傾向があります。
    • この処理が完了するまでに数日かかる場合があります。
    • Avamarは設計どおりに動作しています。回避策は、GC中にバックアップを実行しないことです。
MSG_ERR_BADTIMESYNC
  • これはまれな問題であり、マルチノード グリッドでのみ発生します。このエラーは、1つ以上のAvamarデータ ノードとユーティリティー ノード間で時刻が同期されていない場合に発生します。
  • すべてのメンテナンス タスク(GC、チェックポイント、および hfscheck) 同じエラーを報告しています。 

Resolution

最新のガベージ コレクション ステータスの確認:

最新のガベージ コレクションに関する情報は、CLI、AUI、またはManagement Console Server (MCS) UIを使用して表示できます

CLIから次の操作を実行します。

AVAMAR GCステータスGIF

  • Avamar ServerへのSSHセッション(puttyなど)を開き、「admin」としてログインします。以下のコマンドを実行します。
status.dpn
avmaint gcstatus
  • 次の例は、ガベージ コレクションが成功した場合を示しています。
Last GC: finished Tue Jul  9 00:00:23 2024 after 00m 03s >> recovered 199.88 KB (OK)
Last GC: finished Wed Jun  5 09:20:46 2024 after 00m 12s >> recovered 0.00 KB (OK)
  • ステータスに「(OK)」以外の表示がある場合は、ガベージ コレクションに関する潜在的な問題があります。
Last GC: finished Mon Jun 17 09:02:41 2024 after 01m 51s >> recovered 14.98 MB (MSG_ERR_DDR_ERROR)
Last GC: finished Thu Jun 13 07:06:54 2024 after 03m 41s >> recovered 0.00 KB (MSG_ERR_DISKFULL)
Last GC: finished Mon Jun 10 19:04:58 2024 after 01m 01s >> recovered 0 KB (MSG_ERR_MISC)
Last GC: finished Thu Jun  16:21:12 2024 after 00m 25s >> recovered 0 KB (MSG_ERR_BADTIMESYNC)

AUIから:

AUI GCステータス
  • [Last Garbage collection status]を確認します。ステータスに 「(OK)」 以外が表示されている場合は、ガベージ コレクションに問題がある可能性があります。

MCS UIから:

ガベージ コレクション ステータスの失敗 - Avamar MCS UI
  • [Last Garbage collection]に 上記のように赤い「x」 が表示されている場合は、ガベージ コレクションに問題がある可能性があるため、さらに分析する必要があります。

(上記の手順を使用して検証された)実際の問題が原因でガベージ コレクションが引き続き失敗する場合は、アラート応答フォームで適切なオプションを選択して、サービス リクエストをサポート エージェントに転送します。

Additional Information

問題が解決されたらエラーを確認する:

CLIから次の操作を実行します。

  1. 次のコマンドを実行して、未確認イベントを検索します。
mccli event show --unack
  1. 一意のIDを入力して単一のコードを確認するか、すべてのエラー コードを確認します。
mccli event show --id-

CLIの確認応答

AUIから:

  1. AUIにログインし、ダッシュボードを表示します。 
AUI確認応答
  1. 感嘆符をクリックすると、次のような内容の画面が表示されます。
AUI確認応答
  1. 未確認イベントをクリックすると、次のような内容の画面が表示されます。
AUI確認応答
  1. イベントを選択し(上図を参照)、[確認]をクリックします。

GCが失敗している時間の判断:

GCが失敗している時間を判断する最も簡単な方法は、CLIを使用することです(ただし、この情報はAUIとMCS UIの両方でも使用できます)

次のコマンドは、過去30日間のすべてのガベージ コレクションの失敗を表示します。

dumpmaintlogs --types=gc --days=30 |grep "failed garbage collection"
2024/05/27-16:32:18.55893 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/05/28-16:32:37.92920 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/05/29-16:31:51.62962 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/05/30-16:31:55.18969 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR
2024/06/20-01:19:09.97961 {0.0} <4202> failed garbage collection with error MSG_ERR_DDR_ERROR

Affected Products

Avamar Server
Article Properties
Article Number: 000226150
Article Type: Solution
Last Modified: 28 Aug 2025
Version:  31
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.