Data Domain: Native SQL Backups to Data Domain Fail After CIFS Timeout is Reached
Summary: The client-side session timeout resets communication with Data Domain causing backup failures.
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Symptoms
Back up to Data Domain Common Internet File System (CIFS) share fails with the following message due to unexpected network error:
BackupIoRequest::ReportIoError: write failure on backup device '\\device\share\Database_full_20240316015305.BAK'. Operating system error 59 (An unexpected network error occurred.). The operating system returned the error '59(An unexpected network error occurred.)' while attempting 'DiskChangeFileSize' on '\\device\share\Database_full_20240316015305.BAK' The operating system returned the error '59(An unexpected network error occurred.)' while attempting 'FlushFileBuffers' on '\\device\share\Database_full_20240316015305.BAK'.
Cause
The Windows Session Timeout is 60 s by default. This timeout is dependent not only on Data Domain response time, but also any network latency. If there is a slow network or longer than expected Data Domain processing (such as rapid index expansion under a heavy backup load), Windows resets the connection causing backup errors.
Resolution
Increase the Windows Session Timeout to a higher value such as 180 s by running the following command:
Set-SmbClientConfiguration -SessionTimeout 180 -Force
Affected Products
Data DomainArticle Properties
Article Number: 000226173
Article Type: Solution
Last Modified: 20 Jun 2024
Version: 1
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