Data Domain:遷移至新 Data Domain 後,Windows SQL CIFS 備份速度緩慢

Summary: Data Domain:遷移至新 Data Domain 後,Windows SQL CIFS 備份速度緩慢

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Symptoms

在舊 Data Domain 上,SQL 備份事務日誌備份需要幾秒鐘才能完成,而在新 Data Domain

上需要一小時才能完成 在新 Data Domain 上運行的每個 SQL 事務日誌備份的持續時間都會隨著每次後續備份

而增加 只有 Windows SQL 備份受到影響 Linux 或 Windows 檔案系統備份會以預期速度執行。

在 ddfs.info 記錄
中看到類似的錯誤05/29 15:00:39.333699 [7ff34e902b30] FM fm_dm1_lookup_by_handle:2865 - 開啟 (串流) - 檔案:/data/col1/mtree/SQL/transaction_log_name_timestamp.trn,FH:43451d:0:21f2058:0:9cde1f46:65772d59:0:(0:99962),cd:1482,標誌:8000008, ch :1a00,1,0,400,6,0,c95cf072,8f864927,21831b89,9c84edd0,f321165e,8992a6ec,open_ch:1a00,1,0,400,6,0,c95cf072,8f864927,21831b89,9c84edd0,f321165e,8992a6ec
05/29 15:00:39.342604 [7ff34e902800] 錯誤:FM fm_make_open_structures:889 - fm_access_intern失敗,錯誤編號 5177
05/29 15:00:39.349694 [7ff34e902800] 發生錯誤:FM fm_make_open_structures:909 - fm_access_delete 失敗,關閉時刪除,顯示 5177
05/29 15:00:39.353303 [7ff34e902800] 錯誤:FM fm_make_open_structures:909 fm_access_delete- 5177

Wireshark 擷取在 SQL 伺服器上
執行關閉時刪除開啟失敗 看到備份中的 CIFS SMB 檔案寫入作業:
2854 0.978471 10.43.132.114 142.164.13.190 SMB2 588 建立要求檔案:mtree\SQL\transaction_log_name_timestamp.trn

檔案寫入後進行尋找和讀取作業:
3556 1.253996 10.43.132.114 142.164.13.190 SMB2 166 尋找要求檔案:mtree\SQL SMB2_FIND_BOTH_DIRECTORY_INFO模式:  <在SQL 伺服器上
執行 .trn

Process Monitor,sqlserver.exe在目標目錄中每個事務日誌的讀取請求上看到訪問被拒絕,因為更多的備份完成,更多的事務日誌被寫入,導致備份時間增加 

程序監視器


Cause

作為備份命令的一部分,使用了 CleanupTime SQL 參數。  

此參數會要求讀取和刪除 Data Domain 上目的地 mtree 中的到期交易備份。

cifs 使用者不是管理員使用者。
管理員使用者需要讀取/刪除資料域
上的舊事務日誌 舊數據域使用管理員使用者
新數據域使用預設使用者

Resolution

將 cifs 使用者設為 Data Domain 上的管理員使用者
user change role <user> admin 

比如
user change role cifsuser admin 

Affected Products

Data Domain
Article Properties
Article Number: 000226280
Article Type: Solution
Last Modified: 01 Nov 2024
Version:  1
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