VxRail: El usuario no puede acceder a la interfaz de usuario de vCenter después de cambiar la contraseña

Summary: El usuario no puede acceder a la interfaz de usuario de vCenter después de que haya cambiado la contraseña.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

El usuario cambió la contraseña de la cuenta y ahora no puede acceder al cliente web de vCenter.

Probó con otra cuenta de administrador para iniciar sesión y actualizó la contraseña de la cuenta anterior, pero la cuenta se bloquea de inmediato.

Se muestra un error en vmdird.syslog.log:
2024-06-20T14:00:26.712034+08:00 err vmdird  t@139659879360256: Bind Request Failed (127.0.0.1) error 49: Protocol version: 3, Bind DN: "CN=issue account,CN=Users,DC=vsphere,DC=local", Method: SASL
2024-06-20T14:00:29.227039+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-103-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3484)(from )(by )(via Rep)(USN 599050,596449)
2024-06-20T14:00:29.230438+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-112-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3487)(from )(by )(via Rep)(USN 599051,596450)
2024-06-20T14:00:29.232652+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-124-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3491)(from )(by )(via Rep)(USN 599052,596451)
2024-06-20T14:00:29.234951+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-127-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3492)(from )(by )(via Rep)(USN 599053,596452)
2024-06-20T14:00:29.236921+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-34-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3449)(from )(by )(via Rep)(USN 599054,596453)
2024-06-20T14:00:29.239273+08:00 info vmdird  t@139660030363392: Modify Entry (cn=AssetEntity_host-52-b47a319e-6554-4483-b5f9-6cd31fe54e39,cn=LicenseService,cn=services,dc=vsphere,dc=local, EID 3455)(from )(by )(via Rep)(USN 599055,596454)
2024-06-20T14:00:29.244296+08:00 info vmdird  t@139660030363392: Modify Entry (cn=vcenter_FQDN02.customer.domain,cn=Servers,cn=Default-First-Site,cn=Sites,cn=Configuration,dc=vsphere,dc=local, EID 3501)(from )(by )(via Int)(USN 599056,0)
2024-06-20T14:00:29.247953+08:00 info vmdird  t@139660030363392: Modify Entry (labeledURI=ldap://vcenter_FQDN01.customer.domain,cn=Replication Agreements,cn=vcenter_FQDN02.customer.domain,cn=Servers,cn=Default-First-Site,cn=Sites,cn=Configuration,dc=vsphere,dc=local, EID 3503)(from )(by )(via Int)(USN 599057,0)
2024-06-20T14:00:29.248020+08:00 info vmdird  t@139660030363392: Replication supplier ldap://vcenter_FQDN01.customer.domain USN range (596446,596454) processed.
2024-06-20T14:00:32.215827+08:00 err vmdird  t@139659879360256: SASLSessionStep: sasl error (-13)(SASL(-13): authentication failure: client evidence does not match what we calculated. Probably a password error)
2024-06-20T14:00:32.216088+08:00 warning vmdird  t@139659879360256: Lockout policy check - account lockout. (cn=issue account,cn=users,dc=vsphere,dc=local)
2024-06-20T14:00:32.216125+08:00 err vmdird  t@139659879360256: VmDirSendLdapResult: Request (Bind), Error (LDAP_INVALID_CREDENTIALS(49)), Message ((49)(SASL step failed.)), (0) socket (127.0.0.1)

Cause

El usuario deshabilitó la función administrator@vsphere.local cuenta. La cuenta se eliminó de la SystemConfiguration.Administrators grupo. Si la solicitud en administrator@vsphere.local está deshabilitada y ninguna otra cuenta tiene los mismos permisos; la cuenta se bloquea. Las actualizaciones de cuentas no actualizan las contraseñas.

Consulte los detalles en el artículo de Broadcom "Código de error de LDAP 49"/error (49) en los registros de vmdird en vCenter Server Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.

Resolution

Para abordar este problema:
  1. Utilice otra cuenta de administración para iniciar sesión en vCenter Web Client. Habilitar administrator@vsphere.local.
  2. Si ya se quitó de SystemConfiguration.Administrators, vuelva a agregarlo al grupo.
  3. Uso administrator@vsphere.local para iniciar sesión en vCenter Web Client, elimine la cuenta con problemas y vuelva a crearla.
Captura de pantalla de SystemConfiguration.Administrators
Article Properties
Article Number: 000226405
Article Type: Solution
Last Modified: 26 Jun 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.