PPDM: Reporting-Engine erzeugt keine Berichte. Keine Daten zum Anzeigen vorhanden.
Summary: Die PowerProtect Data Manager-Reporting-Engine erzeugt keine Berichte und zeigt aufgrund eines DNS-Problems auf dem Reporting-Node immer "Keine anzuzeigenden Daten" an.
Symptoms
Nach der Bereitstellung der Reporting Engine wurden keine Berichte generiert. Wird immer angezeigt "No data to display."
Im dpaagent.log /var/log/reporting/logs/agent/ sehen Sie die folgenden Meldungen, die darauf hinweisen, dass die Generierung des Zertifikats fehlgeschlagen ist, gefolgt von einem Fehler bei der Namensauflösung der PowerProtect Data Manager-Appliance.
INFO 12263.12330 20240530:163624 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup... INFO 12263.12330 20240530:163729 com.emc.dpa.agent.mo - authenticate(): Using authType CERT INFO 12263.12330 20240530:163729 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. ...... WARN 12263.12330 20240530:163739 com.agent.worker - runAgentWorkerRequest(): Received unexpected output from worker: Caused by: java.net.UnknownHostException: ppdm.local: Temporary failure in name resolution
Es wurde bestätigt, dass der Status des Reporting-Node bereit ist.
Es wurde bestätigt, dass die Zeit zwischen dem Reporting-Node und dem PowerProtect Data Manager-Server synchronisiert ist."./ppcp rest --uri whitelist" Zeigt den richtigen Reporting-Node mit der Ablaufzeit in der Zukunft an.
Cause
Melden Sie sich bei der PowerProtect Data Manager-Appliance als Nutzer-Root an und führen Sie den folgenden Befehl aus, um die Zugangsdaten des Reporting-Node abzurufen.
source /opt/emc/vmdirect/unit/vmdirect.env && /opt/emc/vmdirect/bin/infranodemgmt get -secret -node_type ReportingNode
Melden Sie sich dann beim Reporting-Node an, heben Sie die Auskommentierung der folgenden Zeile auf und führen Sie das Skript /opt/emc/dpa/agent/etc/setup_ppdm_certificate.sh aus.
Das Skript ist mit HTTP_CODE=000 fehlgeschlagen. Dies geschieht normalerweise, wenn der Node, mit dem Sie versuchen, das Zertifikat auszutauschen, nicht erreichbar ist. 
Auf dem Reporting-Node 'cat /opt/emc/dpa/agent/data/ppdm/ppdm.ip', Führen Sie dann Folgendes aus: 'nslookup <host return from ppdm.ip>'. nslookup fehlgeschlagen mit "connection timed out."
Da die PowerProtect Data Manager Appliance vom Reporting-Node nicht aufgelöst werden konnte, schlug die Zertifikaterstellung fehl. Daher kann kein Bericht generiert werden, obwohl der Node-Status gut aussieht.
Resolution
- Ändern Sie /etc/resolv.conf auf dem Reporting-Node, um den richtigen DNS-Server zu verwenden.

- Führen Sie das Skript /opt/emc/dpa/agent/etc/setup_ppdm_certificate.sh erneut aus. Es sollte das folgende Erfolgsergebnis angezeigt werden.
- Warten Sie, bis der Backupjob ausgeführt wird, dann kann der Bericht korrekte Daten erzeugen.