PPDM: el motor de generación de informes no genera ningún informe. No hay datos para mostrar.

Summary: El motor de generación de informes de PowerProtect Data Manager nunca genera informes y siempre muestra "No hay datos para mostrar" debido al problema de DNS en el nodo de generación de informes. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Después de implementar el motor de informes, nunca generó informes. Siempre mostrando "No data to display."

En /var/log/reporting/logs/agent/dpaagent.log, puede ver los siguientes mensajes que indican que la generación de certificados falló, seguida de la falla de resolución de nombres del dispositivo PowerProtect Data Manager.
 

INFO    12263.12330    20240530:163624 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup...
INFO    12263.12330    20240530:163729 com.emc.dpa.agent.mo - authenticate(): Using authType CERT
INFO    12263.12330    20240530:163729 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed.
......
WARN    12263.12330    20240530:163739     com.agent.worker - runAgentWorkerRequest(): Received unexpected output from worker: Caused by: java.net.UnknownHostException: ppdm.local: Temporary failure in name resolution


Se confirmó que el estado del nodo que informa es Ready.

Se confirmó que la hora está sincronizada entre el nodo de generación de informes y el servidor de PowerProtect Data Manager.

"./ppcp rest --uri whitelist" Muestra el nodo de generación de informes correcto con la fecha de vencimiento en el futuro.

Salida de REST PPCP

 

Cause

Inicie sesión en el dispositivo PowerProtect Data Manager como usuario raíz y ejecute el siguiente comando para obtener las credenciales del nodo de generación de informes.
 

source /opt/emc/vmdirect/unit/vmdirect.env && /opt/emc/vmdirect/bin/infranodemgmt get -secret -node_type ReportingNode


A continuación, inicie sesión en el nodo de generación de informes, quite los comentarios de la siguiente línea y ejecute el script /opt/emc/dpa/agent/etc/setup_ppdm_certificate.sh.

El script falló con HTTP_CODE=000; esto suele suceder cuando no se puede acceder al nodo con el que intenta intercambiar el certificado. 

Resultado de setup_ppdm_certificate.sh fallido

En el nodo informante, 'cat /opt/emc/dpa/agent/data/ppdm/ppdm.ip', A continuación, ejecute 'nslookup <host return from ppdm.ip>'. El nslookup falló con "connection timed out."

Resultado de nslookup fallido


La falla en la resolución del dispositivo PowerProtect Data Manager desde el nodo de generación de informes causó la falla de la generación de certificados. Por lo tanto, no se puede generar un informe aunque el estado del nodo parezca correcto.
 

Resolution

  1. Modifique /etc/resolv.conf en el nodo de generación de informes para usar el servidor DNS adecuado.

    Resultado correcto setup_ppdm_certificate.sh
  2. Vuelva a ejecutar el script /opt/emc/dpa/agent/etc/setup_ppdm_certificate.sh; debería aparecer el siguiente resultado correcto.
  3. Espere a que se ejecute el trabajo de respaldo y, a continuación, el informe podría generar los datos adecuados.
 

Affected Products

PowerProtect Data Manager Appliance
Article Properties
Article Number: 000226499
Article Type: Solution
Last Modified: 02 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.