PPDM:レポート作成エンジンがレポートを生成していません。表示するデータがありません。
Summary: PowerProtect Data Managerレポート エンジンはレポートを生成せず、レポート ノードのDNSの問題により、常に「表示するデータがありません」と表示されます。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
レポート エンジンを導入した後、レポートが生成されませんでした。常に表示 "No data to display."
/var/log/reporting/logs/agent/dpaagent.logから、証明書の生成に失敗したことを示す次のメッセージに続いて、PowerProtect Data Managerアプライアンスの名前解決の失敗を確認できます。
INFO 12263.12330 20240530:163624 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup... INFO 12263.12330 20240530:163729 com.emc.dpa.agent.mo - authenticate(): Using authType CERT INFO 12263.12330 20240530:163729 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. ...... WARN 12263.12330 20240530:163739 com.agent.worker - runAgentWorkerRequest(): Received unexpected output from worker: Caused by: java.net.UnknownHostException: ppdm.local: Temporary failure in name resolution
レポート ノードのステータスが準備完了であることを確認しました。
レポート ノードとPowerProtect Data Managerサーバーの間で時刻が同期されていることを確認しました。"./ppcp rest --uri whitelist" 将来の有効期限を含む正しいレポート ノードを表示します。
Cause
ユーザーrootとしてPowerProtect Data Managerアプライアンスにログインし、次のコマンドを実行してレポート ノードの認証情報を取得します。
source /opt/emc/vmdirect/unit/vmdirect.env && /opt/emc/vmdirect/bin/infranodemgmt get -secret -node_type ReportingNode
次に、レポート ノードにログインし、次の行のコメントを解除して、/opt/emc/dpa/agent/etc/setup_ppdm_certificate.shスクリプトを実行します
スクリプトがHTTP_CODE=000で失敗しました。これは通常、証明書を交換しようとしているノードに到達できない場合に発生します。
レポート ノードで、 'cat /opt/emc/dpa/agent/data/ppdm/ppdm.ip', 次に実行します 'nslookup <host return from ppdm.ip>'. nslookupが次で失敗しました: "connection timed out."
レポート ノードからPowerProtect Data Managerアプライアンスを解決できなかったため、証明書の生成に失敗しました。したがって、ノードのステータスは良好に見えますが、レポートの生成に失敗します。
Resolution
- レポート ノードの/etc/resolv.confを変更して、適切なDNSサーバーを使用します。

- /opt/emc/dpa/agent/etc/setup_ppdm_certificate.shスクリプトを再実行すると、次のような成功結果が表示されます。
- バックアップ ジョブが実行されるまで待つと、レポートで適切なデータが生成される可能性があります。
Affected Products
PowerProtect Data Manager ApplianceArticle Properties
Article Number: 000226499
Article Type: Solution
Last Modified: 02 Sep 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.