IDPA: PTAgent non riesce a connettersi a iDRAC a causa di un'impostazione errata nelle impostazioni di configurazione locale di iDRAC
Summary: Integrated Data Protection Appliance (IDPA) PTAgent non è in esecuzione e non si avvia. pta_debug registro mostra credenziali non valide. dpacli -agentinfo mostra l'errore idracConnection. ...
Symptoms
1. Sull host ESXi, pta_call get agent/info comando e su ACM dpacli -agentinfo entrambi i comandi mostrano idracConnection, agent, idraccache Errore:
# /opt/dell/DellPTAgent/tools/pta_call get agent/info
Request sent to DellPTAgent @ https://192.168.100.101:8086
{
"libstorelibit.so": "07.05",
"process_id": "2101904",
"idrac_ethernet_ip": "x.x.x.x",
"rest_endpoints": "https://127.0.0.1:8086,https://192.168.100.101:8086",
"api_blocking_enabled": "false",
"ptagentversion": "2.5.5-5",
"name": "hostname",
"host_epoch_time": "1720671327.376838 (secs.usecs)",
"servicetag": "servicetag",
"idrac_pass_thru_ip": "169.254.0.1",
"domain": "host FQDN",
"host_pass_thru_ip": "169.254.0.2",
"status": {
"idracConnection": "Error",
"iSM": "N/A",
"agent": "Error",
"idraccache": "Error"
},
"MarvellLibraryVersion": "5.0.13.1109",
"default_server_cert": "true",
"libstorelibir-3.so": "15.03-0",
"system_uuid": "6330c25e-942f-463a-797e-78ac449f4840",
"ism_version": "4.1.0.0",
"os_version": "6.7.0 build-15160138",
"uptime": "3890 seconds ( 1 hour 4 minutes 50 seconds )",
"mfr": "Dell Inc.",
"os": "VMWare ESXi",
"model": "DP4400",
"libstorelib.so": "07.07",
"TPM Present": "false"
}
2. Sull host ESXi, /scratch/log/pta_debug.log mostra il problema delle credenziali PTAdmin:
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"@odata.type": "#Message.v1_1_0.Message",
"MessageId": "Base.1.8.AccessDenied",
"Message": "The authentication credentials included with this request are missing or invalid.",
"MessageArgs": [],
"MessageArgs@odata.count": 0,
"RelatedProperties":[],
"RelatedProperties@odata.count": 0,
"Severity": "Critical",
"Resolution": "Attempt to ensure that the URI is correct and that the service has the appropriate credentials."
}
]
3. Seguire l'IDPA degli appliance PowerProtect serie DP della Knowledge Base: la cache iDRAC è guasta a causa dell'impostazione PTAgent Minimum Length per ricreare l'account PTAdmin, ma la pagina iDRAC non mostra l'account PTAdmin in iDRAC Settings ->Users -> Local Users.
Cause
Questo problema è causato da un'impostazione errata su iDRAC.
Impostazione iDRAC ->Servizi ->Configurazione
localeDisabilitare Configurazione locale iDRAC utilizzando Impostazioni.
Disabilitare la configurazione locale di iDRAC tramite RACADM.
L'impostazione predefinita per la configurazione di cui sopra è Disabled. Se una delle impostazioni precedenti è abilitata, PTAgent potrebbe non funzionare correttamente.
Resolution
1. Accedere alla pagina iDRAC:
Impostazione iDRAC ->Servizi ->Configurazione
localeDisabilitare la configurazione locale di iDRAC utilizzando le impostazioni.
Disabilitare la configurazione locale di iDRAC tramite RACADM.
Modificare le impostazioni precedenti in Disabled e cliccare sul pulsante Apply .
2. Da ESXi, arrestare PTAgent.
/etc/init.d/DellPTAgent stop
3. Da iDRAC WebGUI, iDRAC Settings ->Users ->Local Users, eliminare l'utente PTAdmin.
4. Da ESXi, ricreare l'utente iDRAC PTAdmin. La password viene sincronizzata automaticamente.
/opt/dell/DellPTAgent/sbin/IDracUser
5. Da ESXi, avviare PTAgent.
/etc/init.d/DellPTAgent start
6. Attendere 5 minuti affinché PTAgent ricostruisca idraccache.
7. Da ESXi, testare la chiamata API REST PTAgent.
/opt/dell/DellPTAgent/tools/pta_call get agent/info /opt/dell/DellPTAgent/tools/pta_call post system/idraccheck