「IDPA:iDRACローカル構成設定の設定が正しくないため、PTAgentがiDRACに接続できない
Summary: Integrated Data Protection Appliance(IDPA) PTAgentが実行されておらず、起動に失敗します。 pta_debugログに無効な認証情報が表示されます。 dpacli -agentinfo は idracConnection エラーを表示します。
Symptoms
1.ESXiホストで、 pta_call get agent/info コマンドと ACM で dpacli -agentinfo コマンドの両方にidracConnection、agent、idraccache Errorが表示されます。
# /opt/dell/DellPTAgent/tools/pta_call get agent/info
Request sent to DellPTAgent @ https://192.168.100.101:8086
{
"libstorelibit.so": "07.05",
"process_id": "2101904",
"idrac_ethernet_ip": "x.x.x.x",
"rest_endpoints": "https://127.0.0.1:8086,https://192.168.100.101:8086",
"api_blocking_enabled": "false",
"ptagentversion": "2.5.5-5",
"name": "hostname",
"host_epoch_time": "1720671327.376838 (secs.usecs)",
"servicetag": "servicetag",
"idrac_pass_thru_ip": "169.254.0.1",
"domain": "host FQDN",
"host_pass_thru_ip": "169.254.0.2",
"status": {
"idracConnection": "Error",
"iSM": "N/A",
"agent": "Error",
"idraccache": "Error"
},
"MarvellLibraryVersion": "5.0.13.1109",
"default_server_cert": "true",
"libstorelibir-3.so": "15.03-0",
"system_uuid": "6330c25e-942f-463a-797e-78ac449f4840",
"ism_version": "4.1.0.0",
"os_version": "6.7.0 build-15160138",
"uptime": "3890 seconds ( 1 hour 4 minutes 50 seconds )",
"mfr": "Dell Inc.",
"os": "VMWare ESXi",
"model": "DP4400",
"libstorelib.so": "07.07",
"TPM Present": "false"
}
2.ESXiホストでは、/scratch/log/pta_debug.logにPTAdmin認証情報の問題が表示されます。
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"@odata.type": "#Message.v1_1_0.Message",
"MessageId": "Base.1.8.AccessDenied",
"Message": "The authentication credentials included with this request are missing or invalid.",
"MessageArgs": [],
"MessageArgs@odata.count": 0,
"RelatedProperties":[],
"RelatedProperties@odata.count": 0,
"Severity": "Critical",
"Resolution": "Attempt to ensure that the URI is correct and that the service has the appropriate credentials."
}
]
3.KBに従う:「PowerProtect DPシリーズ アプライアンスIDPA:PTAdminアカウントを再作成するためのPTAgentパスワードの最小長設定が原因でiDRACキャッシュが失敗したが、iDRACページにiDRAC設定 - ユーザー ->> ローカル ユーザー」にPTAdminアカウントが表示されない。
Cause
この問題は、iDRACの設定が正しくないために発生します。
iDRAC設定 - サービス ->>ローカル設定
:設定を使用してiDRACローカル設定を無効にします。
RACADM を使用した iDRAC ローカル設定の無効化。
上記の構成のデフォルト設定は [Disabled]です。上記の設定 のいずれかが有効になっている場合、PTAgentが正しく動作しない場合があります。
Resolution
1.[iDRAC]ページに移動します。
[iDRAC Setting ] ->[Services ] ->[Local Configuration
][Settings]を使用してiDRACローカル設定を無効にします。
RACADM を使用した iDRAC ローカル設定の無効化。
上記の設定を [Disabled ]に変更し、[ Apply ]ボタンをクリックします。
2.ESXiからPTAgentを停止します。
/etc/init.d/DellPTAgent stop
3.iDRAC WebGUIから、[iDRAC Settings ] ->[Users ] ->[Local Users]の順に選択して、PTAdminユーザーを削除します。
4.ESXiから、iDRAC PTAdminユーザーを再作成します。パスワードは自動的に同期されます。
/opt/dell/DellPTAgent/sbin/IDracUser
5.ESXiからPTAgentを起動します。
/etc/init.d/DellPTAgent start
6.PTAgentがiDRACcacheを再構築するまで5分間待ちます。
7.ESXiから、PTAgent REST APIコールをテストします。
/opt/dell/DellPTAgent/tools/pta_call get agent/info /opt/dell/DellPTAgent/tools/pta_call post system/idraccheck