IDPA:PTAgent 無法連線至 iDRAC,因為 iDRAC 本機組態設定不正確
Summary: Integrated Data Protection Appliance (IDPA) PTAgent 未執行且無法啟動。 pta_debug記錄顯示無效的認證。 dpacli -agentinfo 顯示 iDRACConnection 錯誤。
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Symptoms
1.在 ESXi 主機上, pta_call get agent/info 命令與在 ACM 上 dpacli -agentinfo 命令均顯示 idracConnection, 代理程式, idraccache 錯誤:
# /opt/dell/DellPTAgent/tools/pta_call get agent/info
Request sent to DellPTAgent @ https://192.168.100.101:8086
{
"libstorelibit.so": "07.05",
"process_id": "2101904",
"idrac_ethernet_ip": "x.x.x.x",
"rest_endpoints": "https://127.0.0.1:8086,https://192.168.100.101:8086",
"api_blocking_enabled": "false",
"ptagentversion": "2.5.5-5",
"name": "hostname",
"host_epoch_time": "1720671327.376838 (secs.usecs)",
"servicetag": "servicetag",
"idrac_pass_thru_ip": "169.254.0.1",
"domain": "host FQDN",
"host_pass_thru_ip": "169.254.0.2",
"status": {
"idracConnection": "Error",
"iSM": "N/A",
"agent": "Error",
"idraccache": "Error"
},
"MarvellLibraryVersion": "5.0.13.1109",
"default_server_cert": "true",
"libstorelibir-3.so": "15.03-0",
"system_uuid": "6330c25e-942f-463a-797e-78ac449f4840",
"ism_version": "4.1.0.0",
"os_version": "6.7.0 build-15160138",
"uptime": "3890 seconds ( 1 hour 4 minutes 50 seconds )",
"mfr": "Dell Inc.",
"os": "VMWare ESXi",
"model": "DP4400",
"libstorelib.so": "07.07",
"TPM Present": "false"
}
2.在 ESXi 主機上,/scratch/log/pta_debug.log 會顯示 PTAdmin 登入資料問題:
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"@odata.type": "#Message.v1_1_0.Message",
"MessageId": "Base.1.8.AccessDenied",
"Message": "The authentication credentials included with this request are missing or invalid.",
"MessageArgs": [],
"MessageArgs@odata.count": 0,
"RelatedProperties":[],
"RelatedProperties@odata.count": 0,
"Severity": "Critical",
"Resolution": "Attempt to ensure that the URI is correct and that the service has the appropriate credentials."
}
]
3.請依 KB PowerProtect DP 系列應用裝置 IDPA:iDRAC 快取失敗,因為 PTAgent 密碼最小長度設定可重新建立 PTAdmin 帳戶,但 iDRAC 頁面未在「iDRAC 設定」->「使用者>」-「本機使用者」中顯示「PTAdmin 帳戶」。
Cause
此問題是由 iDRAC 設定不正確所造成。
iDRAC 設定 ->服務 ->本機組態
使用設定停用 iDRAC 本機組態。
使用 RACADM 停用 iDRAC 本機組態。
上述組態的預設設定為 停用。如果以上任何一個設定已 啟用,PTAgent 可能無法正常運作。
Resolution
1.前往 iDRAC 頁面:
iDRAC 設定 ->服務 ->本機組態
使用設定停用 iDRAC 本機組態。
使用 RACADM 停用 iDRAC 本機組態。
將上述設定變更為 停用 ,然後按一下 套用 按鈕。
2.從 ESXi 停止 PTAgent。
/etc/init.d/DellPTAgent stop
3.從 iDRAC WebGUI,iDRAC 設定 ->使用者 ->本機使用者,刪除 PTAdmin 使用者。
4.從 ESXi 重新建立 iDRAC PTAdmin 使用者。密碼會自動同步。
/opt/dell/DellPTAgent/sbin/IDracUser
5.從 ESXi 啟動 PTAgent。
/etc/init.d/DellPTAgent start
6.等待 5 分鐘,讓 PTAgent 重新建置 idraccache。
7.從 ESXi 測試 PTAgent REST API 呼叫。
/opt/dell/DellPTAgent/tools/pta_call get agent/info /opt/dell/DellPTAgent/tools/pta_call post system/idraccheck
Affected Products
Integrated Data Protection Appliance FamilyProducts
Integrated Data Protection Appliance SoftwareArticle Properties
Article Number: 000226934
Article Type: Solution
Last Modified: 16 Oct 2024
Version: 1
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