ІДПА: PTAgent не вдається підключитися до iDRAC через неправильне налаштування в налаштуваннях локальної конфігурації iDRAC
Summary: Вбудований пристрій захисту даних (IDPA) PTAgent не працює і не запускається. pta_debug журналі відображаються недійсні облікові дані. dpacli -agentinfo показує помилку підключення idrac. ...
Symptoms
1. На хості ESXi, pta_call get agent/info і на ACM dpacli -agentinfo обидві команди показують помилку idracConnection, agent, idraccache:
# /opt/dell/DellPTAgent/tools/pta_call get agent/info
Request sent to DellPTAgent @ https://192.168.100.101:8086
{
"libstorelibit.so": "07.05",
"process_id": "2101904",
"idrac_ethernet_ip": "x.x.x.x",
"rest_endpoints": "https://127.0.0.1:8086,https://192.168.100.101:8086",
"api_blocking_enabled": "false",
"ptagentversion": "2.5.5-5",
"name": "hostname",
"host_epoch_time": "1720671327.376838 (secs.usecs)",
"servicetag": "servicetag",
"idrac_pass_thru_ip": "169.254.0.1",
"domain": "host FQDN",
"host_pass_thru_ip": "169.254.0.2",
"status": {
"idracConnection": "Error",
"iSM": "N/A",
"agent": "Error",
"idraccache": "Error"
},
"MarvellLibraryVersion": "5.0.13.1109",
"default_server_cert": "true",
"libstorelibir-3.so": "15.03-0",
"system_uuid": "6330c25e-942f-463a-797e-78ac449f4840",
"ism_version": "4.1.0.0",
"os_version": "6.7.0 build-15160138",
"uptime": "3890 seconds ( 1 hour 4 minutes 50 seconds )",
"mfr": "Dell Inc.",
"os": "VMWare ESXi",
"model": "DP4400",
"libstorelib.so": "07.07",
"TPM Present": "false"
}
2. На хості ESXi /scratch/log/pta_debug.log показує проблему з обліковими даними PTAdmin:
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"@odata.type": "#Message.v1_1_0.Message",
"MessageId": "Base.1.8.AccessDenied",
"Message": "The authentication credentials included with this request are missing or invalid.",
"MessageArgs": [],
"MessageArgs@odata.count": 0,
"RelatedProperties":[],
"RelatedProperties@odata.count": 0,
"Severity": "Critical",
"Resolution": "Attempt to ensure that the URI is correct and that the service has the appropriate credentials."
}
]
3. Слідкуйте за KB PowerProtect DP Series Appliances IDPA: Кеш iDRAC не працював через налаштування мінімальної довжини PTAgent Password для повторного створення облікового запису PTAdmin, але сторінка iDRAC не відображає обліковий запис PTAdmin у налаштуваннях iDRAC ->Користувачі -> Локальні користувачі.
Cause
Ця проблема спричинена неправильним налаштуванням на iDRAC.
Налаштування iDRAC ->Служби ->Локальна конфігурація
Вимкніть локальну конфігурацію iDRAC за допомогою налаштувань.
Вимкніть локальну конфігурацію iDRAC за допомогою RACADM.
За замовчуванням для наведеної вище конфігурації встановлено значення Disabled (Вимкнено). Якщо будь-яке з наведених вище налаштувань увімкнено, PTAgent може не працювати належним чином.
Resolution
1. Перейдіть на сторінку iDRAC:
Налаштування iDRAC ->Служби ->Локальна конфігурація
Вимкніть локальну конфігурацію iDRAC за допомогою Налаштувань.
Вимкніть локальну конфігурацію iDRAC за допомогою RACADM.
Змініть наведені вище налаштування на Вимкнено та натисніть кнопку Застосувати .
2. Від ESXi зупиніться PTAgent.
/etc/init.d/DellPTAgent stop
3. З веб-інтерфейсу iDRAC, Налаштування iDRAC ->Користувачі ->Локальні користувачі, видалити користувача PTAdmin.
4. У ESXi повторно створіть користувача iDRAC PTAdmin. Пароль синхронізується автоматично.
/opt/dell/DellPTAgent/sbin/IDracUser
5. З ESXi почніть PTAgent.
/etc/init.d/DellPTAgent start
6. Зачекайте 5 хвилин, поки PTAgent повторно створить idraccache.
7. З ESXi протестуйте виклик API PTAgent REST.
/opt/dell/DellPTAgent/tools/pta_call get agent/info /opt/dell/DellPTAgent/tools/pta_call post system/idraccheck