Connectrix Cisco:嘗試從區域集中移除區域,並收到錯誤訊息「狀態:作業失敗:[錯誤:區域不存在]」

Summary: 交換器透過 CLI 和光纖管理員 (DCNM SAN 用戶端) 刪除 VSAN 的區域失敗

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Symptoms

從交換器 CLI 和光纖管理員 (DCNM SAN 用戶端) 刪除 VSAN 的區域失敗,
嘗試從區域集中移除區域,並收到下列錯誤訊息:
Status: Operation failed: [Error: Zone not present]:
 

Cause


交換器 CLI 和 DCNM SAN 用戶端的區域刪除均失敗,因為交換器上遺失完整區域資料庫。

請注意以下交換器摘錄,完整區域資料庫 (非使用中組態) 沒有區域,因此值為「0」,而使用中區域資料庫 (使用中組態) 則有 11 個區域。

理想情況下,從區域集中刪除區域時,將從完整區域資料庫啟動操作(非活動配置)。在這種情況下,完整區域資料庫沒有區域,因此在記錄中收到以下警示。

交換器 CLI 摘錄:
 

VSAN: 46 default-zone: Deny distributing: Full Interop: Default
    Mode: Enhanced merge-control: Allow
    Session:  None
    Single-session: Disabled
    Hard-zoning: Enabled broadcast: Unsupported
    Smart-zoning: Disabled
    Rscn-format: fabric-address
    Activation overwrite control: Disabled
Default zone:
    Qos: None broadcast: Unsupported ronly: Unsupported
Full Zoning Database:
    DB size: 184 bytes
    Zonesets:  1 Zones: 0 Aliases: 0 Attribute-groups: 1
Active Zoning Database:
    DB Size: 792 bytes
    Name: CISCO Zonesets: 1 Zones: 11
Current Total Zone database Usage: 976 / 4,000,000 bytes (0 % used)
Pending (Session) DB size:
    Full DB Copy size: 0 bytes
    Active DB Copy size: 0 bytes
SFC size: 0 / 4,000,000 bytes (0 % used)
Status: Operation failed: [Error: Zone not present]:
        At 15:15:32 SAST Jun 24 2024



來自 DCNM 的螢幕擷取畫面:

來自 DCNM 的螢幕擷取畫面

Resolution


由於 FULL 和 ACTIVE Zone 資料庫之間存在不一致,因此建議您先將「Active zoneset to FULL zoneset」複製,以便在相關的 VSAN 46 中保持一致。
發佈區域刪除應該起作用的帖子。

在對應的交換器 CLI 上執行以下操作:

#zone copy active-zoneset full-zoneset vsan 46


一旦區域資料庫 (完整與作用中) 在 VSAN 46 上一致後請嘗試從 DCNM 移除區域 (如有需要),或可從交換器 CLI 執行相同的動作。

 

Affected Products

Connectrix MDS-Series Data Center Network Manager, Connectrix MDS-Series Firmware

Products

Connectrix MDS-Series Hardware
Article Properties
Article Number: 000227523
Article Type: Solution
Last Modified: 14 Apr 2025
Version:  2
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