Connectrix Cisco:尝试从 Zoneset 中删除分区时,收到错误消息“Status:作失败:[错误:Zone not present]”

Summary: 从交换机 CLI 和 Fabric Manager(DCNM SAN 客户端)执行的 VSAN 分区删除作在交换机上失败

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

从交换机 CLI 和 Fabric Manager(DCNM SAN 客户端)
删除 VSAN 的分区在交换机上失败。尝试从 Zoneset 中删除分区时收到以下错误消息:
Status: Operation failed: [Error: Zone not present]:
 

Cause


由于交换机上缺少完整分区数据库,从交换机 CLI 和 DCNM SAN 客户端删除分区失败。

请注意以下交换机的摘录,完整区域数据库(非活动配置)没有区域,因此值为“0”,而活动区域数据库(活动配置)中有 11 个区域。

理想情况下,从分区集中删除分区时,从完整分区数据库(非活动配置)启动作。在这种情况下,完整区域数据库没有区域,因此在日志中收到以下警报。

交换机 CLI 的摘录:
 

VSAN: 46 default-zone: Deny distributing: Full Interop: Default
    Mode: Enhanced merge-control: Allow
    Session:  None
    Single-session: Disabled
    Hard-zoning: Enabled broadcast: Unsupported
    Smart-zoning: Disabled
    Rscn-format: fabric-address
    Activation overwrite control: Disabled
Default zone:
    Qos: None broadcast: Unsupported ronly: Unsupported
Full Zoning Database:
    DB size: 184 bytes
    Zonesets:  1 Zones: 0 Aliases: 0 Attribute-groups: 1
Active Zoning Database:
    DB Size: 792 bytes
    Name: CISCO Zonesets: 1 Zones: 11
Current Total Zone database Usage: 976 / 4,000,000 bytes (0 % used)
Pending (Session) DB size:
    Full DB Copy size: 0 bytes
    Active DB Copy size: 0 bytes
SFC size: 0 / 4,000,000 bytes (0 % used)
Status: Operation failed: [Error: Zone not present]:
        At 15:15:32 SAST Jun 24 2024



来自 DCNM 的屏幕截图:

来自 DCNM 的屏幕截图

Resolution


由于 FULL 和 ACTIVE 分区数据库之间存在不一致,因此建议首先继续作并复制“Active zoneset to FULL zoneset”,以便它们在相关 VSAN 46 中保持一致。
区域删除应该可以执行的 POST。

在相应的交换机 CLI 上执行以下作:

#zone copy active-zoneset full-zoneset vsan 46


区域数据库(完整和活动)在 VSAN 46 中保持一致后,继续尝试从 DCNM 中删除分区(如果需要),或者也可以从交换机 CLI 执行相同的作。

 

Affected Products

Connectrix MDS-Series Data Center Network Manager, Connectrix MDS-Series Firmware

Products

Connectrix MDS-Series Hardware
Article Properties
Article Number: 000227523
Article Type: Solution
Last Modified: 14 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.