PowerScale: Logowanie SSH do węzłów PowerScale przy użyciu poświadczeń domeny usługi Windows Active Directory kończy się niepowodzeniem z błędem "Access Denied"

Summary: Logowanie SSH do nowo dodanych węzłów PowerScale nie powiodło się z poświadczeniami usługi Active Directory, mimo że dostawca uwierzytelniania jest w trybie online na węzłach PowerScale. Te same poświadczenia działają prawidłowo w portalu logowania do interfejsu internetowego ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Logowanie SSH do węzłów PowerScale przy użyciu poświadczeń usługi Active Directory kończy się niepowodzeniem z powodu błędu "Access Denied". 

Cause

W PowerScale dostawca uwierzytelniania ma przypisaną inną powłokę logowania niż powłoka logowania przypisana do konta użytkownika w usłudze Active Directory.
Zobacz poniższy przykład.
  • Zaloguj się do powłoki w klastrze PowerScale przypisanym do dostawcy uwierzytelniania w usłudze Active Directory.   
Clustrername-1# isi auth ads list -v | grep -i shell
Login Shell:/bin/zsh
  • Powłoka logowania przypisana do konta użytkownika w domenie usługi Active Directory sprawdzana z poziomu programu Windows PowerShell 
Get-ADuser ‘username” -Properties loginshell
Loginshell : /usr/bin/ksh

Ze względu na niezgodność powłoki logowania przypisanej do konta użytkownika w usłudze Active Directory i dostawcy uwierzytelniania w PowerScale uwierzytelnianie oparte na domenie nie działa podczas logowania SSH/CLI.

Resolution

Wykonaj poniższą procedurę, aby rozwiązać problem, tworząc łącze symboliczne między powłokami logowania przypisanymi do konta użytkownika usługi Active Directory i dostawcy uwierzytelniania PowerScale.
1. Sprawdź powłokę logowania na platformie Isilon/Powerscale dla dostawcy uwierzytelniania.
   
 isi auth ads list -v | grep -i shell
      Login Shell: /bin/zsh

2. Sprawdź powłokę logowania przypisaną do usługi Active Directory dla konta użytkownika. 
  • Uruchom program PowerShell z komputera z systemem Windows. 
  • Uruchom poniższe polecenie w programie PowerShell      
     Get-ADuser 'ADusername" -Properties login shell
  •  Sprawdź szczegóły powłoki logowania z danych wyjściowych powyższego polecenia, a wyświetli się coś podobnego do poniższego.          
   Loginshell: /usr/bin/ksh

3. Utwórz dowiązanie symboliczne między powłoką logowania przypisaną do dostawcy uwierzytelniania PowerScale a kontem użytkownika w usłudze AD za pomocą poniższego polecenia w PowerScale.
 
    isi_for_array "ln -s /bin/zsh /usr/bin/ksh"

4. Zaloguj się do Isilon/Powerscale za pomocą SSH przy użyciu poświadczeń usługi Active Directory.

Affected Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000227825
Article Type: Solution
Last Modified: 19 Sep 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.