PowerFlex : Erreurs d’IO du client lors de l’utilisation de la réplication

Summary: Les clients/serveurs rencontrent des erreurs d’E/S sur les appareils soutenus par PowerFlex. Le back-end global (MDM/SDS) semble fonctionnel. La réplication PowerFlex est en cours d’utilisation et il existe des erreurs de RPO sur un ou plusieurs des RCG. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Aucune capacité dégradée ou défaillante
  • Aucun SDS n’est découplé ou aucun appareil SDS ne signale d’erreur.
  • Aucun MDM déconnecté

La fonctionnalité de réplication est en cours d’utilisation.
Une ou plusieurs alertes dans l’interface utilisateur signalent les erreurs suivantes :

Major - The RCG consistent image is too large to be consumed by the destination in one piece.

Minor - Remote Consistency Group RPO Exceeded
Les journaux d’événements MDM peuvent signaler les éléments suivants :
2024-06-11 15:55:56.592000:0001566:RPL_PD_CAP_UTILIZATION_MINOR     WARNING  Protection Domain ID <pd_id> Replication journal capacity is at MINOR utilization level
2024-06-11 16:20:12.848000:0001567:RPL_PD_CAP_UTILIZATION_MAJOR     ERROR    Protection Domain ID <pd_id> Replication journal capacity is at MAJOR utilization level
2024-06-11 17:19:57.272000:0001584:RPL_PD_CAP_UTILIZATION_CRITICAL  CRITICAL Protection Domain ID <pd_id> Replication journal capacity is at VERY_HIGH utilization level
2024-06-11 17:52:26.352000:0001585:RPL_PD_CAP_UTILIZATION_CRITICAL  CRITICAL Protection Domain ID <pd_id> Replication journal capacity is at CRITICAL utilization level
...
2024-06-11 16:25:14.381000:0001576:RPL_CG_MOVED_TO_SLIM_MODE        INFO     Replication Consistency Group ID <rcg_id> entered slim mode
2024-06-11 18:27:29.738000:0001586:SDR_CRITICAL_CAP_CHANGE          ERROR    SDR ID <sdr_id>) handling user data changed discarded old user data and stopped to accumulate new user data due critical capacity
 

Impact 

Les clients ne peuvent pas accéder aux volumes qui sont interceptés pour la réplication.


Cause

Un défaut logiciel rare peut se produire lorsque le MDM et le composant SDR ne sont pas d’accord sur les compteurs internes liés à la capacité du journal. Cette différence peut entraîner l’annulation de l’allocation de capacité de journal supplémentaire du MDM lorsque la capacité du SDR est saturée, ce qui peut entraîner des erreurs d’E/S sur les clients/serveurs utilisant des appareils sauvegardés par PowerFlex.

Resolution

Un redémarrage répété de tous les composants SDR est nécessaire, et la propriété du MDM sur le système source doit être basculée pour résoudre le problème.

Redémarrez les composants SDR :

1) Identifiez tous les SDR :

scli --query_all_sdr

2) Passez en mode maintenance sur le SDR :

scli --enter_sdr_maintenance_mode --sdr_name <name>

3) Vérifiez que le SDR est entièrement en mode maintenance en exécutant la commande à l’étape 1.

4) Redémarrez le composant SDR.

pkill sdr

5) Répétez cette opération pour tous les SDR sur le site source.
 

Une fois tous les SDR redémarrés, changez la propriété du MDM :

#3.x
scli --switch_mdm_ownership --new_master_mdm_name <name>
 
#4.x
scli --switch_mdm_ownership --new_primary_mdm_name <name>

*Si vous le souhaitez, la propriété peut être transférée vers le serveur MDM d’origine.

Vérifiez que les erreurs d’E/S sur le client/serveur ne sont plus signalées. Si le client est entré dans un système de fichiers en lecture seule, le client/serveur peut nécessiter un redémarrage.

Jusqu’à ce que la cause puisse être déterminée, il est également recommandé de suspendre tous les RCG sur le système source.

Si les erreurs d’E/S persistent après l’application des étapes ci-dessus, contactez l’équipe d’ingénierie PowerFlex.

Additional Information

Versions affectées

PowerFlex 3.x

PowerFlex 4.x

Problème résolu dans la version

PFMP 4.5.3

Affected Products

PowerFlex Software
Article Properties
Article Number: 000227849
Article Type: Solution
Last Modified: 17 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.