VMware View ha esito negativo con errore "Unable to fetch data from vCenter: Errore TCP/UDP IP -1"
Summary: L'integrazione NetWorker VMware Protection (NVP) è configurata con l'appliance vProxy. VMware View ha iniziato a non aggiornarsi con il messaggio "TCP/UDP IP ERROR -1".
Symptoms
L'esecuzione dell'aggiornamento di VMware View di NetWorker Management Console (NMC) genera il seguente messaggio di errore:
È possibile esaminare /nsr/logs/daemon.raw I registri mostrano:
MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg NSR notice MM/DD/YYYY HH:MM:SS 0 16 nsrdisp_nwbg-D0 Running nsrvim.... MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: nsrvim starting on my-nsr.domain.com (process 212775). MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: Connecting to NetWorker on 'my-nsr.domain.com'. MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: Querying NSR hypervisor resource 'my-vcenter.domain.com' MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: Connecting to service at https://my-vcenter.domain.com/sdk MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: TCP/UDP IP error -1 MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: nsrvim exiting on my-nsr.domain.com (process 212775). MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP error 37 Unable to fetch data from vCenter: TCP/UDP IP error -1 MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP error 37 Unable to fetch data from vCenter: TCP/UDP IP error -1 MM/DD/YYYY HH:MM:SS 2300032768 2127235 0 my-nsr.domain.com nsrdisp_nwbg NSR warning 96 Unable to get the latest environment for my-vcenter.domain.com Hypervisor resource from previous run of 'nsrvim'.
NetWorker: Come utilizzare nsr_render_log per eseguire il rendering .raw file
di logLa risoluzione dei nomi (nome breve, nome di dominio completo e indirizzo IP) tra il server NetWorker e il vCenter Server funziona come previsto. I test di connettività delle porte mostrano una connessione riuscita dal server NetWorker a vCenter sulla porta 443:
[root@my-nsr /]# nsrports -t my-vcenter.domain.com -p 443 Forward lookup for my-vcenter.domain.com Query time: 0.001 sec Canonical name (CNAME): my-vcenter.domain.com Address (A): 192.168.9.1 Connect to port 443: Succeeded (0.000 sec) Reverse lookup for 192.168.9.1 Query time: 0.000 sec Name: my-vcenter.domain.com [root@my-nsr /]# curl -v my-vcenter.domain.com:443 * Trying 192.168.9.1:443... * Connected to my-vcenter.domain.com (192.168.9.1) port 443 (#0) > GET / HTTP/1.1 > Host: my-vcenter.domain.com:443 > User-Agent: curl/7.76.1 > Accept: */* > * Empty reply from server * Closing connection 0 curl: (52) Empty reply from server [root@nsr logs]#
L'esecuzione binaria di NetWorker VMware Inventory Manager (nsrvim) con livello di debug 9 mostra:
[root@my-nsr /]# nsrvim --names my-vcenter.domain.com -D 9 ... MM/DD/YYYY HH:MM:SS nsrvim-D1 Virtualization library fault 'TCP/UDP IP error -1' [get host by name failed in tcp_connect()]. ... MM/DD/YYYY HH:MM:SS nsrvim-D1 nsrvim finished with code: 2
Cause
Il flusso di lavoro VMware View del server NetWorker tenta innanzitutto di risolvere il vCenter utilizzando il comando /etc/hosts prima di utilizzare il DNS (Domain Name System). Il sistema operativo Linux è danneggiato /etc/hosts che impedisce al flusso di lavoro NetWorker VMware View di ottenere i dettagli corretti di vCenter. In un caso, il server Linux /etc/hosts Il file conteneva caratteri speciali aggiuntivi che in genere non si trovano in un file predefinito:
Resolution
La colonna /etc/hosts Il file deve essere aggiornato in modo da riflettere il contenuto di un file standard. Assicurarsi che un backup di /etc/hosts prima di eseguire qualsiasi aggiornamento. Se è necessaria ulteriore assistenza, contattare il supporto per la distribuzione del sistema operativo Linux.