VMware View échoue avec l’erreur « Impossible d’extraire les données du vCenter : Erreur IP TCP/UDP -1"
Summary: L’intégration NetWorker VMware Protection (NVP) est configurée avec l’appliance vProxy. L’actualisation de VMware View a commencé à échouer avec le message « TCP/UDP IP error -1 ».
Symptoms
L’exécution de l’actualisation de la vue VMware NetWorker Management Console (NMC) génère le message d’erreur suivant :
Le fichier /nsr/logs/daemon.raw La section Logs affiche les éléments suivants :
MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg NSR notice MM/DD/YYYY HH:MM:SS 0 16 nsrdisp_nwbg-D0 Running nsrvim.... MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: nsrvim starting on my-nsr.domain.com (process 212775). MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: Connecting to NetWorker on 'my-nsr.domain.com'. MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: Querying NSR hypervisor resource 'my-vcenter.domain.com' MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: Connecting to service at https://my-vcenter.domain.com/sdk MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: TCP/UDP IP error -1 MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: nsrvim exiting on my-nsr.domain.com (process 212775). MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP error 37 Unable to fetch data from vCenter: TCP/UDP IP error -1 MM/DD/YYYY HH:MM:SS 2992023296 2127139 0 my-nsr.domain.com nsrdisp_nwbg RAP error 37 Unable to fetch data from vCenter: TCP/UDP IP error -1 MM/DD/YYYY HH:MM:SS 2300032768 2127235 0 my-nsr.domain.com nsrdisp_nwbg NSR warning 96 Unable to get the latest environment for my-vcenter.domain.com Hypervisor resource from previous run of 'nsrvim'.
NetWorker : Utilisation de nsr_render_log pour le rendu des fichiers
journaux .rawLa résolution de noms (nom abrégé, nom de domaine complet et adresse IP) entre NetWorker Server et vCenter Server fonctionne comme prévu. Les tests de connectivité des ports indiquent une connexion réussie entre NetWorker Server et vCenter sur le port 443 :
[root@my-nsr /]# nsrports -t my-vcenter.domain.com -p 443 Forward lookup for my-vcenter.domain.com Query time: 0.001 sec Canonical name (CNAME): my-vcenter.domain.com Address (A): 192.168.9.1 Connect to port 443: Succeeded (0.000 sec) Reverse lookup for 192.168.9.1 Query time: 0.000 sec Name: my-vcenter.domain.com [root@my-nsr /]# curl -v my-vcenter.domain.com:443 * Trying 192.168.9.1:443... * Connected to my-vcenter.domain.com (192.168.9.1) port 443 (#0) > GET / HTTP/1.1 > Host: my-vcenter.domain.com:443 > User-Agent: curl/7.76.1 > Accept: */* > * Empty reply from server * Closing connection 0 curl: (52) Empty reply from server [root@nsr logs]#
L’exécution binaire de NetWorker VMware Inventory Manager (nsrvim) avec le niveau de débogage 9 affiche les éléments suivants :
[root@my-nsr /]# nsrvim --names my-vcenter.domain.com -D 9 ... MM/DD/YYYY HH:MM:SS nsrvim-D1 Virtualization library fault 'TCP/UDP IP error -1' [get host by name failed in tcp_connect()]. ... MM/DD/YYYY HH:MM:SS nsrvim-D1 nsrvim finished with code: 2
Cause
Le workflow NetWorker Server VMware View tente d’abord de résoudre le vCenter à l’aide de /etc/hosts avant d’utiliser le DNS (Domain Name System). Le système d’exploitation Linux est corrompu /etc/hosts Fichier qui empêche le workflow NetWorker VMware View d’obtenir les informations vCenter appropriées. Dans un cas, le Linux /etc/hosts Le fichier contenait des caractères spéciaux supplémentaires qui ne figurent généralement pas dans un fichier par défaut :
Resolution
La commande /etc/hosts doit être mis à jour pour refléter le contenu d’un fichier standard. Assurez-vous qu’une sauvegarde du fichier /etc/hosts file est supprimé avant d’exécuter des mises à jour. Si vous avez besoin d’une aide supplémentaire, contactez le support de distribution du système d’exploitation Linux.