Avamar:Exchangeデータベースのリストアが、バックアップでデータベースが見つからないことを示すavtarエラーで失敗する

Summary: この記事では、Exchangeデータベースで大文字と小文字の区別が一致しないため発生するExchangeリストアの問題について説明します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

シナリオ:
  • 要件は、Exchangeデータベースをリストアすることです。この例では、これを「Database4」と呼びます。
  • データベースのリストア プロセスは失敗し、Database4パスがバックアップ ピースに見つからないことを示すメッセージがログに表示されますが、データベースはAvamarユーザー インターフェイス(GUIとAUI)の両方でリストアに使用できます。
  •  リストア ログに表示されるエラー メッセージのタイプは次のとおりです。
avtar Error <5195>: Path "EX-Node3_00000000\H:\mountpoints\Database4\Database4.edb" not found in backup. (Element 'Database4.edb' at position 3 in search path 'EX-Node3_00000000\H:\mountpoints\Database4\Database4.edb' not found) 
  • 同じバックアップ ピースと同じExchange Serverから別のデータベース(Database2など)をリストアすると、正常に機能します。 

Cause

Exchange環境には、Microsoftがサポートする非標準のデータベース構成がありますが、Avamar製品でこの問題が発生することが知られています。

このシナリオでは、影響を受けるデータベース(Database4)のデータベース ファイル パスで大文字と小文字の区別が一致しません。
OSの「データベース ストレージ パス」とExchangeアプリケーションの「データベースの場所のパス」の間に不整合があります
 
影響を受けるデータベースの例(Database4):
パスの不一致:
  • DBのOSパスは、大文字(文字MおよびP)の「Mount Point」フォルダーを使用して作成されました
H:\MountPoints\Database4\Database4.edb
  • Exchange アプリケーションの Database4 パスは、すべて小文字で構成されました。
H:\mountpoints\Database4\Database4.edb

影響を受けないデータベースの例(Database2):
OSデータベースのパスとExchange構成内の対応するパスの大文字と小文字の区別は同じです。
  • データベース ストレージ パス
H:\MountPoints\Database2\Database2.edb
  • データベースの場所のパス
H:\MountPoints\Database2\Database2.edb
 
注:大文字と小文字の不一致は、そのパスの他のレベルに存在する可能性があります。この例では、マウント ポイント レベルで確認されています。

これらのパスを確認するには、次の手順を実行します。
  • Windowsエクスプローラーを使用してOSパスを確認します
  • Exchange 管理センター (EAC) を使用してデータベース構成を確認する
    • => servers/databases/<edit プロパティ>
      • または、Exchange Powershellコマンドを使用します。
Get-MailboxDatabase -Identity <affected DB name> | Select-Object edbfilepath, logfolderpath | fl

大文字と小文字が一致しない状態では、Avamarプロセス(avtar)がバックアップ プロセス中にバックアップ メタデータに誤ったデータベース情報を記録します。

リストア時に、avtarプロセスは正しいデータベースのパスを識別しません。そのため、「database not found in backup」というメッセージを出力してデータベースをリストアできません

Resolution

このデータベースの大文字と小文字の不一致の状況を解決するために、Avamar製品は、これらのタイプのシナリオを処理する「--use-case-sensitive-paths」というフラグを使用してカウントします。
  • バックアップ プロセスに参加するすべてのExchange DAGノードで、Avamar Clientのvarフォルダー(デフォルト パス「C:\Program Files\avs\var\」)の下にある「avexvss.cmd」ファイルにフラグを追加する必要があります。
  • また、DAG統合バックアップの場合は、クラスター クライアントのvarディレクトリーの下にある「avexvss.cmd」ファイルにフラグを追加する必要があります
    • これはDAGノード間で共有されるUNCパスであり、バックアップを調整し、DAGクライアントの構成とログ ファイルを格納するために必要です
      UNCパスの例 "\\share-server\share-folder\DAGname\var\")
  • フラグ値は「false」に設定する必要があります(デフォルト値は「true」)。
    • --use-case-sensitive-paths=false
注意:重要な注意点
  • フラグがプロキシ ノード(IPレスDAG構成)またはクラスター クライアント(フェデレーション構成)にのみ追加されている場合、バックアップは成功しますが、リストアは失敗する可能性があります。
  • したがって、バックアップ プロセスに参加している(DAGクラスターの)すべてのExchangeノードに前述のフラグを追加することが重要です。
 
このフラグを「false」に設定すると、今後のすべてのバックアップに影響が及ばず、これらの新しいバックアップのリストアが正常に行われます

古いバックアップは、このフラグを使用して修正されないため、特別な手順でリストアする必要があります。

この特別な手順については、「Avamar: データベース パスの大文字と小文字の不一致の問題の影響を受けるバックアップからExchangeデータベースをリストアする方法。

Additional Information

  • 大文字と小文字が一致しないExchange環境で前述のフラグを使用しない場合、バックアップは次のエラーで失敗する可能性があります。
avtar Error <7042>: Failed to create snapview, as one of the elements required for path "XXXXXXXXX.edb" not found in backup account '/XXXXXX' lablenum 3 (only found 'XXXX\E:' of path 'XXXX.edb').

Affected Products

Avamar Plug-in for Exchange VSS

Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000228153
Article Type: Solution
Last Modified: 03 Sep 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.