Avamar: Niepowodzenie przywracania bazy danych Exchange z błędem avtar informującym, że nie znaleziono bazy danych w kopii zapasowej

Summary: Ten artykuł dotyczy problemu z przywracaniem programu Exchange z powodu niezgodności wielkości liter w bazach danych programu Exchange.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenariusz:
  • Wymaganiem jest przywrócenie bazy danych programu Exchange, którą w tym przykładzie nazywamy "Baza danych4".
  • Proces przywracania bazy danych kończy się niepowodzeniem z komunikatem w dzienniku informującym, że ścieżka bazy danych4 nie została znaleziona we fragmencie kopii zapasowej, jednak baza danych jest dostępna do przywrócenia w obu interfejsach użytkownika Avamar (GUI i AUI).
  •  Oto typ komunikatu o błędzie wyświetlany w dzienniku przywracania:
avtar Error <5195>: Path "EX-Node3_00000000\H:\mountpoints\Database4\Database4.edb" not found in backup. (Element 'Database4.edb' at position 3 in search path 'EX-Node3_00000000\H:\mountpoints\Database4\Database4.edb' not found) 
  • Przywracanie innej bazy danych (na przykład bazy danych2) z tego samego elementu kopii zapasowej i tego samego serwera Exchange działa zgodnie z oczekiwaniami. 

Cause

Środowisko Exchange przedstawia niestandardową konfigurację bazy danych obsługiwaną przez firmę Microsoft, ale wiadomo, że powoduje ten problem w produkcie Avamar.

W tym scenariuszu baza danych, której dotyczy problem, (Database4) przedstawia niespójną wielkość liter w ścieżce pliku bazy danych.
Istnieje niezgodność między "ścieżką przechowywania bazy danych" systemu operacyjnego a "ścieżką lokalizacji bazy danych" aplikacji Exchange"Przykład bazy danych, której dotyczy problem (Baza danych4

):
Niezgodność ścieżek: 
  • Ścieżka systemu operacyjnego dla baz danych została utworzona z folderem "Mount Point" zapisanym wielkimi literami (litery M i P)
H:\MountPoints\Database4\Database4.edb
  • Ścieżka Database4 w aplikacji Exchange została skonfigurowana tak, aby wszystkie litery były pisane małymi literami:
H:\mountpoints\Database4\Database4.edb

Przykład bazy danych, której nie dotyczy problem (Database2):
Ścieżka bazy danych systemu operacyjnego i odpowiadająca jej ścieżka w konfiguracji programu Exchange mają tę samą wielkość liter:
  • Ścieżka przechowywania bazy danych
H:\MountPoints\Database2\Database2.edb
  • Ścieżka lokalizacji bazy danych
H:\MountPoints\Database2\Database2.edb
 
Uwaga: Niezgodność wielkości liter może występować na innych poziomach tej ścieżki, w tym przykładzie była widoczna na poziomie punktu montowania.

Aby sprawdzić te ścieżki:
  • Sprawdź ścieżkę systemu operacyjnego za pomocą Eksploratora Windows
  • Użyj centrum administracyjnego programu Exchange (EAC), aby sprawdzić konfigurację bazy danych
    • >= serwery/bazy danych/edytuj właściwości bazy danych,< której dotyczy problem>
      • Możesz także użyć polecenia Exchange PowerShell:
Get-MailboxDatabase -Identity <affected DB name> | Select-Object edbfilepath, logfolderpath | fl

Stan niezgodności wielkości liter powoduje, że proces Avamar (avtar) rejestruje nieprawidłowe informacje o bazie danych w metadanych kopii zapasowej podczas procesu tworzenia kopii zapasowej.

W czasie przywracania proces avtar nie identyfikuje poprawnej ścieżki do bazy danych. W związku z tym nie można przywrócić bazy danych, wyświetlając komunikat "nie znaleziono bazy danych w kopii zapasowej"

Resolution

Aby rozwiązać problem niezgodności wielkości liter w tej bazie danych, produkt Avamar jest zliczany z flagą o nazwie "--use-case-sensitive-paths", która zajmuje się tego typu scenariuszami.
  • Flagę należy dodać do pliku "avexvss.cmd" w folderze var klienta Avamar (domyślna ścieżka "C:\Program Files\avs\var\") we wszystkich węzłach DAG Exchange, które uczestniczą w procesie tworzenia kopii zapasowej.
  • Ponadto w przypadku federacyjnych kopii zapasowych DAG flagę należy dodać w pliku "avexvss.cmd" w katalogu var klienta klastra
    • Jest to ścieżka UNC współużytkowana przez węzły DAG i jest potrzebna do koordynowania kopii zapasowych oraz przechowywania konfiguracji klienta DAG i plików
      dziennika Przykład ścieżki UNC: "\\share-server\share-folder\nazwa_DAG\var\")
  • Wartość flagi musi być ustawiona na "false" (jej wartość domyślna to "true"):
    • --use-case-sensitive-paths=false
Przestroga: Ważna uwaga
  • Jeśli flaga jest dodawana tylko do węzła proxy (w konfiguracji DAG bez adresów IP) lub klienta klastra (w konfiguracji federacyjnej), tworzenie kopii zapasowej powiedzie się, ale przywracanie może zakończyć się niepowodzeniem z tym samym problemem.
  • Dlatego ważne jest, aby dodać wspomnianą flagę w każdym węźle Exchange (klastra DAG) uczestniczącym w procesie tworzenia kopii zapasowej.
 
Ustawienie tej flagi jako "false" gwarantuje, że nie będzie to miało wpływu na żadne przyszłe kopie zapasowe, a przywracanie tych nowych kopii zapasowych zakończy się pomyślnie.

Starsze kopie zapasowe nie są naprawiane przy użyciu tej flagi i wymagają specjalistycznej procedury w celu przywrócenia.

Ta specjalna procedura została opisana w aplikacji Avamar: Przywracanie bazy danych Exchange z kopii zapasowej, której dotyczy problem niezgodności wielkości liter w ścieżce bazy danych.

Additional Information

  • Jeśli wspomniana flaga nie jest używana w środowisku Exchange, w którym występuje niezgodność wielkości liter, tworzenie kopii zapasowej może zakończyć się niepowodzeniem z następującym błędem:
avtar Error <7042>: Failed to create snapview, as one of the elements required for path "XXXXXXXXX.edb" not found in backup account '/XXXXXX' lablenum 3 (only found 'XXXX\E:' of path 'XXXX.edb').

Affected Products

Avamar Plug-in for Exchange VSS

Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000228153
Article Type: Solution
Last Modified: 03 Sep 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.