Авамар: Не вдалося відновити базу даних Exchange із помилкою avtar про те, що базу даних не знайдено в резервній копії

Summary: У цій статті вирішено проблему відновлення Exchange через невідповідність регістру в базах даних Exchange.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Сценарій:
  • Вимога полягає в тому, щоб відновити базу даних Exchange, яку ми називаємо «База даних4» у цьому прикладі.
  • Процес відновлення бази даних зазнає невдачі з повідомленням у журналі про те, що шлях до Database4 не знайдено в резервній копії, однак база даних доступна для відновлення в обох інтерфейсах користувача Avamar (GUI та AUI).
  •  Ось такий тип повідомлення про помилку відображається в журналі відновлення:
avtar Error <5195>: Path "EX-Node3_00000000\H:\mountpoints\Database4\Database4.edb" not found in backup. (Element 'Database4.edb' at position 3 in search path 'EX-Node3_00000000\H:\mountpoints\Database4\Database4.edb' not found) 
  • Відновлення іншої бази даних (наприклад, Database2) з тієї ж резервної копії та того самого сервера Exchange працює належним чином. 

Cause

Середовище Exchange представляє нестандартну конфігурацію бази даних, яку підтримує Microsoft, але відомо, що вона спричиняє цю проблему для продукту Avamar.

У цьому сценарії уражена база даних (Database4) демонструє непослідовну капіталізацію регістру в шляху до файлу бази даних.
Існує невідповідність між ОС "шлях зберігання бази даних" і "шлях розташування бази даних" програми Exchange"
 
Приклад ураженої бази даних (Database4):
Невідповідність шляхів:
  • Шлях ОС для БД створювався з папкою "Точка монтування" у верхніх регістрах (літери М та П)
H:\MountPoints\Database4\Database4.edb
  • Шлях до Database4 в додатку Exchange був налаштований з усіма буквами в нижньому регістрі:
H:\mountpoints\Database4\Database4.edb

Приклад незачепленої бази даних (Database2):
Шлях до бази даних ОС і відповідний шлях у конфігурації Exchange мають однакову капіталізацію регістру:
  • Шлях до зберігання бази даних
H:\MountPoints\Database2\Database2.edb
  • Шлях до розташування в базі даних
H:\MountPoints\Database2\Database2.edb
 
Примітка: Невідповідність регістру могла існувати і на інших рівнях цього шляху, в цьому прикладі це було видно на рівні точки монтування.

Щоб перевірити ці шляхи:
  • Використовуйте Провідник Windows , щоб перевірити шлях до ОС
  • За допомогою Центру адміністрування Exchange (EAC) перевірте конфігурацію бази даних
    • >= сервери/бази даних/<редагування властивостей ураженої БД>
      • Або скористайтеся командою Exchange Powershell:
Get-MailboxDatabase -Identity <affected DB name> | Select-Object edbfilepath, logfolderpath | fl

Умова невідповідності регістру призводить до того, що процес Avamar (avtar) записує неправильну інформацію з бази даних у метадані резервної копії під час процесу резервного копіювання.

Під час відновлення процес avtar не визначає правильний шлях до бази даних. Тому відновити базу даних не вдається шляхом друку повідомлення "база даних не знайдена в резервній копії"

Resolution

Щоб вирішити ситуацію невідповідності регістрів цієї бази даних, продукт Avamar враховується з прапорцем під назвою "--use-case-sensitive-paths", який піклується про ці типи сценаріїв.
  • Прапорець повинен бути доданий у файл "avexvss.cmd" під папкою var клієнта Avamar (шлях за замовчуванням "C:\Program Files\avs\var\") у всіх вузлах Exchange DAG, які беруть участь у процесі резервного копіювання.
  • Крім того, для об'єднаних резервних копій DAG прапорець повинен бути доданий у файлі "avexvss.cmd" під директорією var клієнта Cluster
    • Це шлях UNC, який використовується між вузлами DAG і необхідний для координації резервних копій та зберігання конфігурації клієнта DAG і файлів
      журналів Приклад шляху UNC "\\share-server\share-folder\DAGname\var\")
  • Значення прапорця має бути встановлено як "false" (його значення за замовчуванням "true"):
    • --use-case-sensitive-paths=false
Обережність: Важливе зауваження
  • Якщо прапорець додано лише до проксі-вузла (у конфігурації DAG без IP) або клієнта кластера (у об'єднаній конфігурації), резервне копіювання буде успішним, але відновлення може не вирішити ту саму проблему.
  • Тому важливо додати згаданий прапорець у кожен вузол Exchange (кластера DAG), що бере участь у процесі резервного копіювання.
 
Встановлення цього прапорця як "false" гарантує, що це не вплине на всі майбутні резервні копії, і що відновлення цих нових резервних копій буде успішним.

Старі резервні копії не виправляються за допомогою цього прапора і вимагають спеціалізованої процедури для відновлення.

Ця особлива процедура описана в Avamar: Як відновити базу даних Exchange із резервної копії, на яку впливає проблема невідповідності регістру шляху до бази даних.

Additional Information

  • Якщо зазначений прапорець не використовується в середовищі Exchange, яке представляє невідповідність капіталізації випадку, резервне копіювання може завершитися помилкою з такою помилкою:
avtar Error <7042>: Failed to create snapview, as one of the elements required for path "XXXXXXXXX.edb" not found in backup account '/XXXXXX' lablenum 3 (only found 'XXXX\E:' of path 'XXXX.edb').

Affected Products

Avamar Plug-in for Exchange VSS

Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000228153
Article Type: Solution
Last Modified: 03 Sep 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.