RecoverPoint for VM: 5.3.4.1 및 6.0.1.x의 스플리터는 DCUI 로그인 요청을 생성합니다.

Summary: 스플리터 VIB를 5.3.4.1로 업그레이드하거나 6.0.1.x 버전을 설치한 후 스플리터 프로세스는 vCenter에서 많은 DCUI 로그인 요청을 생성합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

RecoverPoint Splitter/Kdriver VIB를 5.3.4.1 버전으로 업그레이드한 후 kdriver는 vCenter에서 많은 DCUI 로그인 요청을 생성합니다.

영향을 받는 ESXi 호스트의 /scratch/log/kdriver.log.* 에서:

2024/08/21 14:39:51.268 - #2 - 4561369/4561352 - HostIPDiscoveryMgr_AO_IMPL:  rpEsxInfoScan: /opt/emc/rp/kdriver/bin/rp_rpa_discovery.sh --scan-props & executed successfully
2024/08/21 14:40:26.444 - #2 - 4561369/4561352 - HostIPDiscoveryMgr_AO_IMPL:  rpEsxInfoScan: /opt/emc/rp/kdriver/bin/rp_rpa_discovery.sh --scan-props & executed successfully


영향을 받는 ESXi 호스트의 var/log/hostd.log에서:

2024-08-18T23:32:18.395Z info hostd[2101236] [Originator@6876 sub=Default opID=esxcli_name] Accepted password for user dcui from 127.0.0.1
2024-08-18T23:32:18.395Z warning hostd[2101236] [Originator@6876 sub=Vimsvc opID=esxcli_name] Refresh function is not configured.User data can't be added to scheduler.User name: dcui
2024-08-18T23:32:18.395Z info hostd[2101236] [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli_name] Event 125221 : User dcui@127.0.0.1 logged in as pyvmomi Python/3.8.18 (VMkernel 7.0.3 x86_64)
2024-08-18T23:32:18.466Z info hostd[2100837] [Originator@6876 sub=Solo.VmwareCLI opID=esxcli_name user=dcui] Dispatch list
2024-08-18T23:32:18.475Z info hostd[2100837] [Originator@6876 sub=Solo.VmwareCLI opID=esxcli_name user=dcui] Dispatch list done


RecoverPoint 스플리터를 6.0.1.x 버전으로 설치하거나 업그레이드한 후 vCenter에서 많은 DCUI(Direct Console User Interface) 로그인 요청이 생성됩니다.

영향을 받는 ESXi 호스트의 /scratch/log/iofilterd-emcsplitter.log 에서:

2024-08-16T08:24:40.578Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced list -o "/UserVars/RP_IP_Discovery_8" | grep "\s\s\sString Value:" | awk -F "String Value: " {'print $2'}'
2024-08-16T08:24:41.145Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced list -o "/UserVars/RP_IP_Discovery_9" | grep "\s\s\sString Value:" | awk -F "String Value: " {'print $2'}'
2024-08-16T08:24:41.473Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced set -o "/UserVars/emcsplitter_clusters" -s ""'
2024-08-16T08:24:41.720Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced list -o "/UserVars/RP_IP_Discovery_10" | grep "\s\s\sString Value:" | awk -F "String Value: " {'print $2'}'




영향을 받는 ESXi 호스트의 var/log/hostd.log에서:

 

2024-08-16T08:24:40.538Z In(166) Hostd[2099945]: [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli-ed-6cca sid=52e328a0 user=dcui] Event 2652729 : User dcui@127.0.0.1 logged out (login time: Friday, 16 August, 2024 08:24:40 AM, number of API invocations: 7, user agent: pyvmomi Python/3.8.16 (VMkernel; 8.0.1; x86_64))
2024-08-16T08:24:41.059Z In(166) Hostd[2099964]: [Originator@6876 sub=Vimsvc.HaSessionManager opID=esxcli-hostname sid=5284e077] Accepted password for user dcui from 127.0.0.1 - session=5284e077-ac72-8d89-47b2-38feba5f8354
2024-08-16T08:24:41.059Z Wa(164) Hostd[2099964]: [Originator@6876 sub=Vimsvc opID=esxcli-hostname sid=5284e077] Refresh function is not configured.User data can't be added to scheduler.User name: dcui
2024-08-16T08:24:41.059Z In(166) Hostd[2099964]: [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli-hostname sid=5284e077] Event 2652730 : User dcui@127.0.0.1 logged in as pyvmomi Python/3.8.16 (VMkernel; 8.0.1; x86_64)
2024-08-16T08:24:41.109Z In(166) Hostd[2099943]: [Originator@6876 sub=Solo.VmwareCLI opID=esxcli-8f-6cd7 sid=5284e077 user=dcui] Dispatch system.settings.advanced.list
2024-08-16T08:24:41.111Z In(166) Hostd[2099943]: [Originator@6876 sub=Solo.VmwareCLI opID=esxcli-8f-6cd7 sid=5284e077 user=dcui] Dispatch system.settings.advanced.list done
2024-08-16T08:24:41.114Z In(166) Hostd[2099957]: [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli-8f-6cd8 sid=5284e077 user=dcui] Event 2652731 : User dcui@127.0.0.1 logged out (login time: Friday, 16 August, 2024 08:24:41 AM, number of API invocations: 7, user agent: pyvmomi Python/3.8.16 (VMkernel; 8.0.1; x86_64))
2024-08-16T08:24:41.630Z In(166) Hostd[2099938]: [Originator@6876 sub=Vimsvc.HaSessionManager opID=esxcli-hostname sid=520464cb] Accepted password for user dcui from 127.0.0.1 - session=520464cb-08ef-ad94-d4dd-4d02abaf0937
2024-08-16T08:24:41.630Z Wa(164) Hostd[2099938]: [Originator@6876 sub=Vimsvc opID=esxcli-hostname sid=520464cb] Refresh function is not configured.User data can't be added to scheduler.User name: dcui



이 로그인 및 로그아웃 호출에 환경에 있는 호스트 수를 곱합니다. vCenter에서 여러 이벤트를 생성하므로 /seat 파티션이 가득 차서 vCenter가 응답하지 않을 수 있습니다.

Cause

5.3.4.1 버전

RecoverPoint 버전 5.3.4.1에서 rp_rpa_discovery.sh 스플리터/kdriver VIB에 추가되었습니다. 이 스크립트는 기본적으로 35초마다 실행되어 예약된 일정에 따라 ESXi 호스트 세부 정보를 검색하도록 설계되었습니다.

이 스크립트는 DCUI 호출을 사용하여 각 호스트에 필요한 값을 수집하여 vCenter의 각 호스트에 대해 빈번한 로그인 및 로그아웃 요청을 생성합니다. ESXi에서 실행되는 각 명령은 vCenter의 데이터베이스에 로깅되고 데이터베이스(/seat)가 포함된 스토리지 파티션이 가득 찰 수 있습니다. 이로 인해 vCenter가 비정상적으로 동작할 수 있습니다.

이 문제의 영향은 vCenter에서 실행 중인 호스트 수에 따라 달라집니다. 호스트가 많을수록 파티션이 더 빨리 채워져 VXPD 서비스가 충돌할 수 있습니다.

이 동작은 버전 7.0.x를 실행하는 호스트에 영향을 줍니다.

6.0.1.x 버전

RecoverPoint 버전 6.0.1.x에서 RecoverPoint는 DCUI와 함께 esxcli 명령을 사용하여 시스템 정보를 가져옵니다. 이러한 호출은 각 호스트에 필요한 값을 수집하여 vCenter의 각 호스트에 대해 빈번한 로그인 및 로그아웃 요청을 생성합니다. ESXi에서 실행되는 각 명령은 vCenter의 데이터베이스에 로깅되고 데이터베이스(/seat)가 포함된 스토리지 파티션이 가득 찰 수 있습니다. 이로 인해 vCenter가 비정상적으로 동작할 수 있습니다.

RecoverPoint 5.3.4.1 버전과 달리 더 이상 각 명령의 실행 시간을 관리하지 않습니다.

Resolution

해결 방법:

A - RecoverPoint for Virtual Machines 버전 5.3.4.1 및 vSphere 7.0.x의 경우:

옵션 1:

DCUI 호출 수를 줄이려면 다음 단계를 수행합니다.
 

  1. ESXi에 대한 ssh 세션을 엽니다.
  2. 아래 명령을 수행합니다.

sed -i 's/t_RpEsxInfoScanInterval                     = 35000000  # 35 seconds/t_RpEsxInfoScanInterval                     = 15770000000000 # 6 months As per Dell KB123456 # OLD value is 35000000  # 35 seconds/' /etc/config/emc/rp/kdriver/tweak/tweak.params.splitter

  1. 값이 1577000000000000으로 t_RpEsxInfoScanInterval 값으로 변경되었는지 확인합니다. 
cat /etc/config/emc/rp/kdriver/tweak/tweak.params.splitter | grep t_RpEsxInfoScanInterval

 

  1. 스플리터 재시작 

ps | grep kdriver

pkill -9 kdriver



옵션 2:

해결 방법을 수행하는 두 번째 옵션이 있습니다. Dell Technologies가 자동으로 변경하는 스크립트를 제공할 수 있습니다. 

  1. 스크립트를 얻으려면 RecoverPoint 지원에 문의하십시오. 하나는 Python으로 작성되고 다른 하나는 bash로 작성되는 두 가지 옵션이 있습니다. 스크립트 이름은 kdriver_scantime_change.sh 또는 kdriver_scantime_change.py입니다.
  2. 영향을 받는 ESXi 호스트/tmp 아래에 스크립트를 배치합니다.
  3. 다음 명령을 실행합니다.
    chmod +x kdriver_scantime_change.sh

    또는 
    chmod +x kdriver_scantime_change.py
  4. 이제 다음 명령을 사용하여 스크립트를 실행합니다.
    ./kdriver_scantime_change.sh

    또는 
    python kdriver_scantime_change.py


변경으로 인해 스캔이 35초마다 실행되는 대신 6개월마다 실행됩니다. 이 변경 사항은 RecoverPoint와 ESXi 호스트 간의 통신에 영향을 미치지 않습니다.


B - RecoverPoint for Virtual Machines 버전 6.0.1.x 및 vSphere 8.0.x의 경우:

Broadcom은 vCenter 사이징이 권장 사항을 준수하도록 요청합니다.

https://docs.vmware.com/en/VMware-vSphere/6.5/com.vmware.vsphere.install.doc/GUID-077C7523-E0EA-4922-8D48-C026916323C4.html이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.
 

참고: 위의 링크는 버전 6.5를 참조하지만 버전 8.0.x에도 동일한 크기 값이 유효합니다.

 

/seat 파티션을 늘려야 하는 경우 Broadcom 문서의 지침을 따릅니다 https://knowledge.broadcom.com/external/article/316602/increasing-the-disk-space-for-the-vcente.html이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.



파티션을 100% 사용하는 경우 Broadcom 문서의 정리 지침을 참조하십시오.

https://knowledge.broadcom.com/external/article/318931/storageseat-disk-100-full-on-vcenter-ser.html이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다.

 

 

C - RecoverPoint for Virtual Machines 버전 5.3.4.1 및 vSphere 8.0.x의 경우
 

이 문제는 RecoverPoint for VMs 스플리터 5.3.4.1.HF2 버전에서 해결되었습니다. 

업그레이드가 환경에 적합한지 확인하려면 Dell Technologies 고객 지원 센터 또는 서비스 담당자에게 문의하고 이 솔루션 ID를 참조하십시오.

 

참고: t_RpEsxInfoScanInterval 35초로 되돌려야 합니다. 필요한 변경을 자동으로 수행하기 위한 스크립트가 필요한 경우 지원 부서에 문의하십시오.

 

Article Properties
Article Number: 000228164
Article Type: Solution
Last Modified: 12 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.