RecoverPoint for VMs: Rozdzielnik w 5.3.4.1 i 6.0.1.x generuje żądania logowania DCUI

Summary: Po uaktualnieniu rozdzielnika VIB do wersji 5.3.4.1 lub po zainstalowaniu wersji 6.0.1.x proces rozdzielnika wygeneruje wiele żądań logowania DCUI w vCenter.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Po uaktualnieniu rozdzielnika RecoverPoint / kdriver VIB do wersji 5.3.4.1, kdriver wygeneruje wiele żądań logowania DCUI w vCenter.

Z /scratch/log/kdriver.log.* na hoście ESXi, którego dotyczy problem:

2024/08/21 14:39:51.268 - #2 - 4561369/4561352 - HostIPDiscoveryMgr_AO_IMPL:  rpEsxInfoScan: /opt/emc/rp/kdriver/bin/rp_rpa_discovery.sh --scan-props & executed successfully
2024/08/21 14:40:26.444 - #2 - 4561369/4561352 - HostIPDiscoveryMgr_AO_IMPL:  rpEsxInfoScan: /opt/emc/rp/kdriver/bin/rp_rpa_discovery.sh --scan-props & executed successfully


Z var/log/hostd.log na hoście ESXi, którego dotyczy problem:

2024-08-18T23:32:18.395Z info hostd[2101236] [Originator@6876 sub=Default opID=esxcli_name] Accepted password for user dcui from 127.0.0.1
2024-08-18T23:32:18.395Z warning hostd[2101236] [Originator@6876 sub=Vimsvc opID=esxcli_name] Refresh function is not configured.User data can't be added to scheduler.User name: dcui
2024-08-18T23:32:18.395Z info hostd[2101236] [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli_name] Event 125221 : User dcui@127.0.0.1 logged in as pyvmomi Python/3.8.18 (VMkernel 7.0.3 x86_64)
2024-08-18T23:32:18.466Z info hostd[2100837] [Originator@6876 sub=Solo.VmwareCLI opID=esxcli_name user=dcui] Dispatch list
2024-08-18T23:32:18.475Z info hostd[2100837] [Originator@6876 sub=Solo.VmwareCLI opID=esxcli_name user=dcui] Dispatch list done


Po zainstalowaniu lub uaktualnieniu rozdzielacza RecoverPoint do wersji 6.0.1.x wygeneruje on wiele żądań logowania do interfejsu DCUI (Direct Console User Interface) w vCenter.

Z /scratch/log/iofilterd-emcsplitter.log na hoście ESXi, którego dotyczy problem:

2024-08-16T08:24:40.578Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced list -o "/UserVars/RP_IP_Discovery_8" | grep "\s\s\sString Value:" | awk -F "String Value: " {'print $2'}'
2024-08-16T08:24:41.145Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced list -o "/UserVars/RP_IP_Discovery_9" | grep "\s\s\sString Value:" | awk -F "String Value: " {'print $2'}'
2024-08-16T08:24:41.473Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced set -o "/UserVars/emcsplitter_clusters" -s ""'
2024-08-16T08:24:41.720Z In(14) iofilterd-emcsplitter[16847250]: spl_run_cmd: running command 'VI_USERNAME=dcui esxcli system settings advanced list -o "/UserVars/RP_IP_Discovery_10" | grep "\s\s\sString Value:" | awk -F "String Value: " {'print $2'}'




Z var/log/hostd.log na hoście ESXi, którego dotyczy problem:

 

2024-08-16T08:24:40.538Z In(166) Hostd[2099945]: [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli-ed-6cca sid=52e328a0 user=dcui] Event 2652729 : User dcui@127.0.0.1 logged out (login time: Friday, 16 August, 2024 08:24:40 AM, number of API invocations: 7, user agent: pyvmomi Python/3.8.16 (VMkernel; 8.0.1; x86_64))
2024-08-16T08:24:41.059Z In(166) Hostd[2099964]: [Originator@6876 sub=Vimsvc.HaSessionManager opID=esxcli-hostname sid=5284e077] Accepted password for user dcui from 127.0.0.1 - session=5284e077-ac72-8d89-47b2-38feba5f8354
2024-08-16T08:24:41.059Z Wa(164) Hostd[2099964]: [Originator@6876 sub=Vimsvc opID=esxcli-hostname sid=5284e077] Refresh function is not configured.User data can't be added to scheduler.User name: dcui
2024-08-16T08:24:41.059Z In(166) Hostd[2099964]: [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli-hostname sid=5284e077] Event 2652730 : User dcui@127.0.0.1 logged in as pyvmomi Python/3.8.16 (VMkernel; 8.0.1; x86_64)
2024-08-16T08:24:41.109Z In(166) Hostd[2099943]: [Originator@6876 sub=Solo.VmwareCLI opID=esxcli-8f-6cd7 sid=5284e077 user=dcui] Dispatch system.settings.advanced.list
2024-08-16T08:24:41.111Z In(166) Hostd[2099943]: [Originator@6876 sub=Solo.VmwareCLI opID=esxcli-8f-6cd7 sid=5284e077 user=dcui] Dispatch system.settings.advanced.list done
2024-08-16T08:24:41.114Z In(166) Hostd[2099957]: [Originator@6876 sub=Vimsvc.ha-eventmgr opID=esxcli-8f-6cd8 sid=5284e077 user=dcui] Event 2652731 : User dcui@127.0.0.1 logged out (login time: Friday, 16 August, 2024 08:24:41 AM, number of API invocations: 7, user agent: pyvmomi Python/3.8.16 (VMkernel; 8.0.1; x86_64))
2024-08-16T08:24:41.630Z In(166) Hostd[2099938]: [Originator@6876 sub=Vimsvc.HaSessionManager opID=esxcli-hostname sid=520464cb] Accepted password for user dcui from 127.0.0.1 - session=520464cb-08ef-ad94-d4dd-4d02abaf0937
2024-08-16T08:24:41.630Z Wa(164) Hostd[2099938]: [Originator@6876 sub=Vimsvc opID=esxcli-hostname sid=520464cb] Refresh function is not configured.User data can't be added to scheduler.User name: dcui



Te wywołania logowania i wylogowania są mnożone przez liczbę hostów w środowisku. Generuje wiele zdarzeń w vCenter, które mogą potencjalnie zapełnić partycję /seat, powodując, że vCenter przestaje odpowiadać.

Cause

Wersja

5.3.4.1W wersji RecoverPoint 5.3.4.1 nowy skrypt o nazwie rp_rpa_discovery.sh został dodany do rozdzielacza/kdriver VIB. Ten skrypt służy do pobierania szczegółów hosta ESXi zgodnie z harmonogramem, domyślnie co 35 sekund.

Skrypt używa wywołań DCUI do zebrania niezbędnych wartości dla każdego hosta, generując częste żądania logowania i wylogowania dla każdego hosta w vCenter. Każde polecenie uruchomione w ESXi jest rejestrowane w bazie danych vCenter, a partycja pamięci masowej zawierająca bazę danych (/seat) może zostać zapełniona. Może to powodować nieprawidłowe działanie vCenter.

Wpływ tego problemu zależy od liczby hostów uruchomionych w vCenter. Im więcej hostów, tym szybciej partycja może się zapełnić, potencjalnie powodując awarię usługi VXPD.

To zachowanie dotyczy hostów z wersją 7.0.x.

Wersja

6.0.1.xW programie RecoverPoint w wersji 6.0.1.x program RecoverPoint używa polecenia esxcli to z DCUI w celu pobrania informacji o systemie. Wywołania te zbierają niezbędne wartości dla każdego hosta, generując częste żądania logowania i wylogowania dla każdego hosta w vCenter. Każde polecenie uruchomione w ESXi jest rejestrowane w bazie danych vCenter, a partycja pamięci masowej zawierająca bazę danych (/seat) może zostać zapełniona. Może to powodować nieprawidłowe działanie vCenter.

W przeciwieństwie do wersji RecoverPoint 5.3.4.1 nie można już zarządzać czasem wykonania każdego polecenia.

Resolution

Obejście problemu:

A — W przypadku RecoverPoint dla maszyn wirtualnych w wersji 5.3.4.1 i vSphere 7.0.x:

Opcja 1:

Aby zmniejszyć liczbę wywołań DCUI, wykonaj następujące czynności:
 

  1. Otwórz sesję SSH w ESXi.
  2. Wykonaj poniższe polecenie.

sed -i 's/t_RpEsxInfoScanInterval                     = 35000000  # 35 seconds/t_RpEsxInfoScanInterval                     = 15770000000000 # 6 months As per Dell KB123456 # OLD value is 35000000  # 35 seconds/' /etc/config/emc/rp/kdriver/tweak/tweak.params.splitter

  1. Sprawdź, czy wartość została zmieniona na t_RpEsxInfoScanInterval wartość na 15770000000000 
cat /etc/config/emc/rp/kdriver/tweak/tweak.params.splitter | grep t_RpEsxInfoScanInterval

 

  1. Uruchom ponownie rozdzielacz 

ps | grep kdriver

pkill -9 kdriver



Opcja 2:

Istnieje druga opcja obejścia problemu: firma Dell Technologies może dostarczyć skrypt umożliwiający automatyczne wprowadzenie zmian. 

  1. Skontaktuj się z pomocą techniczną RecoverPoint, aby uzyskać skrypt, istnieją dwie opcje, jedna jest napisana w Pythonie, a druga w bash. Nazwa skryptu to kdriver_scantime_change.sh lub kdriver_scantime_change.py.
  2. Umieść skrypt w katalogu /tmp na hoście ESXi, którego dotyczy problem.
  3. Uruchom polecenie:
    chmod +x kdriver_scantime_change.sh

    Lub 
    chmod +x kdriver_scantime_change.py
  4. Teraz uruchom skrypt za pomocą polecenia:
    ./kdriver_scantime_change.sh

    Lub 
    python kdriver_scantime_change.py


Ta zmiana powoduje, że skanowanie jest uruchamiane co 6 miesięcy zamiast co 35 sekund. Ta zmiana nie powinna wpłynąć na komunikację między RecoverPoint a hostami ESXi.


B — w przypadku RecoverPoint dla maszyn wirtualnych w wersji 6.0.1.x i vSphere 8.0.x:

Firma Broadcom żąda, aby rozmiary vCenter były zgodne z ich zaleceniami.

https://docs.vmware.com/en/VMware-vSphere/6.5/com.vmware.vsphere.install.doc/GUID-077C7523-E0EA-4922-8D48-C026916323C4.htmlKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.
 

UWAGA: Powyższy link odnosi się do wersji 6.5, ale te same wartości zmiany rozmiaru obowiązują dla wersji 8.0.x.

 

Jeśli konieczne jest zwiększenie partycji /seat, postępuj zgodnie z instrukcjami zawartymi w artykule Broadcom:

https://knowledge.broadcom.com/external/article/316602/increasing-the-disk-space-for-the-vcente.htmlKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

Jeśli partycja jest wykorzystana w 100%, zapoznaj się z artykułem Broadcom, aby uzyskać instrukcje czyszczenia.

https://knowledge.broadcom.com/external/article/318931/storageseat-disk-100-full-on-vcenter-ser.htmlKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

 

 

C — dla RecoverPoint dla maszyn wirtualnych w wersji 5.3.4.1 i vSphere 8.0.x
 

Ten problem został rozwiązany w rozdzielniku RecoverPoint dla maszyn wirtualnych w wersji 5.3.4.1.HF2

Aby ustalić, czy uaktualnienie jest odpowiednie dla Twojego środowiska, skontaktuj się z centrum pomocy technicznej Dell Technologies lub przedstawicielem działu obsługi i odwołaj się do tego identyfikatora rozwiązania.

 

UWAGA: t_RpEsxInfoScanInterval należy cofnąć do 35 sekund. Skontaktuj się z pomocą techniczną, jeśli potrzebujesz skryptu do automatycznego wprowadzenia niezbędnych zmian.

 

Article Properties
Article Number: 000228164
Article Type: Solution
Last Modified: 12 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.