PowerFlex管理プラットフォーム: Add Networkウィザードがエラー VXFM0004で失敗する

Summary: ワークロードVLANをCO RGに追加する「ネットワークの追加」ウィザードがエラー VXFM0004で失敗します。

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Symptoms

CO RGに「ネットワークの追加」ウィザードを使用すると、エラー VXFM0004で失敗します。
[Add Network]ウィザードで[Finish]をクリックすると、UIがロードされ、次のエラーで失敗します。
ネットワークの追加ウィザードのvxfm0004エラー

An error occurred. Expand the list to view the details of the error. (500)
The operation cannot be performed because of an internal issue. (VXFM0004)

asmManagerポッド ログ
[Finish]をクリックすると、次のログ エントリーが表示されます。

「Add Existing Resource Group」操作を実行しようとすると、これと同じエラーが表示されます。

"messages" : [ {
  "id" : null,
  "messageCode" : "IDENTITYPOOLMANAGER.0001",
  "messageBundle" : "IdentityPoolManager",
  "severity" : "ERROR",
  "category" : "USER_FACING",
  "displayMessage" : "The record ID <ID> cannot be retrieved because it is not in the database.",
  "responseAction" : "Enter the correct record ID, and then retry the operation.",
  "detailedMessage" : "The application cannot find the record ID identified in the message because it is not present in the database.",
  "correlationId" : null,
  "agentId" : null,
  "timeStamp" : "Date",
  "sequenceNumber" : 0
} ]

問題 

前述のエラーは、「ネットワークの追加」や「既存のリソース グループの追加」などの自動オーケストレーション タスクに影響を与えることが確認されており、他のタスクに影響を与える可能性があります。

 

Cause

このエラーは、 asmManager は、存在しなくなったレコード ID をキャッシュしています。

自動化タスクがキューに登録されて開始されると、 asmManager pod はこの孤立した ID を認識し、データベースから ID が欠落しているためエラーが発生します。

 

Resolution

この問題を解決する手順は次のとおりです。

  1. エラーが発生しているRGを削除します。
    VXFM0004RG名とネットワークをメモします

  2. MVMで次のコマンドを実行して、新しいasmManagerポッドを再作成します。

    kubectl delete pod -n powerflex $(kubectl get pods -n powerflex|grep asmm|awk '{print $1}')
  3. [Add Networks]ウィザードを再実行します。

影響を受けるバージョン

PFMPの4.5.2

修正バージョン

PFMPの4.8

 

Affected Products

PowerFlex rack, PowerFlex Appliance, PowerFlex Software
Article Properties
Article Number: 000228269
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  3
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