In Unisphere for PowerMax 10.1 werden keine Performancedaten erfasst
Summary: In Unisphere for PowerMax 10.1 werden keine Performancedaten erfasst
Symptoms
Unisphere-Performancedaten auf dem Windows-Host erfassen keine Daten, die Ports 8088 und 8089 werden nicht von netstat überwacht.
Der storstpd-Daemon konnte die verarbeitete Performancedatendatei DCF nicht über den Standardport 8088 und Port 8089 an die Postgres-Datenbank senden
storsptd.log:
Aug-19 7:55:14.271 pdsSockConnect #2377 : connect() failed: [fd=1820] [WSA code: 10061 - No connection could be made because the target machine actively refused it.]<Error> [4084 dcfSpaSender] Aug-19 7:55:14.272 pdsIpcClientConnInit #1782 : Unable to establish client connection [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019<Error> [4084 dcfSpaSender] Aug-19 7:55:14.272 : [sendFile()] TID: 912 SID: unable to connect to server: on port: 8088.<Warn > [4084 dcfSpaSender] Aug-19 7:55:14.272 : [dcfSpaSender()] TID: 912 error processing file: 20240818_1300_000_F.dcf.gz.
Postgres-Protokolle zeigen, dass das Datenbanksystem unterbrochen wurde und regulär gestartet wird:
2024-08-12 11:57:38 GMT:127.0.0.1(59537):[unknown]@[unknown]:[6480]:LOG: could not receive data from client: An existing connection was forcibly closed by the remote host.
In den SMAS- und RUN-Protokollen werden keine Fehler protokolliert, die darauf hinweisen, dass die erforderlichen Ports von anderen Prozessen/Anwendungen verwendet werden:
Error [em.spa.SPA] (EJB default - 4) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Address already in use: JVM_Bind.
- Keine FSCK-Fehler oder IO-Fehler in der Systemereignisanzeige gemeldet
- Keine netzwerkbezogenen Probleme mit den Ports 8088 oder 8089.
Cause
Dies ist ein bekanntes Problem in Unisphere for PowerMax v10.1, bei dem der storstpd-Daemon aufgrund einer Situation, in der übermäßige Warnmeldungen vorhanden sind, keine DCF-Dateien mehr sendet.
Resolution
Problemumgehung:
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Ändern Sie die Einstellungen in den folgenden 2 ejb-jar.xml Dateien im Unisphere-Installationsverzeichnis von true in false:
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Dieses Problem wurde in Unisphere for PowerMax v10.2 dauerhaft behoben.