Données de performances non collectées dans Unisphere for PowerMax 10.1

Summary: Données de performances non collectées dans Unisphere for PowerMax 10.1

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les données de performances Unisphere sur l’hôte Windows ne collectent pas de données, les ports 8088 et 8089 ne restent pas à l’écoute de netstat.

Le processus storstpd n’a pas pu envoyer le DCF du fichier de données de performances traité à la base de données Postgres via les ports 8088 et 8089 par défaut

storsptd.log :

Aug-19 7:55:14.271 pdsSockConnect #2377 : connect() failed: [fd=1820] [WSA code: 10061 - No connection could be made because the target machine actively refused it.]
<Error> [4084 dcfSpaSender] Aug-19 7:55:14.272 pdsIpcClientConnInit #1782 : Unable to establish client connection [pdsSockSocket()/pdsSockConnect() failed], nRc= 700004019
<Error> [4084 dcfSpaSender] Aug-19 7:55:14.272 : [sendFile()] TID: 912 SID: unable to connect to server: on port: 8088.
<Warn > [4084 dcfSpaSender] Aug-19 7:55:14.272 : [dcfSpaSender()] TID: 912 error processing file: 20240818_1300_000_F.dcf.gz.

Les logs Postgres indiquent que le système de base de données a été interrompu et démarre régulièrement :

2024-08-12 11:57:38 GMT:127.0.0.1(59537):[unknown]@[unknown]:[6480]:LOG:  could not receive data from client: An existing connection was forcibly closed by the remote host.

Aucune erreur n’est consignée dans les journaux SMAS et RUN pour montrer que les ports requis sont en cours d’utilisation par d’autres processus/applications :

Error [em.spa.SPA] (EJB default - 4) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Address already in use: JVM_Bind.

  • Aucune erreur FSCK ou erreur d’E/S signalée dans l’observateur d’événements système
  • Aucun problème réseau avec les ports 8088 ou 8089.

Cause

Il s’agit d’un problème connu dans Unisphere for PowerMax v10.1 où le processus storstpd cesse d’envoyer des fichiers dcf en raison d’un nombre excessif d’alertes. 

Resolution

Solution de contournement :
 

Modifiez les paramètres de true à false dans les 2 fichiers ejb-jar.xml suivants dans le répertoire d’installation de Unisphere :

  1. install_dir/SMAS/jboss/domain/deploy/domain-symm.ear/domain-symm-ejb.jar/META-INF/ejb-jar.xml
  2. install_dir/SMAS/jboss/domain/deploy0/domain-symm0.ear/domain-symm-ejb.jar/META-INF/ejb-jar.xml


Le cadre est ici :


<ejb-class>com.emc.em.domain.symmetrix.alert.SymmAutoClearAlertService</ejb-class>
<env-entry>
<env-entry-name>autoClearAlertsEnabled</env-entry-name>
<env-entry-type>java.lang.Boolean</env-entry-type>
<env-entry-value>true</env-entry-value>
</env-entry>


Définissez true sur false et enregistrez les fichiers.

Redémarrez le SMAS (ne le redémarrez pas, car les modifications seront perdues).

 

 





















Ce problème est définitivement résolu dans Unisphere for PowerMax v10.2.

Affected Products

Unisphere for PowerMax
Article Properties
Article Number: 000228313
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.