NetWorker Recovery з Cyber Recovery не вдається через помилку BAD_DATA

Summary: Виконати відновлення NetWorker за допомогою Cyber Recovery не вдається з помилкою Failed to run task recoverapp. Не вдається отримати пристрої NW. Помилка NetWorker не може розшифрувати дані: BAD_DATA ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Коли користувач виконує відновлення NetWorker за допомогою Cyber Recovery, завдання не виконується з наступною помилкою:

Failed to run task recoverapp. Unable to get NW devices. NetWorker Error is Unable to decrypt data: BAD_DATA
Відновлення NetWorker не вдається відновити з повідомленням про помилку

Ця помилка також відображається в журналі демонів NetWorker.
Повідомлення про помилку в журналі демонів NetWorker
Мі́сце: C:\Program Files\EMC NetWorker\nsr\logs.daemon.raw
NetWorker: Як використовувати nsr_render_log для відображення файлів журналу .raw

При доступі до інтерфейсу користувача NetWorker Management Console (NMC) при спробі навігації по вкладках інтерфейсу користувача з'являється спливаюче вікно з помилкою «BAD_DATA».
Спливаюче вікно з BAD_DATA

 

Cause

Ця проблема виникає, коли вихідний сервер NetWorker є фізичним комп'ютером Windows, тоді як цільовий сервер NetWorker у сховищі є віртуальною машиною. Проблема криється в замку NetWorker. На вихідному сервері NetWorker використовується парольна фраза Datazone, яка неправильно відновлюється в процесі Cyber Recovery.

 

Resolution

Спосіб вирішення: Парольна фраза Datazone повинна бути оновлена вручну в NetWorker після виконання завдання «Відновлення» в Cyber Recovery. Кроки для вирішення проблеми з блоком блокування та парольною фразою Datazone описані нижче:

  1. Видаліть відновлений замок: Видаліть блок, який було відновлено в процесі кібервідновлення.
    видалити блокувальник в NMC

  2. Створіть новий сейф: Вручну створіть новий блок для цільового сервера NetWorker у сховищі.
    створити сейфбокс в NMC

  3. Оновіть парольну фразу Datazone: За допомогою кнопки nsradmin команду для оновлення парольної фрази Datazone. Переконайтеся, що парольна фраза збігається з тією, що використовується на робочому (вихідному) сервері NetWorker.
    Парольна фраза для оновлення nsradmin

  4. Перезапустіть служби NetWorker: Після оновлення парольної фрази перезапустіть служби NetWorker на цільовому сервері, виконавши наступні команди:

    net stop nsrexecd
    net start nsrd
    net start gstd
  5. Перевірити: Увійдіть в інтерфейс NMC і перевірте, чи вирішена помилка спливаючого вікна «BAD_DATA». Перейдіть по вкладках, щоб переконатися, що проблема більше не відображається.

 

Affected Products

NetWorker
Article Properties
Article Number: 000228407
Article Type: Solution
Last Modified: 26 Sep 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.