NetWorker Recovery з Cyber Recovery не вдається через помилку BAD_DATA
Summary: Виконати відновлення NetWorker за допомогою Cyber Recovery не вдається з помилкою Failed to run task recoverapp. Не вдається отримати пристрої NW. Помилка NetWorker не може розшифрувати дані: BAD_DATA ...
Symptoms
Коли користувач виконує відновлення NetWorker за допомогою Cyber Recovery, завдання не виконується з наступною помилкою:
Failed to run task recoverapp. Unable to get NW devices. NetWorker Error is Unable to decrypt data: BAD_DATA
Ця помилка також відображається в журналі демонів NetWorker.
Мі́сце: C:\Program Files\EMC NetWorker\nsr\logs.daemon.raw
NetWorker: Як використовувати nsr_render_log для відображення файлів журналу .raw
При доступі до інтерфейсу користувача NetWorker Management Console (NMC) при спробі навігації по вкладках інтерфейсу користувача з'являється спливаюче вікно з помилкою «BAD_DATA».
Cause
Ця проблема виникає, коли вихідний сервер NetWorker є фізичним комп'ютером Windows, тоді як цільовий сервер NetWorker у сховищі є віртуальною машиною. Проблема криється в замку NetWorker. На вихідному сервері NetWorker використовується парольна фраза Datazone, яка неправильно відновлюється в процесі Cyber Recovery.
Resolution
Спосіб вирішення: Парольна фраза Datazone повинна бути оновлена вручну в NetWorker після виконання завдання «Відновлення» в Cyber Recovery. Кроки для вирішення проблеми з блоком блокування та парольною фразою Datazone описані нижче:
-
Видаліть відновлений замок: Видаліть блок, який було відновлено в процесі кібервідновлення.

-
Створіть новий сейф: Вручну створіть новий блок для цільового сервера NetWorker у сховищі.

-
Оновіть парольну фразу Datazone: За допомогою кнопки
nsradminкоманду для оновлення парольної фрази Datazone. Переконайтеся, що парольна фраза збігається з тією, що використовується на робочому (вихідному) сервері NetWorker.

-
Перезапустіть служби NetWorker: Після оновлення парольної фрази перезапустіть служби NetWorker на цільовому сервері, виконавши наступні команди:
net stop nsrexecd net start nsrd net start gstd
-
Перевірити: Увійдіть в інтерфейс NMC і перевірте, чи вирішена помилка спливаючого вікна «BAD_DATA». Перейдіть по вкладках, щоб переконатися, що проблема більше не відображається.