NetWorker Recovery met Cyber Recovery mislukt door BAD_DATA fout
Summary: Het uitvoeren van een NetWorker Recovery met Cyber Recovery mislukt met de fout Kan taak recoverapp niet uitvoeren. Kan NW-apparaten niet ophalen. NetWorker Error is Unable to decrypt data: BAD_DATA ...
Symptoms
Wanneer een gebruiker een NetWorker-herstel uitvoert via Cyber Recovery, mislukt de taak met de volgende fout:
Failed to run task recoverapp. Unable to get NW devices. NetWorker Error is Unable to decrypt data: BAD_DATA
Deze fout wordt ook weergegeven in het NetWorker daemon log.
Plaats: C:\Program Files\EMC NetWorker\nsr\logs.daemon.raw
NetWorker: De nsr_render_log gebruiken om .raw logbestanden weer te geven
Wanneer u de UI van de NetWorker Management Console (NMC) opent, wordt de fout "BAD_DATA" weergegeven wanneer u door de UI-tabbladen probeert te navigeren.
Cause
Dit probleem doet zich voor wanneer de NetWorker-bronserver een fysieke Windows-machine is, terwijl de doel-NetWorker-server in de kluis een virtuele machine is. Het probleem ligt bij de NetWorker-lockbox. Op de NetWorker-bronserver wordt een wachtwoordzin voor de datazone gebruikt, die niet correct wordt hersteld tijdens het cyberherstelproces.
Resolution
Tijdelijke oplossing: De wachtwoordzin van de Datazone moet handmatig worden bijgewerkt in NetWorker na het voltooien van de hersteltaak in Cyber Recovery. De stappen voor het oplossen van het probleem met de wachtwoordzin van de lockbox en Datazone worden hieronder beschreven:
-
Verwijder de herstelde lockbox: Verwijder de lockbox die is hersteld als onderdeel van het Cyber Recovery-proces.

-
Maak een nieuwe lockbox aan: Maak handmatig een nieuwe lockbox voor de doel-NetWorker-server in de kluis.

-
Werk de wachtwoordzin voor de datazone bij: Gebruik de
nsradminopdracht om de wachtwoordzin van de datazone bij te werken. Zorg ervoor dat de wachtwoordzin hetzelfde is als de wachtwoordzin die wordt gebruikt op de NetWorker-server (bronzin).

-
NetWorker Services opnieuw starten: Nadat u de wachtwoordzin hebt bijgewerkt, start u de NetWorker-services opnieuw op de doelserver door de volgende opdrachten uit te voeren:
net stop nsrexecd net start nsrd net start gstd
-
Valideren: Meld u aan bij de NMC UI en controleer of de pop-upfout "BAD_DATA" is opgelost. Navigeer door de tabbladen om te controleren of het probleem zich niet meer voordoet.