DPC: Dockerポート構成の問題によるDPC IAMサービス障害の修正

Summary: このナレッジベース記事では、DPC dp-iamサービスの開始に失敗する問題の解決策について説明します。これは、docker-compose.ymlファイルのポート構成の問題が原因である場合です。根本原因は、コロンが多すぎる無効なIPv6アドレスであり、コンテナのビルド時に誤った解釈を引き起こします。解決策は、docker-compose.ymlファイルを編集し、IPv6アドレスを角括弧で囲んで、docker composeサービスを再起動することです。 ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • DPCのdp-iamサービスがダウンしています。
  • サービスを開始しようとすると失敗します。
  • /var/log/dpc/iam/dp_iam.logに、次のエラーが表示されます。
error decoding 'ports': Invalid ip address ::1: address ::1:: too many colons in address
  • 上記のエラーは、/var/log/dpc/install/intstall.logにも表示される場合があります。 
これは、バージョン19.10以降で確認できます。

Cause

この問題は、docker-compose.ymlファイルの構成の問題が原因で発生します。IPv6アドレスに「::」が含まれているため、システムはコンテナ ビルドのポートを誤って解釈します。

/var/log/dpc/iam/dp_iam.logファイルのエラー メッセージは、システムがIPv6アドレスを正しく解析できないことを示しています。

Resolution

メモ: この問題の修正がgoidpaツールに追加されました。次のKBに従ってgoidpaをインストールしてください。
次に、ACMで次のコマンドを実行します。
./goidpa dpc yml-port-fix

 

注:問題が解決しない場合は、Dellサポートにお問い合わせください。


 

Additional Information

goidpa自動プロセスが失敗した場合、この問題に対する手動の手順は次のとおりです。

  • PUTTY/SSHを使用してadminとしてDPC UIにログインし、su -をrootユーザーとして実行します。
  • 次のように、docker compose ファイルが含まれているディレクトリに移動します。
cd /usr/local/dpc/lib/iam/bin
  • 次のコマンドを使用して、「docker-compose.yml」ファイルを編集します。
vi docker-compose.yml
  • servicesセクションのiam-providerセクションで、次のようにポートを編集します。
ports:
            - "127.0.0.1:8143:8443"
            - "::1:8143:8443"

Change this by putting square brackets around the IPv6 address, "::1" as follows:

ports:
            - "127.0.0.1:8143:8443"
            - "[::1]:8143:8443"
  • servicesセクションのiam-serviceセクションで、次のようにポートを編集します。
ports:
            - "127.0.0.1:8870:8870"
            - "::1:8870:8870"

Change this by putting square brackets around the IPv6 address, "::1" as follows:

ports:
            - "127.0.0.1:8870:8870"
            - "[::1]:8870:8870"
  • ESCキーをクリックし、次のように入力してviエディターを終了します。
:x
  • 次のコマンドを使用して、docker compose サービスを再起動します。
docker-compose down
docker-compose up -d
  •  次のコマンドを使用して、msm-elgサービスを再起動します。
service msm-elg restart

 

Affected Products

Data Protection Central
Article Properties
Article Number: 000228776
Article Type: Solution
Last Modified: 24 Apr 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.