ECS: xDoctor: RAP081: Symptomkode: 2048: Alle NTP-servere er IKKE egnet for synkronisering

Summary: xDoctor oppdaget en Network Time Protocol (NTP) daemon problem.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Alle noder i et ECS-rack skal ha NTP-daemonen kjørende, og de konfigurerte NTP-serverne skal være i stand til å synkronisere tiden. Hvis ikke, kan dette føre til problemer med frontend datainntak.

Symptom

Melding

NTP_NOT_SUITABLE_ERROR

Melding = Alle NTP-servere er IKKE egnet for synkronisering.
Ekstra = [Liste over noder]

Cause

Symptomene ovenfor forblir som en ADVARSEL hvis det ikke forekommer innen 24 timer.
Etter 24 timer, hvis dette vedvarer, vil alvorlighetsgraden økes til en FEIL, og en RAP081 rapporteres.

Resolution

Dette betyr at på hver node som er oppført i feltet "Ekstra", kan ikke synkroniseres med NTP-serveren.

Bekreftelse:
1. Hent listen over NTP-servere på hver av de oppgitte nodene:

Kommando:

# getrackinfo-r | grep NTP

Eksempel:

admin@node1:~> getrackinfo -r | grep NTP
NTPServer = xxx.xxx.xxx.xxx

2. For hver NTP-server som er oppført i trinn 1, test om den er i stand til å synkronisere tiden.

Kommando:

# sudo ntpdate -p 2 -d <NTP IP-adresse / NTP FQDN>

Eller

# sudo ntpdate -p 2 -d 'getrackinfo-r | grep NTP |grep -oP "(?:[0-9]{1,3}\.) {3} [0-9] {1,3}"'

Eksempel (i stand til å synkronisere tid):

admin@node1:~> sudo ntpdate -p 2 -d xxx.xxx.xxx.xxx
22 Feb 13:47:48 ntpdate [110901]: ntpdate 4.2.8p11@1.3728-o Thu Jun 14 09:26:52 UTC 2018 (1)
Looking for host <NTP IP Address> and service ntp<
NTP IP Address> reversed to <NTP hostname>
host found: <NTP vertsnavn>
overføre (<NTP IP-adresse>)
motta (<NTP IP-adresse>)
overføre (<NTP IP-adresse>)
motta (<NTP IP-adresse>)
server <NTP IP-adresse>, port 123
stratum 2, presisjon -24, sprang 00, tillit 000
refid [<NTP IP-adresse>], forsinkelse 0,02615, spredning 0,00003
overført 2, i filter 2
referansetid:    e01a7b0d.af9e6616 Fre, Feb 22 2019 13: 43: 41.686
Oppsinn tidsstempel: e01a7c06.748e0c65 Fre, Feb 22 2019 13: 47: 50.455
overføre tidsstempel:  e01a7c06.7478b000 Fre, Feb 22, 2019 13:47:50.454
filter delay:  0.02635 0.02615 0.00000 0.00000
0.00000 0.00000 0.00000 0.00000
FILTERFORSKYVNING: 0,000043 -0,00002 0,0000000 0,000000
0,000000 0,000000 0,0000000 0,000000
forsinkelse 0,02615, spredning 0,00003
forskyvning -0,000022

22 februar 13:47:50 ntpdate [110901]: justere tid server <NTP IP-adresse> offset -0.000022 sek

Eksempel: (Hvis den ikke kan synkronisere tiden, gir den følgende utdata)

admin@node1:~> sudo ntpdate -p 2 -d xxx.xxx.xxx.xxx
22 Feb 13:47:48 ntpdate [110901]: ntpdate 4.2.8p11@1.3728-o Thu Jun 14 09:26:52 UTC 2018 (1)
Looking for host <NTP IP Address> and service ntp<
NTP IP Address> reversed to <NTP hostname>
host found: <NTP vertsnavnoverføre (<NTP IP-adresse>)
overføre (NTP IP-adresse>)
overføre (<<NTP IP-adresse>)

server <NTP IP-adresse>, port 123
stratum 2, presisjon -24, sprang 00, tillit 000
refid [<NTP IP-adresse>], forsinkelse 0,02615, spredning 0,00003
overført 2, i filter 2
referansetid:>
    e01a7b0d.af9e6616 Fre, Feb 22 2019 13: 43: 41.686
Oppsinn tidsstempel: e01a7c06.748e0c65 Fre, Feb 22 2019 13: 47: 50.455
overføre tidsstempel:  e01a7c06.7478b000 Fre, Feb 22, 2019 13:47:50.454
filter delay:  0.02635 0.02615 0.00000 0.00000
0.00000 0.00000 0.00000 0.00000
FILTERFORSKYVNING: 0,000043 -0,00002 0,0000000 0,000000
0,000000 0,000000 0,0000000 0,000000
forsinkelse 0,02615, spredning 0,00003
forskyvning -0,000022

22 februar 13:47:50 ntpdate [112232]: ingen server egnet for synkronisering funnet

3. Legg til FQDN i NTP-delen i getrackinfo -r-resultatet.

Kommando:

# sudo setrackinfo -a NTPServer < NTP FQDN >

4. Se etter nettverksseparasjon og statiske ruter, som NTP sendt fra administrasjonsgrensesnittet via policybasert ruting, kan forårsake problemet.

Kommando:

# getrackinfo -n; getrackinfo -t

Eksempel:

admin@node1:~>getrackinfo -n; getrackinfo -t
Navngitte nettverk
==============
node-ID IP-adresse Nettmaske Gateway VLAN-grensesnitt
Statisk ruteliste
=================
node-ID Nettverksnettmaske Gateway-grensesnitt

5. Kontroller at NTP-servere lytter i miljøet sitt. Det er ofte en brannmur som blokkerer porten. 

Kommando:

# sudo ntpq -c som

Eksempel: (Nedenfor ser vi en NTP-server som ikke kan nås, og den andre blokkerer sannsynligvis på grunn av en ACL)

admin@node1:~> sudo ntpq -c as
ind assid status conf reach auth condition last_event cnt
===========================================================
1 56633 8011 ja nei ingen avvise mobilisere 1

6. Sjekk om det har oppstått dataavvik i NTP. 

Kommando:

# viprexec "date +%s" 2>&1 | grep "^15"

Eksempel:

admin@node1:~>viprexec "date +%s" 2>&1 | grep "^15"
1554470147
1554470111
1554470096
1554470142
1554470144
1554470109
1554470124
1554470140

7. Se etter statusen til ntpd-tjenesten, og start deretter tjenesten på nytt. (Selv om statusen er oppe og går, fortsett med omstarten.) 
Merk: ntpd.service er en tjeneste uten innvirkning.

Kommando:

# viprexec systemctl status ntpd.service | grep Active:

Eksempel:

admin@node1:~> viprexec systemctl status ntpd.service | grep Active:
   Aktiv: aktiv (kjører) siden tirs 06.08.2019 02:49:06 UTC; 1 dag 18 timer siden
Aktiv: aktiv (kjører) siden Tir 06.08.2019 02:49:07 UTC; 1 dag 18 timer siden
Aktiv: aktiv (løpende) siden ons 07.08.2019 20:13:27 UTC; 58min siden
Aktiv: aktiv (kjører) siden Tir 06.08.2019 02:49:06 UTC; 1 dag 18 timer siden
Aktiv: aktiv (kjører) siden Tir 06.08.2019 02:49:07 UTC; 1 dag 18 timer siden
Aktiv: aktiv (kjører) siden Tir 06.08.2019 02:49:07 UTC; 1 dag 18 timer siden
Aktiv: aktiv (kjører) siden tirs 06.08.2019 02:49:07 UTC; 1 dag 18t siden
Aktiv: aktiv (kjører) siden Tir 06.08.2019 02:49:07 UTC; 1 dag 18 timer siden

Kommando: 

# viprexec systemctl restart ntpd.service

Eksempel:

admin@node1:~> viprexec systemctl restart ntpd.service
Output from host: 192.168.219.8
Utgang fra vert: 192.168.219.7
Utgang fra vert : 192.168.219.6
Utgang fra vert: 192.168.219.4
Utgang fra vert: 192.168.219.3
Utgang fra vert : 192.168.219.2
Utgang fra vert : 192.168.219.5
Utgang fra vert: 192.168.219.1

8. Kontroller md5sum ntp.conf-filen på alle nodene.

Kommando:

# viprexec "sudo md5sum /etc/ntp.conf"

Eksempel:

admin@node1:~> viprexec "sudo md5sum /etc/ntp.conf"

Utdata fra vert: 192.168.219.2
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Utdata fra vert: 192.168.219.5
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Utdata fra vert: 192.168.219.4
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Utdata fra vert: 192.168.219.1
7da6eb8009abc18ed1875f1f15ade72a /etc/ntp.conf

Utdata fra vert: 192.168.219.3
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Utdata fra vert: 192.168.219.8
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Utdata fra vert: 192.168.219.6
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Utdata fra vert: 192.168.219.7
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Merk: Dette kan skyldes at du har et offentlig grensesnitt og administrasjonsgrensesnitt, og nodene er alle konfigurert til å gå ut av offentligheten i henhold til den siste konfigurasjonen som ble gitt. På eldre versjoner av ECS kan PBR sitte fast der en node er gyldig og resten av nodene så ut til å være bak en brannmur.

9. Legg til 123 i ns_mgmt i getrackinfo -r-resultatet, og sjekk deretter om NTP har begynt å sende og motta.

Kommando:

# sudo setrackinfo-en ns_mgmt 123

Eksempel:

admin@node1:~>sudo setrackinfo-en ns_mgmt 123

Hvis feilen fortsatt vedvarer, plasserer du port 123 tilbake i det offentlige grensesnittet og ser etter synkroniseringen igjen.

Kommando:

# sudo setrackinfo -d ns_mgmt 123

Eksempel:

admin@node1:~> sudo setrackinfo -d ns_mgmt 123

Kontroller statusen for NTP-synkroniseringen etter å ha utført hvert av trinnene ovenfor.

Resolusjon:
Dette betyr at serveren som konfigurert ikke er en NTP-server, eller at den ikke fungerer som forventet. Kundens nettverksteam må være engasjert for å løse NTP-problemet.

Additional Information

Hvis oppløsningen ovenfor ikke fungerer, må kundens nettverksteam engasjeres for å løse NTP-problemet.

For symptom 'NTP daemon not running' (NTPD_NOT_RUNNING), se kunnskapsartikkel:
ECS: xDoctor: RAP081: Symptomkode: 2048: NTP-bakgrunnsprosessen kjører

ikkeFor symptom 'Alle NTP-servere justerer en forskyvning høyere enn feilterskelen' (NTP_ERROR_OFFSET_ERROR), se kunnskapsartikkel:
ECS: xDoctor: RAP081: Symptomkode: 2048: Alle NTP-servere justerer en forskyvning høyere enn feilterskelen

For symptom 'System time difference above ERROR Threshold', se kunnskapsartikkel:
ECS: xDoctor: RAP081: Symptomkode: 2048: Systemtidsforskjell over ERROR-terskelen

Affected Products

ECS

Products

ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Software
Article Properties
Article Number: 000230633
Article Type: Solution
Last Modified: 03 Oct 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.