ECS: xDoctor: RAP081: Symptom Code: 2048: Všechny servery NTP NEJSOU vhodné pro synchronizaci

Summary: Aplikace xDoctor zjistila problém s démonem NTP (Network Time Protocol).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Všechny uzly v racku ECS by měly mít spuštěného démona NTP a nakonfigurované servery NTP by měly být schopny synchronizovat čas. Pokud ne, může to vést k problémům s příjmem dat front-endu.

Příznak

Zpráva

NTP_NOT_SUITABLE_ERROR

Zpráva = Všechny servery NTP NEJSOU vhodné pro synchronizaci.
Extra = [Seznam uzlů]

Cause

Výše uvedené příznaky zůstávají jako VAROVÁNÍ, pokud se neobjeví do 24 hodin.
Pokud po 24 hodinách přetrvává, závažnost se zvýší na CHYBU a nahlásí se RAP081.

Resolution

To znamená, že žádný uzel uvedený v poli "Extra" nelze synchronizovat se serverem NTP.

Ověření:
1. Získejte seznam serverů NTP pro každý z uvedených uzlů:

Příkaz:

# getrackinfo -r | grep NTP

Příklad:

admin@node1:~> getrackinfo -r | grep NTP
NTPServer = xxx.xxx.xxx.xxx

2. U každého serveru NTP uvedeného v kroku 1 otestujte, zda je schopen synchronizovat čas.

Příkaz:

# sudo ntpdate -p 2 -d <Adresa IP NTP / NTP FQDN>

Nebo

# sudo ntpdate -p 2 -d 'getrackinfo -r | grep NTP |grep -oP "(?:[0-9]{1,3}\.) {3} [0-9] {1,3}"'

Příklad (s možností synchronizace času):

admin@node1:~> sudo ntpdate -p 2 -d xxx.xxx.xxx.xxx
22 Feb 13:47:48 ntpdate[110901]: ntpdate 4.2.8p11@1.3728-o Thu Jun 14 09:26:52 UTC 2018 (1)
Hledá se IP adresa> hostitele <NTP a služba ntp
<IP adresa> NTP obrácená na <název hostitele>
NTP hostitele nalezen : <Přenos názvu>hostitele NTP (<IP adresa> NTP)
příjem (<IP adresa> NTP)
přenos (<IP adresa> NTP)příjem (<IP adresa> NTP)

IP adresa> serveru <NTP, port 123
vrstva 2, přesnost -24, skok 00, důvěra 000
refid [<IP adresa> NTP], zpoždění 0,02615, rozptyl 0,00003
přenášen 2, v referenčním čase filtru 2
:
    e01a7b0d.af9e6616 Fri, Feb 22 2019 13:43:41.686
originate timestamp: e01a7c06.748e0c65 Fri, Feb 22 2019 13:47:50.455
Vysílat časové razítko:  e01a7c06.7478b000 Fri, Feb 22 2019 13:47:50.454
zpoždění filtru:  0,02635 0,02615 0,00000 0,00000
0,00000 0,00000 0,00000 0,00000
Posun filtru: 0.000043 -0.00002 0.000000 0.0000000
0.0000000 0.000000 0.0000000 0.000000
zpoždění 0.02615, disperze 0.00003
offset -0.000022

22 Feb 13:47:50 ntpdate[110901]: úprava časového serveru <posun IP adresy> NTP -0.000022 sec

Příklad: (server není schopen synchronizovat čas)

admin@node1:~> sudo ntpdate -p 2 -d xxx.xxx.xxx.xxx
22 Feb 13:47:48 ntpdate[110901]: ntpdate 4.2.8p11@1.3728-o Thu Jun 14 09:26:52 UTC 2018 (1)
Hledá se IP adresa> hostitele <NTP a služba ntp
<IP adresa> NTP obrácená na <název hostitele>
NTP hostitele nalezen : <Přenos názvu>
hostiteleNTP (<IP adresa> NTP)
přenos (<IP adresa> NTP)
přenos (<adresa> IP NTP)

server <IP adresa> NTP, port 123
vrstva 2, přesnost -24, přestup 00, důvěra 000
refid [<IP adresa> NTP], zpoždění 0,02615, rozptyl 0,00003
přenesen 2, v referenčním čase filtru 2
:    e01a7b0d.af9e6616 Fri, Feb 22 2019 13:43:41.686
originate timestamp: e01a7c06.748e0c65 Fri, Feb 22 2019 13:47:50.455
Vysílat časové razítko:  e01a7c06.7478b000 Fri, Feb 22 2019 13:47:50.454
zpoždění filtru:  0,02635 0,02615 0,00000 0,00000
0,00000 0,00000 0,00000 0,00000
Posun filtru: 0.000043 -0.00002 0.000000 0.0000000
0.0000000 0.000000 0.0000000 0.000000
zpoždění 0.02615, disperze 0.00003
offset -0.000022

22 Feb 13:47:50 ntpdate[112232]: nebyl nalezen žádný server vhodný pro synchronizaci

3. Přidejte plně kvalifikovaný název domény do oddílu NTP ve výsledku getrackinfo -r .

Příkaz:

# sudo setrackinfo -a NTPServer < NTP FQDN >

4. Zkontrolujte oddělení sítě a statické trasy, protože problém může způsobit protokol NTP odeslaný z rozhraní pro správu prostřednictvím směrování založeného na zásadách.

Příkaz:

# getrackinfo -n; getrackinfo -t

Příklad:

admin@node1:~>getrackinfo -n; getrackinfo -t
Pojmenované sítě
==============
ID uzlu IP adresa sítě Brána masky sítě Rozhraní
VLAN Seznam statických tras=================

ID uzlu Rozhraní brány síťové masky

5. Ověřte, zda servery NTP naslouchají ve svém prostředí a zda brána firewall neblokuje port. 

Příkaz:

# sudo ntpq -c as

Příklad: (Níže vidíme jeden server NTP, který není dostupný, a druhý se blokuje, pravděpodobně kvůli seznamu ACL.)

admin@node1:~> sudo ntpq -c as
ind assid status conf reach auth condition last_event cnt
===========================================================
1 56633 8011 ano ne žádný odmítnout mobilizovat 1

6. Zkontrolujte, zda v serveru NTP nedošlo k posunu data. 

Příkaz:

# viprexec "date +%s" 2>&1 | grep "^15"

Příklad:

admin@node1:~>viprexec "date +%s" 2>&1 | grep "^15"
1554470147
1554470111
1554470096
1554470142 1554470144

1554470109
1554470124
1554470140

7. Zkontrolujte stav služby ntpd a poté ji restartujte (I když je stav Up and Running, pokračujte restartováním.) 
Poznámka: Služba ntpd.service nemá žádný dopad.

Příkaz:

# viprexec systemctl status ntpd.service | grep Active:

Příklad:

admin@node1:~> viprexec systemctl status ntpd.service | grep Aktivní:
   Aktivní: aktivní (běží) od út 2019-08-06 02:49:06 UTC; 1 den 18h před
Aktivní: aktivní (běží) od út 2019-08-06 02:49:07 UTC; 1 den 18h před
Aktivní: aktivní (běží) od st 2019-08-07 20:13:27 UTC; 58min před
Aktivní: aktivní (běží) od út 2019-08-06 02:49:06 UTC; 1 den 18h před
Aktivní: aktivní (běží) od út 2019-08-06 02:49:07 UTC; 1 den 18h před
Aktivní: aktivní (běží) od út 2019-08-06 02:49:07 UTC; 1 den 18h před
Aktivní: aktivní (běží) od út 2019-08-06 02:49:07 UTC; před 1 dnem 18h
Aktivní: aktivní (běží) od út 2019-08-06 02:49:07 UTC; 1 den 18h před

Příkaz: 

# viprexec systemctl restart ntpd.service

Příklad:

admin@node1:~> viprexec systemctl restart ntpd.service
Výstup z hostitele: 192.168.219.8
Výstup z hostitele: 192.168.219.7
Výstup z hostitele: 192.168.219.6
Výstup z hostitele: 192.168.219.4
Výstup z hostitele: 192.168.219.3
Výstup z hostitele: 192.168.219.2
Výstup z hostitele: 192.168.219.5
Výstup z hostitele: 192 168 219.1

8. Zkontrolujte soubor md5sum ntp.conf ve všech uzlech.

Příkaz:

# viprexec "sudo md5sum /etc/ntp.conf"

Příklad:

admin@node1:~> viprexec "sudo md5sum /etc/ntp.conf"

Výstup z hostitele: 192.168.219.2
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Výstup z hostitele: 192.168.219.5
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Výstup z hostitele: 192.168.219.4
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Výstup z hostitele: 192.168.219.1
7da6eb8009abc18ed1875f1f15ade72a /etc/ntp.conf

Výstup z hostitele: 192.168.219.3
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Výstup z hostitele: 192.168.219.8
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Výstup z hostitele: 192.168.219.6
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Výstup z hostitele: 192.168.219.7
741F0ABB12AC82A21F150004BD407334 /etc/ntp.conf

Poznámka: To může být způsobeno tím, že máte veřejné rozhraní a rozhraní pro správu a všechny uzly jsou nakonfigurované tak, aby byly neveřejné podle poslední poskytnuté konfigurace. Ve starších verzích systému ECS může dojít k uváznutí PBR, kde je jeden uzel platný a zbytek uzlů se zdá být za firewallem.

9. Přidejte k části ns_mgmt ve výsledku příkazu getrackinfo -r část 123 a zkontrolujte, jestli server NTP začal přenášet a přijímat data.

Příkaz:

# sudo setrackinfo -a ns_mgmt 123

Příklad:

admin@node1:~>sudo setrackinfo -a ns_mgmt 123

Pokud chyba stále přetrvává, přejděte na port 123 zpět do veřejného rozhraní a znovu zkontrolujte synchronizaci.

Příkaz:

# sudo setrackinfo -d ns_mgmt 123

Příklad:

admin@node1:~> sudo setrackinfo -d ns_mgmt 123

Po provedení každého z výše uvedených kroků zkontrolujte stav synchronizace NTP.

Usnesení:
To znamená, že nakonfigurovaný server není serverem NTP nebo nefunguje podle očekávání. K vyřešení problému s NTP je nutné zapojit síťový tým zákazníka.

Additional Information

Pokud výše uvedené řešení nefunguje, je nutné do řešení problému s NTP zapojit zákazníkův síťový tým.

Příznak "NTP daemon není spuštěn" (NTPD_NOT_RUNNING) naleznete v článku znalostní databáze:
ECS: xDoctor: RAP081: Symptom Code: 2048: Démon NTP není spuštěn.

Příznak "Všechny servery NTP upravují posun vyšší než prahová hodnota chyby" (NTP_ERROR_OFFSET_ERROR) naleznete v článku znalostní databáze:
ECS: xDoctor: RAP081: Symptom Code: 2048: Všechny servery NTP upraví posun vyšší, než je prahová hodnota

chybyPříznak "Rozdíl systémových časů nad prahovou hodnotou ERROR" naleznete v článku znalostní databáze:
ECS: xDoctor: RAP081: Symptom Code: 2048: Rozdíl systémových časů nad prahovou hodnotou ERROR

Affected Products

ECS

Products

ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Software
Article Properties
Article Number: 000230633
Article Type: Solution
Last Modified: 03 Oct 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.