ECS: xDoctor: RAP081: Код симптому: 2048: Всі NTP-сервери НЕ підходять для синхронізації

Summary: xDoctor виявив проблему з фоновою службою Network Time Protocol (NTP).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Усі вузли в стійці ECS повинні мати запущений демон NTP, а налаштовані NTP-сервери повинні мати можливість синхронізувати час. Якщо ні, це може призвести до проблем із прийомом даних інтерфейсу.

Симптом

Повідомлення

NTP_NOT_SUITABLE_ERROR

Повідомлення = Всі NTP-сервери НЕ підходять для синхронізації.
Extra = [Список вузлів]

Cause

Перераховані вище симптоми залишаються ПОПЕРЕДЖЕННЯМ, якщо воно не виникає протягом 24 годин.
Через 24 години, якщо це не зникне, тяжкість буде збільшена до ПОМИЛКИ, і буде повідомлено про RAP081.

Resolution

Це означає, що на кожному вузлі, вказаному в полі «Додатково», не можна синхронізуватися з NTP-сервером.

Верифікація:
1. Отримайте список NTP-серверів на кожному з перелічених вузлів:

Команда:

# getrackinfo -r | grep NTP

Приклад:

admin@node1:~> getrackinfo -r | grep NTP
NTPServer = xxx.xxx.xxx.xxx

2. Для кожного NTP-сервера, переліченого на кроці 1, перевірте, чи здатний він синхронізувати час.

Команда:

# sudo ntpdate -p 2 -d <IP-адреса NTP / NTP FQDN>

Або

# sudo ntpdate -p 2 -d 'getrackinfo -r | grep NTP |grep -oP "(?:[0-9]{1,3}\.) {3} [0-9] {1,3}"'

Приклад (здатний синхронізувати час):

admin@node1:~> sudo ntpdate -p 2 -d xxx.xxx.xxx.xxx
22 Feb 13:47:48 ntpdate[110901]: ntpdate 4.2.8p11@1.3728-o Чт Чер 14 09:26:52 UTC 2018 (1)
Шукаю IP-адресу хоста <NTP IP адреси> та службу ntp
<NTP IP-адреса> змінена на <NTP ім'я>
хоста знайдено : <NTP hostname>
transmit (<IP адреса> NTP)
rereceive (<IP-адреса> NTP)
transmit(<IP-адреса> NTP)
прийом (<IP-адреса> NTP)
IP-адреса> сервера<, порт 123
stratum 2, точність -24, стрибок 00, довіра 000
refid [<IP-адреса> NTP], затримка 0,02615, дисперсія 0,00003
передана 2, у фільтрі 2
довідковий час:    e01a7b0d.af9e6616 Пт, 22 лютого 2019 13:43:41.686
вихідна позначка часу: e01a7c06.748e0c65 Пт, 22 лютого 2019 13:47:50.455
позначка часу передачі:  e01a7c06.7478b000 Пт, 22 лютого 2019 13:47:50.454
затримка фільтра:  0,02635 0,02615 0,00000 0,00000
0,00000 0,00000 0,00000 0,00000
Зміщення фільтра: 0,000043 -0,00002 0,000000 0,000000
0,000000 0,000000 0,000000 0,000000
затримка 0,02615, дисперсія 0,00003
зміщення -0,000022

22 лютого 13:47:50 ntpdate[110901]: коригування часу сервера <NTP IP-адреси> зміщення -0,000022 сек

Приклад: (Якщо він не здатний синхронізувати час, він виводить)

admin@node1:~> sudo ntpdate -p 2 -d xxx.xxx.xxx.xxx
22 Feb 13:47:48 ntpdate[110901]: ntpdate 4.2.8p11@1.3728-o Чт Чер 14 09:26:52 UTC 2018 (1)
Шукаю IP-адресу хоста <NTP IP адреси> та службу ntp
<NTP IP-адреса> змінена на <NTP ім'я>
хоста знайдено : <Передача імені хоста>
NTP (<IP-адреса> NTP)
передача (<IP-адреса> NTP)
передача (<IP-адреса> NTP)

сервера <IP-адреса>, порт 123
stratum 2, точність -24, стрибок 00, довірчий 000
refid [<IP-адреса> NTP], затримка 0,02615, дисперсія 0,00003
передана 2, у фільтрі 2
довідковий час:    e01a7b0d.af9e6616 Пт, 22 лютого 2019 13:43:41.686
вихідна позначка часу: e01a7c06.748e0c65 Пт, 22 лютого 2019 13:47:50.455
позначка часу передачі:  e01a7c06.7478b000 Пт, 22 лютого 2019 13:47:50.454
затримка фільтра:  0,02635 0,02615 0,00000 0,00000
0,00000 0,00000 0,00000 0,00000
Зміщення фільтра: 0,000043 -0,00002 0,000000 0,000000
0,000000 0,000000 0,000000 0,000000
затримка 0,02615, дисперсія 0,00003
зміщення -0,000022

22 Feb 13:47:50 ntpdate[112232]: не знайдено жодного сервера, придатного для синхронізації

3. Додайте FQDN до розділу NTP у результаті getrackinfo -r.

Команда:

# sudo setrackinfo -a NTPServer < NTP FQDN >

4. Перевірте наявність розділення мережі та статичних маршрутів, оскільки NTP, надісланий з інтерфейсу керування через маршрутизацію на основі політик, може спричинити проблему.

Команда:

# getrackinfo -n; getrackinfo -t

Приклад:

admin@node1:~>getrackinfo -n; getrackinfo -t
Іменовані мережі
==============
Ідентифікатор вузла Мережева IP-адреса Netmask Gateway VLAN Інтерфейс
статичного маршруту
=================
Ідентифікатор вузла Network Netmask Інтерфейс шлюзу

5. Переконайтеся, що NTP-сервери прослуховують дані у своєму середовищі та чи часто брандмауер блокує порт. 

Команда:

# sudo ntpq -c як

Приклад: (Нижче ми бачимо один сервер NTP, який недоступний, а інший блокується, ймовірно, через список контролю доступу)

admin@node1:~> sudo ntpq -c as
ind assid status conf reach auth condition last_event cnt
===========================================================
1 56633 8011 так ні немає відхилити мобілізувати 1

6. Перевірте, чи немає зсуву дат у NTP. 

Команда:

# viprexec "date +%s" 2>&1 | grep "^15"

Приклад:

admin@node1:~>viprexec "date +%s" 2>&1 | grep "^15"
1554470147
1554470111
1554470096 1554470142
1554470144

1554470109
1554470124
1554470140

7. Перевірте стан служби ntpd і перезапустіть її. (Навіть якщо стан увімкнено та працює, продовжуйте перезавантаження.) 
Примітка: ntpd.service – це служба, яка не впливає на ситуацію.

Команда:

# viprexec systemctl status ntpd.service | grep активний:

Приклад:

admin@node1:~> viprexec systemctl status ntpd.service | grep Активний:
   Активний: активний (запущений) з Вт 2019-08-06 02:49:06 UTC; 1 день 18год тому
Активний: активний (запущений) з Вт 2019-08-06 02:49:07 UTC; 1 день 18год тому
Активний: активний (запущений) з Ср 2019-08-07 20:13:27 UTC; 58хв тому
Активний: активний (запущений) з Вт 2019-08-06 02:49:06 UTC; 1 день 18год тому
Активний: активний (запущений) з Вт 2019-08-06 02:49:07 UTC; 1 день 18 годин тому
Активний: активний (запущений) з Вт 2019-08-06 02:49:07 UTC; 1 день 18 годин тому
Активний: активний (запущений) з Вт 2019-08-06 02:49:07 UTC; 1 день 18год тому
Активний: активний (запущено) з Вт 2019-08-06 02:49:07 UTC; 1 день 18год тому

Команда: 

# viprexec systemctl restart ntpd.service

Приклад:

admin@node1:~> viprexec systemctl restart ntpd.service
Виведення з хоста : 192.168.219.8
Вихід з хоста : 192.168.219.7
Вихід з хоста : 192.168.219.6
Вихід з хоста : 192.168.219.4
Вихід з хоста : 192.168.219.3
Вихід з хоста : 192.168.219.2
Вихід з хоста : 192.168.219.5
Вихід з хоста : 192.168.219.1

8. Перевірте файл md5sum ntp.conf на всіх вузлах.

Команда:

# viprexec "sudo md5sum /etc/ntp.conf"

Приклад:

admin@node1:~> viprexec "sudo md5sum /etc/ntp.conf"

Висновок з хоста : 192.168.219.2
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Висновок з хоста : 192.168.219.5
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Висновок з хоста : 192.168.219.4
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Висновок з хоста : 192.168.219.1
7da6eb8009abc18ed1875f1f15ade72a /etc/ntp.conf

Висновок з хоста : 192.168.219.3
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Висновок з хоста : 192.168.219.8
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Висновок з хоста : 192.168.219.6
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Висновок з хоста : 192.168.219.7
741f0abb12ac82a21f150004bd407334 /etc/ntp.conf

Примітка: Це може бути пов'язано з наявністю публічного інтерфейсу та інтерфейсу керування, і всі вузли налаштовані на вихід з публічних відповідно до останньої наданої конфігурації. На старих версіях ECS PBR може застрягти, коли один вузол є дійсним, а решта вузлів начебто знаходяться за брандмауером.

9. Додайте 123 до ns_mgmt в результаті getrackinfo -r, а потім перевірте, чи почав NTP передавати та приймати.

Команда:

# sudo setrackinfo -a ns_mgmt 123

Приклад:

admin@node1:~>sudo setrackinfo -a ns_mgmt 123

Якщо помилка не зникає, помістіть порт 123 назад у загальнодоступний інтерфейс і знову перевірте синхронізацію.

Команда:

# sudo setrackinfo -d ns_mgmt 123

Приклад:

admin@node1:~> sudo setrackinfo -d ns_mgmt 123

Перевіряйте стан синхронізації NTP після виконання кожного з перерахованих вище кроків.

Резолюція:
Це означає, що налаштований сервер не є сервером NTP або він не працює належним чином. Для вирішення проблеми з NTP необхідно залучити мережеву команду клієнта.

Additional Information

Якщо наведене вище рішення не працює, для вирішення проблеми з NTP необхідно залучити мережеву команду клієнта.

Щодо симптому 'NTP daemon not runing' (NTPD_NOT_RUNNING), дивіться статтю
знань: ECS: xDoctor: RAP081: Код симптому: 2048: Фонова служба NTP не працює

Про симптом «Усі сервери NTP налаштовують зміщення, що перевищує поріг помилки» (NTP_ERROR_OFFSET_ERROR), дивіться статтю знань:
ECS: xDoctor: RAP081: Код симптому: 2048: Усі NTP-сервери налаштовують зміщення, вище порогу

помилкиЩодо симптому 'Різниця в часі системи вище порогу ПОМИЛКИ', дивіться статтю знань:
ECS: xDoctor: RAP081: Код симптому: 2048: Різниця в часі системи перевищує поріг ERROR

Affected Products

ECS

Products

ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Software
Article Properties
Article Number: 000230633
Article Type: Solution
Last Modified: 03 Oct 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.