PowerFlex Ağ Geçidi: GW yeniden yüklemesinden sonra kullanıcı arayüzü hatası ERR_SSL_PROTOCOL_ERROR
Summary: GW yeniden yüklemesinden sonra kullanıcı arayüzü hatası ERR_SSL_PROTOCOL_ERROR
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Senaryo
PowerFlex Ağ Geçidi (GW) 3.6.0.6 sürümünden 3.6.2 ye yükseltildi. Ardından 3.6.2 sürümü kaldırıldı ve 3.6.0.6 sürümü yeniden yüklendi.
PowerFlex GW kullanıcı arayüzü, eski sürüm olan 3.6.0.6'yı yeniden yükledikten sonra ERR_SSL_PROTOCOL_ERROR gösterir.
Java sürümü bu senaryoda bir faktör değildi.
Etki
PowerFlex GW kullanıcı arayüzünde oturum açılamıyor.
Cause
PowerFlex Gateway sürüm 3.6.2 yeni cryptoj 3.6.2'den önceki sürümlerle uyumlu olmayan kitaplıklar.
Resolution
PowerFlex GW ye SSH aracılığıyla bağlanın
-
GW rpm'yi kaldırın
rpm -e $(rpm -qa |grep -i emc|grep gateway)
-
Yeni taşı
cryptojKitaplıkları /tmp dizinine ekleyin.find "$(dirname "$(readlink -f "$(which java)")")/../lib/ext" -type f \( -exec rpm -qf {} \; -o -print \) | grep "^/" | xargs -I {} mv {} /tmp/ -
JAR dosyalarının /tmp dizinine taşındığını doğrulayın
ll /tmp/ | grep jar -rwxr-xr-x 1 root root 494856 Sep 23 17:40 commons-lang3-3.6.jar -rwxr-xr-x 1 root root 2291434 Sep 23 17:40 cryptoj-6.2.3.jar -rwxr-xr-x 1 root root 72292 Sep 23 17:32 cryptojce-6.2.6.2.jar -rwxr-xr-x 1 root root 1583411 Sep 23 17:32 cryptojcommon-6.2.6.2.jar -rwxr-xr-x 1 root root 528171 Sep 23 17:32 jcm-6.2.5.jar -rwxr-xr-x 1 root root 501115 Sep 23 17:32 sslj-6.5.jar
-
GW'yi yeniden yükleyin
GATEWAY_ADMIN_PASSWORD='<password>' rpm -ivh /path_to_rpm/EMC-ScaleIO-gateway-3.6-600.113.x86_64.rpm
-
Kullanıcı arayüzüne erişebildiğinizi doğrulayın
Additional Information
Etkilenen Sürüm
PowerFlex Gateway sürüm 3.6.1.x ve altı
Düzeltildiği Sürüm
TDB
Article Properties
Article Number: 000230777
Article Type: Solution
Last Modified: 01 Oct 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.