Data Protection Advisor: Når du har oppgradert til 19.11, mislykkes Avamar-datainnsamlingsforespørsler med uventet EOF fra Worker Process

Summary: Når du har oppgradert til 19.11, mislykkes Avamar-datainnsamlingsforespørsler med uventet EOF fra arbeiderprosessen.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Når du har oppgradert til 19.11, mislykkes Avamar-datainnsamlingsforespørselen og viser en feil unexpected EOF from worker process. Dette observeres når du kjører Avamar jobmonitor-forespørselen.

Følgende observeres i agentloggene etter at agenten er plassert i feilsøkingslogging og kjøring av forespørselen om datainnsamling på nytt:
DBG1     7344.10320    20240822:151447          com.base.os - cfindpath(): couldn't find file dpaagent_modavamar_jobmonitor.exe
DBG1     7344.10320    20240822:151447      com.base.runcmd - csystemopen(): command is E:\DPA\agent\bin\dpaagent_modavamar.exe
DBG2     7344.10320    20240822:151447      com.base.runcmd - csystemopen(): raw command line is E:\DPA\agent\bin\dpaagent_modavamar.exe
DBG2     7344.10320    20240822:151447      com.base.runcmd - csystemopen(): command input is
<CMDINPUT version='6'><AGENTID>ea4c7604-77b4-4801-b9af-83cf349fa820</AGENTID><MODCONFIG><GLOBALCONFIG><USEBINARYMULT>true</USEBINARYMULT></GLOBALCONFIG><LOGPATH>E:\DPA\agent\logs\</LOGPATH><PSTOREBASE>E:\DPA\agent\data</PSTOREBASE><PLUGINSDIR>E:\DPA\agent\plugins</PLUGINSDIR></MODCONFIG><LOGLEVEL>Debug low</LOGLEVEL><REQUEST><UUID>ca26dce2-3a6e-41ae-9710-a0057d1543fc</UUID><MODULE><NAME>avamar</NAME></MODULE><FUNCTION><NAME>jobmonitor</NAME></FUNCTION><PERIOD>300</PERIOD><COMMITMODE>1</COMMITMODE><TARGET><NODEUUID>305f400d-7e96-4b34-a2fe-7fac09edfe41</NODEUUID><NODETYPE>Avamar</NODETYPE><NETNAME>hostname</NETNAME><INSTANCENAME>Avamar</INSTANCENAME><ISLOCAL>false</ISLOCAL></TARGET><CRED><TYPE>generic-app</TYPE><GENERICAPP><USERNAME>viewuser</USERNAME><PASSWORD>password</PASSWORD></GENERICAPP></CRED><HISTORICAL>0</HISTORICAL><OPTION><NAME>dbport</NAME><VALUE>5555</VALUE></OPTION><OPTION><NAME>dspreference</NAME><VALUE>false</VALUE></OPTION><OPTION><NAME>pollbatch</NAME><VALUE>86400</VALUE></OPTION><OPTION><NAME>dbname</NAME><VALUE>mcdb</VALUE></OPTION></REQUEST><ISCHECK>false</ISCHECK><COMPRESS>true</COMPRESS><FIPSMODE>false</FIPSMODE></CMDINPUT>
 
DBG1     7344.10320    20240822:151447        com.base.i18n - convertToUTF8Start(): iconv to 'UTF-8' not possible or reading from UTF-8 hence not using a converter
DBG2     7344.10320    20240822:151447      com.base.runcmd - csystemreadline(): wrote 1223 bytes, 0 remaining
DBG1     7344.10320    20240822:151447      com.base.runcmd - csystemreadline(): no more lines left
ERR      7344.10320    20240822:151447     com.agent.worker - runAgentWorkerRequest(): Unexpected EOF from worker process while running request avamar:jobmonitor on hostname:Avamar
The data collection for Avamar request fails after upgrade to DPA 19.11
 
Caused by: ERR 3784.4692 20240801:162933 com.agent.worker - runAgentWorkerRequest(): Unexpected EOF from worker process while running request avamar:jobmonitor

Cause

Dette er et kjent problem i Data Protection Advisor.

vcruntime140.dll-modulen mangler på DPA-applikasjonsserveren.
DPA Avamar-datainnsamlingsmodulen (dpaagent_modavamar.exe) krever denne modulen.
 
vcruntime140.dll-modulen er i Visual C++ 2015 Redistributable Package (x64) for Microsoft Windows.

Resolution

Det er ingen permanent løsning på dette problemet. Problemet undersøkes fortsatt av Dells teknikere.

Det finnes en midlertidig løsning på dette problemet.

Installer den omdistribuerbare pakken (x64) for Visual C++ 2015 på DPA datainnsamlingsserveren. Denne pakken er tilgjengelig for nedlasting direkte fra Microsoft.
Når du har installert pakken på serveren for datainnsamling for DPA, starter du DPA Agent på nytt.

Hvis du vil ha mer informasjon eller informasjon, kan du kontakte Dells tekniske kundestøtte .
Article Properties
Article Number: 000231566
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.