Avamar: Proxy Deployment Manager – Ny proxy kan ikke implementeres pga. fejl med låst fil
Summary: Avamar: Proxy Deployment Manager – Ny proxy kan ikke implementeres på grund af fejlen Tænd proxy: Kan ikke få adgang til fil, da den er låst"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Implementeringen af nye proxyer i VSAN-miljøer ved hjælp af Proxy Deployment Manager kan mislykkes på grund af følgende.
Fejlmeddelelse: Der opstod en fejl under proxy: Kan ikke få adgang til filen, da den er låst."
Log placering: Denne fejl vises i følgende logfil på Avamar-serveren:
/usr/local/avamar/var/log/vcs/deploymanager.log
Logoplysninger:
TRACE [Thread-39 ][ impl.ConnectionManagerService# releaseSession]: Releasing connection manager session: id=...147079090986 DEBUG [Thread-39 ][ worker.DeployWorker# run]: Powering on VM TRACE [Thread-40 ][ util.VcConnection# keepAlive]: Keep-aliving VC session TRACE [Thread-40 ][ impl.ConnectionManagerService# sendKeepAlive]: Keep-alive connection manager session: ...85fdd16e4831 WARN [Thread-39 ][ worker.DeployWorker# run]: Error powering on proxy: Unable to access file since it is locked WARN [Thread-39 ][ worker.DeployWorker# run]: Uncaught MethodFault null DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: INFO [Thread-39 ][ worker.TaskWorker# sendTaskError]: Sending fault com.vmware.vim25.LocalizedMethodFault@60a82b15 INFO [Thread-39 ][ worker.DeployWorker# run]: Deploy of proxy gnewproxyhostname.example.com (19.10.100-166) to host esxi.example.com was not successful. Cleaning up deploy artifacts... DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: Cleaning up after error... INFO [Thread-39 ][ worker.DeployWorker# run]: keepDeployFailedProxy: false
Cause
Problemet med fillåsning skyldes:
- Miljøfaktorer; Dette problem opstår ikke i de fleste miljøer.
- Utilstrækkelig forsinkelse mellem det mislykkede forsøg på at tænde og den manuelle opstart
- Timing problemer, der gør det vanskeligt at bestemme den nøjagtige årsag.
Resolution
Langsigtet løsning
Hotfixes, der løser dette problem, udgives i AV19.9 og AV19.10SP1. Rettelsen vil også være i den næste store Avamar-udgivelse.
Løsning
Kontakt Dell Support for at installere en ændret version af Deployment Manager, der tilføjer en forsinkelse mellem implementeringsopgaven og opstartsopgaven.
Affected Products
AvamarArticle Properties
Article Number: 000233945
Article Type: Solution
Last Modified: 29 Nov 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.