Avamar: Proxy Deployment Manager - 잠긴 파일 오류로 인해 새 프록시를 배포하지 못함
Summary: Avamar: Proxy Deployment Manager - New Proxy Fails to Deploy Due to "Error Powering on Proxy: 파일이 잠겨 있기 때문에 액세스할 수 없습니다."
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
다음과 같은 이유로 Proxy Deployment Manager를 사용하여 VSAN 환경에서 새 프록시를 배포하지 못할 수 있습니다.
오류 메시지: "프록시 전원 켜기 중 오류 발생: 파일이 잠겨 있어 액세스할 수 없습니다."
로그 위치: 이 오류는 Avamar Server의 다음 로그 파일에 나타납니다.
/usr/local/avamar/var/log/vcs/deploymanager.log
로그 세부 정보:
TRACE [Thread-39 ][ impl.ConnectionManagerService# releaseSession]: Releasing connection manager session: id=...147079090986 DEBUG [Thread-39 ][ worker.DeployWorker# run]: Powering on VM TRACE [Thread-40 ][ util.VcConnection# keepAlive]: Keep-aliving VC session TRACE [Thread-40 ][ impl.ConnectionManagerService# sendKeepAlive]: Keep-alive connection manager session: ...85fdd16e4831 WARN [Thread-39 ][ worker.DeployWorker# run]: Error powering on proxy: Unable to access file since it is locked WARN [Thread-39 ][ worker.DeployWorker# run]: Uncaught MethodFault null DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: INFO [Thread-39 ][ worker.TaskWorker# sendTaskError]: Sending fault com.vmware.vim25.LocalizedMethodFault@60a82b15 INFO [Thread-39 ][ worker.DeployWorker# run]: Deploy of proxy gnewproxyhostname.example.com (19.10.100-166) to host esxi.example.com was not successful. Cleaning up deploy artifacts... DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: Cleaning up after error... INFO [Thread-39 ][ worker.DeployWorker# run]: keepDeployFailedProxy: false
Cause
파일 잠금 문제는 다음과 같은 원인으로 인해 발생합니다.
- 환경 요인; 대부분의 환경에서는 이 문제가 발생하지 않습니다.
- 실패한 전원 켜기 시도와 수동 전원 켜기 사이의 지연 부족
- 정확한 원인을 파악하기 어렵게 만드는 타이밍 문제.
Resolution
장기적 해결책
이 문제를 해결하는 핫픽스는 AV19.9 및 AV19.10SP1에서 릴리스됩니다. 이 수정 사항은 다음 주요 Avamar 릴리스에도 포함될 예정입니다.
해결 방법
Dell 지원 부서에 문의하여 배포 작업과 전원 켜기 작업 사이에 지연을 추가하는 수정된 버전의 Deployment Manager를 설치하십시오.
Affected Products
AvamarArticle Properties
Article Number: 000233945
Article Type: Solution
Last Modified: 29 Nov 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.