Avamar:Proxy Deployment Manager — 由于锁定文件错误,新代理无法部署
Summary: Avamar:Proxy Deployment Manager — 新代理由于“Error powering on proxy:由于文件已锁定,因此无法访问该文件”
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
由于以下原因,使用 Proxy Deployment Manager 在 vSAN 环境中部署新代理可能会失败。
错误消息:“Error power on proxy:由于文件已被锁定,因此无法访问该文件。”
日志位置:此错误出现在 Avamar Server 上的以下日志文件中:
/usr/local/avamar/var/log/vcs/deploymanager.log
日志详细信息:
TRACE [Thread-39 ][ impl.ConnectionManagerService# releaseSession]: Releasing connection manager session: id=...147079090986 DEBUG [Thread-39 ][ worker.DeployWorker# run]: Powering on VM TRACE [Thread-40 ][ util.VcConnection# keepAlive]: Keep-aliving VC session TRACE [Thread-40 ][ impl.ConnectionManagerService# sendKeepAlive]: Keep-alive connection manager session: ...85fdd16e4831 WARN [Thread-39 ][ worker.DeployWorker# run]: Error powering on proxy: Unable to access file since it is locked WARN [Thread-39 ][ worker.DeployWorker# run]: Uncaught MethodFault null DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: INFO [Thread-39 ][ worker.TaskWorker# sendTaskError]: Sending fault com.vmware.vim25.LocalizedMethodFault@60a82b15 INFO [Thread-39 ][ worker.DeployWorker# run]: Deploy of proxy gnewproxyhostname.example.com (19.10.100-166) to host esxi.example.com was not successful. Cleaning up deploy artifacts... DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: Cleaning up after error... INFO [Thread-39 ][ worker.DeployWorker# run]: keepDeployFailedProxy: false
Cause
文件锁定问题的原因是:
- 环境因素;在大多数环境中不会发生此问题。
- 尝试开机失败与手动开机之间的延迟不足
- 计时问题导致难以确定确切原因。
Resolution
长期解决方案
解决此问题的修补程序将在 AV19.9 和 AV19.10SP1 中发布。该修复也将在下一个主要 Avamar 版本中提供。
解决方法
请联系戴尔支持,以安装修改后的 Deployment Manager 版本,该版本会增加部署任务与开机任务之间的延迟。
Affected Products
AvamarArticle Properties
Article Number: 000233945
Article Type: Solution
Last Modified: 29 Nov 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.