iDRAC9: The firmware update job is not starting
Summary: In some instances, the firmware update job may fail to initiate when performing a firmware update through available iDRAC interfaces.
Symptoms
The firmware update job has been created but remains in the "New" job state.

Identify the issue:
If either of the below are true then the error message can be seen.
- If the job queue has not been cleared
- If another Firmware Update job is present and previously failed due to a timeout, or is stuck in the downloading job state.
Message event: JCP052: The job was in either running or downloading state and timed out before completion.
Example: Job Timeout

Example: Job Downloading

Cause
The Integrated Dell Remote Access Controller (iDRAC) Remote Enablement Downloader is detecting another ongoing instance because of a lockfile, which is preventing new firmware update jobs from moving out of the "New" job state. When a firmware update job is running, the lockfile is removed once the job is completed. However, this issue can occur if a previous firmware update job fails during the file transfer of the update package to the iDRAC.
- On iDRAC Firmware prior to 7.00.60.00, the job queue displays a previous Firmware Update Job state as Downloading.
- On iDRAC Firmware version 7.00.60.00 or later, the job queue displays a previous Firmware Update Job state as Failed due to Timeout.
Resolution
Fix:
This issue is resolved in the iDRAC Firmware version 7.20.10.50.
Workaround:
To work around the issue, reset the iDRAC and then re-create the firmware update job.
