NVP-vProxy: VM-Backup schlägt aufgrund des VMware View-Fehlers "Daten können nicht von vCenter abgerufen werden" fehl

Summary: VM-Backups schlagen aufgrund eines Verbindungsproblems mit dem vCenter Server fehl. In diesem Artikel wird die Lösung erläutert.

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Symptoms

vCenter-Backups schlagen aufgrund von Verbindungsproblemen mit vCenter fehl.

  • Empfangsfehler in der NMC ähnlich wie KB: NVP-vProxy: Die Ansicht des Updates schlägt fehl, Fehler "Daten können nicht aus vCenter abgerufen werden: Es wurde festgestellt, dass EOF gegen das Protokoll verstößt."
  • NetWorker VMware View-Fehler empfangen:
    Unable to fetch data from vCenter: EOF was observed that violates the protocol.  The client probably provided invalid authentication information.
  • Verbindungsprobleme mit vCenter führen zu SSL-Fehlern. SSL-Fehler in der vProxy-Datei /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-vddk.log.
    VDDK INFO 2024-10-07T21:01:42.616+05:30 error -[04510] [Originator@6876 sub=IO] HandshakeCb; <SSL(<io_obj p:0x00007f2694008bc8, h:68, <TCP 'xxx.xxx.xxx.xxx : 60194'>, <TCP 'xxx.xxx.xxx.xxx : 443'>>)>; error: N7Vmacore3Ssl12SSLExceptionE(SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake.)
    VDDK INFO 2024-10-07T21:01:42.749+05:30 error -[10320] [Originator@6876 sub=transport] Cannot connect to Server: SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake..
    2024-10-07T15:31:42Z NOTICE: VDDK INFO 2024-10-07T21:01:42.791+05:30 warning -[10320] [Originator@6876 sub=transport] Fail to fetch ddb with double encoding, error(Cannot connect to server)
  • /var/log/vmware/envoy/envoy.log des vCenter Servers enthält:
    2024-10-09T22:32:56.814Z warning envoy[3248] [Originator@6876 sub=filter] [Tags: "ConnectionId":"737396"] remote https connections exceed max allowed: 2048
    2024-10-09T22:32:56.814Z warning envoy[3248] [Originator@6876 sub=filter] [Tags: "ConnectionId":"737396"] closing connection TCP<xxx.xxx.xxx.xxx:55718, xxx.xxx.xxx.xxx:443>

 

Cause

Die Ursache des Problems ist ein Verbindungsproblem zwischen dem vCenter Server und dem NetWorker-Server, das zu einem Fehler bei vCenter-Backups führt. Die VMware View-Fehlermeldung "EOF was observed that breaches the protocol" weist auf ein Verbindungsproblem mit vCenter hin.

Die vbackupd-vddk.log Datei vom vProxy-Server zeigt einen SSL-Fehler mit der folgenden Meldung an:

"SSL Exception: error:140000DB:SSL routines:SSL routines:short read: The connection was closed by the remote end during handshake."

Das VMware Envoy-Protokoll zeigt denselben Fehler an, was auf ein Problem mit der Netzwerkauslastung hinweist.

"remote https connections exceed max allowed: 2048" suggests that the vCenter server is exceeding the maximum allowed connections to the vProxy server.

Die Meldung zum Schließen der Verbindung: "closing connection TCP<xxx.xxx.xxx.xxx:55718, xxx.xxx.xxx.xxx:443>" gibt an, dass der vProxy-Server die Verbindung aufgrund von übermäßigen Verbindungen schließt.

 

Resolution

Standardmäßig führt NetWorker alle 15 Minuten eine Bestandsaufnahme für ein vCenter durch. Der vCenter-Bestandsaufnahmeprozess wird auch immer dann durchgeführt, wenn ein Nutzer über die NetWorker Management Console eine Verbindung zum NetWorker-Server herstellt und eine VMware-Schutz-Policy gestartet wird. Das standardmäßige Bestandsaufnahmeintervall "nsrvim" kann auf bis zu 60 Minuten erhöht werden, siehe: NVP-vProxy: Der NetWorker-nsrvim-Prozess wird alle 15 Minuten ausgeführt, was zu einer hohen Workload auf vCenter Server und potenzieller Nichtverfügbarkeit von VPXD führt

Wenn das Problem auch nach dem Erhöhen der NSRVIM_TIME_INTERVAL auf 60 Minuten weiterhin besteht, führen Sie die folgenden Schritte aus:

HINWEIS: Dieses Problem wirkt sich auf NetWorker VMware Protection aus. Er tritt jedoch auf dem vCenter Server auf. Um das Problem zu beheben, wenden Sie sich an Ihr VMware-Team oder den VMware-Support, um das Verbindungsproblem zwischen dem vCenter und den NetWorker-Servern zu beheben.

Die Lösung für das vCenter-Backupfehlerproblem besteht darin, den Erschöpfungsfehler der SSL-Verbindung zu beheben. Führen Sie die folgenden Schritte aus, um das Problem zu beheben:

  1. Folgen Sie VMware KB 344920. Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.
  2. Wenden Sie sich an den VMware-Support: Wenn das Problem nicht durch den oben genannten Wissensdatenbank-Artikel behoben werden kann, wenden Sie sich an den VMware-Support, um weitere Unterstützung zu erhalten.
VORSICHT: Das Deaktivieren der SSL-Verifizierung kann die Sicherheit Ihrer Umgebung gefährden. Es wird empfohlen, die SSL-Verifizierung nur als letzten Ausweg und nur nach Rücksprache mit dem VMware-Support zu deaktivieren.

Überprüfen Sie nach der Implementierung der obigen Schritte, ob das Problem behoben wurde, indem Sie die vCenter Server- und vProxy-Protokolle auf SSL-bezogene Fehler überprüfen. Wenn das Problem weiterhin besteht, wenden Sie sich an den VMware Support, um weitere Unterstützung zu erhalten.

 

Additional Information

Überprüfen Sie, ob der NetWorker-Server eine Verbindung zum vCenter-HTTPS-Port (443) über SSL herstellen kann:

openssl s_client -connect VCENTER_ADDRESS:443
HINWEIS: openssl ist ein Dienstprogramm eines Drittanbieters. Sie ist in der Regel standardmäßig auf Linux-Betriebssystemen enthalten. Auf Windows-Betriebssystemen ist sie jedoch in der Regel nicht standardmäßig enthalten. Dies erfordert die Installation von openssl.

NVP-vProxy: Troubleshooting der Netzwerkverbindung bei Backup- und Wiederherstellungsvorgängen

 

Affected Products

NetWorker
Article Properties
Article Number: 000236865
Article Type: Solution
Last Modified: 23 Jan 2025
Version:  3
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