Échec de l’enregistrement de l’agent de système de fichiers PowerProtect Data Manager en raison d’un problème de configuration de la recherche IP inversée

Summary: L’enregistrement de l’agent de système de fichiers PowerProtect Data Manager échoue en raison d’un problème de configuration de recherche IP inversée. L’enregistrement de l’agent échoue après une nouvelle installation lorsque la recherche IP inversée n’est pas configurée. Pour résoudre le problème, configurez la recherche IP inversée sur le serveur DNS ou modifiez temporairement le fichier hosts. ...

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Symptoms

Échec de l’enregistrement de l’agent de système de fichiers PowerProtect Data Manager après une nouvelle installation

À partir de l’état d’enregistrement des agents >d’applicationde l’interface utilisateur> de PowerProtect Data Manager, Failed after Acceptance Certificates.  

Capture d’écran de l’agent d’application dont l’état est « Acceptance Certificates »

Capture d’écran des agents d’application dont l’état est « Failed »

Dans C:\Program Files\DPSAPPS\AgentService\logs\OpAgentSvc-******.log, il montre ce qui suit PPDM IpCheck validation failed pour /greetings call.

[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 361- Could not fetch the host details for the address ppdm.local.com
[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 362- PPDM IpCheck validation failed. Rejecting the api call for /greetings
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5658- Timeout error occurred, exiting registration process exit code 7. Error - 3600 seconds
Traceback (most recent call last):
File "Http\HTTPServer.py", line 5656, in startWSGIServer
File "Http\HTTPServer.py", line 5503, in start_server
File "src\\gevent\\greenlet.py", line 1065, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\\greenlet.py", line 1075, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\_hub_primitives.py", line 250, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 287, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 185, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_hub_primitives.py", line 176, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_waiter.py", line 195, in gevent._gevent_c_waiter.MultipleWaiter.get
File "src\\gevent\_waiter.py", line 154, in gevent._gevent_c_waiter.Waiter.get
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 65, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_gevent_c_greenlet_primitives.pxd", line 35, in gevent._gevent_c_greenlet_primitives._greenlet_switch
gevent.timeout.Timeout: 3600 seconds
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5660- Please follow the remediation steps mentioned below to resolve the problem :
1. Check if the host is approved/whitelisted on PowerProtect Data Manager server.
2. Alternatively, 'Auto Allow List' can be enabled on PowerProtect Data Manager server.
3. Ensure there is no connectivity issue from PowerProtect Data Manager server to agent system.
4. Restart the agent service and try again.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 949- HTTPServer has stopped with exitcode 7.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 951- Stopping the agentService

Cause

La cause première de l’échec de l’enregistrement de l’agent de système de fichiers PowerProtect Data Manager est attribuée à l’absence de configuration de recherche IP inversée. Exécutez nslookup côté client pour vérifier la résolution de noms de PowerProtect Data Manager. Cela fonctionne pour le nom d’hôte PowerProtect Data Manager, mais pas pour la recherche inverse d’adresse IP. 

Sortie nslookup pour le nom d’hôte

Sortie nslookup pour l’adresse IP

Il est indiqué dans le Guide de l’utilisateur du système de fichiers PowerProtect Data Manager que « la résolution de noms et la recherche IP inversée doivent être configurées » 

Guide de l’utilisateur du système de fichiers PPDM

Resolution

La résolution consiste à configurer la recherche IP inverse de PowerProtect Data Manager sur un serveur DNS. Si le serveur DNS n’est pas accessible à ce moment-là, modifiez temporairement le fichier hosts côté client. Ensuite, l’État de l’enregistrement dans l’interface utilisateur doit être automatiquement remplacé par En attente d’approbation. Si ce n’est pas le cas, redémarrez manuellement le service de l’agent PowerProtect côté client.

Service de l’agent PowerProtect côté client

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000239282
Article Type: Solution
Last Modified: 16 Dec 2024
Version:  2
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