Registrazione del file system agent di PowerProtect Data Manager non riuscita a causa di un problema di configurazione della ricerca inversa

Summary: La registrazione del File System Agent di PowerProtect Data Manager non riesce a causa di un problema di configurazione della ricerca IP inversa. La registrazione dell'agent non riesce dopo una nuova installazione quando la ricerca IP inversa non è configurata. Per risolvere il problema, configurare la ricerca IP inversa sul server DNS o modificare temporaneamente il file hosts. ...

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Symptoms

La registrazione del file system di PowerProtect Data Manager File System Agent non è riuscita dopo una nuova installazione

Da PowerProtect Data Manager UI >Application Agents >Registration Status, viene visualizzato Failed dopo l'accettazione dei certificati.

Screenshot dell'Application Agent con stato

Screenshot degli application agent con stato

In C:\Program Files\DPSAPPS\AgentService\logs\OpAgentSvc-******.log, mostra quanto segue PPDM IpCheck validation failed per /greetings calldegli host.

[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 361- Could not fetch the host details for the address ppdm.local.com
[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 362- PPDM IpCheck validation failed. Rejecting the api call for /greetings
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5658- Timeout error occurred, exiting registration process exit code 7. Error - 3600 seconds
Traceback (most recent call last):
File "Http\HTTPServer.py", line 5656, in startWSGIServer
File "Http\HTTPServer.py", line 5503, in start_server
File "src\\gevent\\greenlet.py", line 1065, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\\greenlet.py", line 1075, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\_hub_primitives.py", line 250, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 287, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 185, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_hub_primitives.py", line 176, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_waiter.py", line 195, in gevent._gevent_c_waiter.MultipleWaiter.get
File "src\\gevent\_waiter.py", line 154, in gevent._gevent_c_waiter.Waiter.get
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 65, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_gevent_c_greenlet_primitives.pxd", line 35, in gevent._gevent_c_greenlet_primitives._greenlet_switch
gevent.timeout.Timeout: 3600 seconds
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5660- Please follow the remediation steps mentioned below to resolve the problem :
1. Check if the host is approved/whitelisted on PowerProtect Data Manager server.
2. Alternatively, 'Auto Allow List' can be enabled on PowerProtect Data Manager server.
3. Ensure there is no connectivity issue from PowerProtect Data Manager server to agent system.
4. Restart the agent service and try again.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 949- HTTPServer has stopped with exitcode 7.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 951- Stopping the agentService

Cause

La root cause dell'errore di registrazione del File System Agent di PowerProtect Data Manager è attribuita all'assenza della configurazione della ricerca IP inversa. Eseguire nslookup sul lato client per verificare la risoluzione dei nomi di PowerProtect Data Manager. Funziona per il nome host di PowerProtect Data Manager, ma non per la ricerca IP inversa. 

Output nslookup per il nome host

Output nslookup per l'IP

Nella Guida utente del file system di PowerProtect Data Manager è documentato che "la risoluzione dei nomi e la ricerca IP inversa devono essere configurate" 

Guida utente del file system PPDM

Resolution

La risoluzione consiste nel configurare la ricerca IP inversa di PowerProtect Data Manager su un server DNS. Se il server DNS non è al momento accessibile, modificare temporaneamente il file hosts sul lato client. Successivamente, Registration Status nell'interfaccia utente dovrebbe essere modificato automaticamente in In attesa di approvazione. In caso contrario, riavviare manualmente il servizio PowerProtect Agent sul lato client.

Servizio PowerProtect Agent sul lato client

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000239282
Article Type: Solution
Last Modified: 16 Dec 2024
Version:  2
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