Не удалось зарегистрировать агента файловой системы PowerProtect Data Manager из-за проблемы с конфигурацией обратного поиска IP-адреса

Summary: Не удается зарегистрировать агента файловой системы PowerProtect Data Manager из-за проблемы конфигурации обратного поиска IP-адреса. Регистрация агента завершается ошибкой после новой установки, если обратный поиск IP-адреса не настроен. Чтобы решить эту проблему, настройте обратный поиск IP-адреса на сервере DNS или временно измените файл hosts. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Не удалось зарегистрировать агента файловой системы PowerProtect Data Manager после новой установки

В пользовательском интерфейсе > PowerProtect Data Manager Application Agents >Status отображается состояние «Failed after Acceptance Certificates».

Снимок экрана Application Agent со статусом

Снимок экрана Application Agents со статусом

В C:\Program Files\DPSAPPS\AgentService\logs\OpAgentSvc-******.log, он показывает ниже PPDM IpCheck validation failed для /greetings call.

[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 361- Could not fetch the host details for the address ppdm.local.com
[2024-10-21 03:53:05,643 GMT| 2024-10-21 11:53:05,643506 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-checkIP()-Line 362- PPDM IpCheck validation failed. Rejecting the api call for /greetings
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5658- Timeout error occurred, exiting registration process exit code 7. Error - 3600 seconds
Traceback (most recent call last):
File "Http\HTTPServer.py", line 5656, in startWSGIServer
File "Http\HTTPServer.py", line 5503, in start_server
File "src\\gevent\\greenlet.py", line 1065, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\\greenlet.py", line 1075, in gevent._gevent_cgreenlet.joinall
File "src\\gevent\_hub_primitives.py", line 250, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 287, in gevent._gevent_c_hub_primitives.wait_on_objects
File "src\\gevent\_hub_primitives.py", line 185, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_hub_primitives.py", line 176, in gevent._gevent_c_hub_primitives._WaitIterator.__next__
File "src\\gevent\_waiter.py", line 195, in gevent._gevent_c_waiter.MultipleWaiter.get
File "src\\gevent\_waiter.py", line 154, in gevent._gevent_c_waiter.Waiter.get
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 61, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_greenlet_primitives.py", line 65, in gevent._gevent_c_greenlet_primitives.SwitchOutGreenletWithLoop.switch
File "src\\gevent\_gevent_c_greenlet_primitives.pxd", line 35, in gevent._gevent_c_greenlet_primitives._greenlet_switch
gevent.timeout.Timeout: 3600 seconds
[2024-10-21 03:53:24,449 GMT| 2024-10-21 11:53:24,449717 | DBGHTTPSERVER| PID-2796| TID-3564| INFO] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\Http\HTTPServer.pyc-startWSGIServer()-Line 5660- Please follow the remediation steps mentioned below to resolve the problem :
1. Check if the host is approved/whitelisted on PowerProtect Data Manager server.
2. Alternatively, 'Auto Allow List' can be enabled on PowerProtect Data Manager server.
3. Ensure there is no connectivity issue from PowerProtect Data Manager server to agent system.
4. Restart the agent service and try again.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 949- HTTPServer has stopped with exitcode 7.
[2024-10-21 03:53:25,230 GMT| 2024-10-21 11:53:25,230570 | AGENTSVC_OP| PID-4320| TID-6672| ERROR] C:\Program Files\DPSAPPS\AgentService\tmp_MEI50402\main.py-checkHttpServer()-Line 951- Stopping the agentService

Cause

Основная причина сбоя регистрации агента файловой системы PowerProtect Data Manager — отсутствие конфигурации обратного поиска IP-адреса. Выполните nslookup на стороне клиента, чтобы проверить разрешение имен PowerProtect Data Manager. Это работает для имени хоста PowerProtect Data Manager, но не для обратного поиска IP-адреса. 

Выходные данные nslookup для имени хоста

Выходные данные nslookup для IP-адреса

В руководстве пользователя файловой системы PowerProtect Data Manager указано: «Необходимо настроить разрешение имен и обратный поиск IP-адресов» 

Руководство пользователя по файловой системе PPDM

Resolution

Для решения этой проблемы необходимо настроить обратный поиск IP-адреса PowerProtect Data Manager на DNS-сервере. Если DNS-сервер в данный момент недоступен, временно измените файл hosts на стороне клиента. После этого Статус регистрации в пользовательском интерфейсе должен автоматически измениться на Ожидает утверждения. В противном случае перезапустите службу агента PowerProtect на стороне клиента вручную.

PowerProtect Agent Service на стороне клиента

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000239282
Article Type: Solution
Last Modified: 16 Dec 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.