Avamar: Tworzenie kopii zapasowej kończy się niepowodzeniem z komunikatem "Kopia zapasowa klienta wyłączona"

Summary: W tym artykule wyjaśniono, w jaki sposób ponownie włączyć wielu klientów na serwerze Avamar po uaktualnieniu lub innych problemach przy użyciu konsoli administratora lub mcdb.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kopia zapasowa jest uruchamiana i natychmiast kończy się niepowodzeniem z "Client Backup Disabled"
 

AUI pokazujące, że tworzenie kopii zapasowej nie powiodło się ze stanem


Dostęp do zarządzania > zasobami interfejsu użytkownika Avamar (AUI), > wybierz domenę>, wybierz klienta>, kliknij przycisk WYŚWIETL WIĘCEJ>, kliknij kartę Informacje.

W polu Enabled wyświetlany jest tekst "Nie".
 

Klient wyświetla włączoną wartość jako

 

 

Cause

To zachowanie można zaobserwować u niektórych lub wszystkich klientów po uaktualnieniu kodu lub ponownym uruchomieniu serwera z cofnięciem. Pierwotna przyczyna jest w tej chwili nieznana.

Resolution

Istnieją trzy metody włączania klientów:
 

  1. Korzystanie z AUI: Najlepsze rozwiązanie umożliwiające obsługę kilku klientów.
  2. Korzystanie z konsoli administratora Avamar: Idealne rozwiązanie umożliwiające obsługę wielu klientów w różnych domenach.
  3. Aktualizowanie bazy danych konsoli zarządzającej (mcdb): Nadaje się do włączenia wszystkich klientów jednocześnie.

 

1. Korzystanie z AUI:

  • Dostęp do interfejsu użytkownika Avamar (AUI)
  • Przejdź do zarządzania zasobami
  • Wybierz domenę
  • Wybierz klienta
  • Kliknij trzy kropki w WIĘCEJ AKCJI
  • Kliknij opcję Edit Client
  • Kliknij pole wyboru Włączone

Enabled i zaznacz pole wyboru, aby włączyć klienta. 

  • Kliknij przycisk AKTUALIZUJ
  • W kolumnie Enabled klient ma wartość "true"

Klient wyświetlany jako włączony.

 

2. Korzystanie z konsoli administratora Avamar

  • Uruchom konsolę Avamar Administrator
  • Przejdź do zasad
  • Na karcie Policy Management wybierz domenę, aby włączyć klientów. W poniższym przykładzie wybrano Lab_Clients.
  • W tej domenie jest pięciu klientów. W kolumnie "Backups Disabled" widoczna jest informacja "Yes", co oznacza, że klienci są wyłączeni.

Wszystkie klienty w jednej domenie są wyświetlane jako wyłączone.

  • Wybierz jednego klienta i naciśnij Ctrl + A, aby wybrać wszystkich klientów. 

Wybieranie wszystkich klientów. 

  • Aby wybrać więcej niż jednego klienta (nie wszystkich), wybierz jednego klienta i po naciśnięciu Ctrl wybierz pozostałych klientów

Wybieranie niektórych klientów. 

  • Kliknij przycisk Edytuj
  • Pojawia się następujące ostrzeżenie:

Wyskakujące okno ostrzeżenia. Zignoruj to.

  • Kliknij przycisk OK , aby kontynuować:


Zostanie wyświetlone okno "Edit Multiple Clients". Zmień wartość opcji "Disable all backups" z Tak na Nie. Zmień menu rozwijane z "Nie zmieniaj" na "Zastosuj zmianę":

Edytuj wielu klientów. 

  • Kliknij przycisk OK
  • Kliknij przycisk Odśwież w prawym górnym rogu
  • Kolumna "Backups Disabled" ma wartość "No", co oznacza, że klienci są włączeni.

Wszyscy klienci włączeni.

 

3. Aktualizowanie bazy danych konsoli zarządzającej (mcdb)

  • Ta procedura wymaga zatrzymania i uruchomienia usługi Management Console Service (MCS). Upewnij się, że istnieje prawidłowe opróżnienie MCS i ostatni punkt kontrolny. Serwer Avamar musi być bezczynny.
  • Zatrzymaj usługę MCS i pozostaw mcdb w trybie online:
mcserver.sh --stop && dbmaint.sh --db=on mcdb
  • Połącz z mcdb:
psql -d mcdb -p 5555
  • Uruchom następujące polecenie. Polecenie włącza wszystkich klientów z wyjątkiem klientów w domenie MC_RETIRED i MC_SYSTEM:
update clients set enabled='t' where descr not like '%MC_SYSTEM%' and descr not like '%MC_RETIRED%';
  • Zamknij bazę danych mcdb
\q

Uruchom usługi MCS i Backup Scheduler.

mcserver.sh --start && dpnctl start sched
  • Sprawdź, czy klienty są włączone.

Affected Products

Avamar Client, Avamar Server
Article Properties
Article Number: 000243306
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.