Авамар: Не вдається створити резервне копіювання з функцією "Резервне копіювання клієнта вимкнено"

Summary: У цій статті пояснюється, як повторно ввімкнути кілька клієнтів на сервері Avamar після оновлення або інших проблем за допомогою консолі адміністратора або mcdb.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Запускається резервне копіювання і відразу ж виходить з ладу з "Client Backup Disabled"
 

AUI показує, що не вдалося виконати резервне копіювання зі статусом «Резервне копіювання клієнта вимкнено».


Отримайте доступ до керування > активами інтерфейсу користувача Avamar (AUI), > виберіть домен, виберіть Клієнт, > натисніть ПЕРЕГЛЯНУТИ БІЛЬШЕ>, перейдіть на вкладку Інформація>.

Поле Увімкнено відображається як "Ні".
 

Клієнт показує увімкнене значення як

 

 

Cause

Така поведінка може спостерігатися у деяких або всіх клієнтів після оновлення коду або перезавантаження сервера з відкатом. Першопричина на даний момент невідома.

Resolution

Є три методи, які дозволяють клієнтам працювати:
 

  1. Використання AUI: Найкраще підходить для кількох клієнтів.
  2. За допомогою консолі адміністратора Avamar: Ідеально підходить для підтримки кількох клієнтів у різних доменах.
  3. Оновлення бази даних консолі керування (mcdb): Підходить для включення всіх клієнтів відразу.

 

1. Використання AUI:

  • Доступ до інтерфейсу користувача Avamar (AUI)
  • Перейдіть до розділу «Управління активами»
  • Виберіть домен
  • Оберіть клієнта
  • Натисніть на три крапки в БІЛЬШЕ ДІЙ
  • Натисніть Редагувати клієнта
  • Установіть прапорець «Увімкнено»

Включено поле і вибираємо пункт для включення клієнта. 

  • Натисніть ОНОВИТИ
  • У стовпці Увімкнено клієнт відображається як "true"

Клієнт відображається як увімкнено.

 

2. Використання консолі адміністратора Avamar

  • Запустіть консоль адміністратора Avamar
  • Перейти до політики
  • На вкладці «Керування політиками » виберіть домен, щоб активувати клієнтів. У наведеному нижче прикладі вибрано Lab_Clients.
  • У цій сфері є п'ять клієнтів. Стовпець "Резервне копіювання вимкнено" відображається як "Так", це означає, що клієнти вимкнені.

Усі клієнти в одному домені відображаються як вимкнені.

  • Виберіть один клієнт і Ctrl + A, щоб вибрати всіх клієнтів. 

Вибір всіх клієнтів. 

  • Щоб вибрати більше одного клієнта (не всіх), виберіть один клієнт і, утримуючи натиснуту клавішу Ctrl, виберіть інші клієнти

Вибір деяких клієнтів. 

  • Натисніть кнопку «Редагувати »
  • З'являється таке попередження:

Спливаюче вікно з попередженням. Ігноруйте це.

  • Натисніть OK , щоб продовжити:


З'явиться вікно «Редагувати кілька клієнтів». Змініть значення "Вимкнути всі резервні копії" з "Так" на "Ні". Змініть випадаюче меню з "Не змінювати" на "Застосувати зміни":

Функція редагування кількох клієнтів. 

  • Натисніть кнопку «OK»
  • Натисніть кнопку оновлення у верхньому правому куті
  • Стовпець "Резервне копіювання вимкнено" відображається як "Ні", це означає, що клієнти включені.

Всі клієнти включені.

 

3. Оновлення бази даних консолі керування (mcdb)

  • Ця процедура вимагає зупинки та запуску служби консолі керування (MCS). Переконайтеся, що є дійсний флеш MCS і нещодавня контрольна точка. Сервер Avamar має бути неактивним.
  • Зупиніть службу MCS і залиште mcdb в мережі:
mcserver.sh --stop && dbmaint.sh --db=on mcdb
  • Підключення до mcdb:
psql -d mcdb -p 5555
  • Виконайте наступну команду. Команда вмикає всіх клієнтів, крім клієнтів під доменом MC_RETIRED та MC_SYSTEM:
update clients set enabled='t' where descr not like '%MC_SYSTEM%' and descr not like '%MC_RETIRED%';
  • Вийдіть з mcdb
\q

Запустіть служби MCS і Backup Scheduler.

mcserver.sh --start && dpnctl start sched
  • Підтвердьте, чи ввімкнено клієнти.

Affected Products

Avamar Client, Avamar Server
Article Properties
Article Number: 000243306
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.