Dell Pro Keyboard and Mouse KM5221W Stops Working after Update

Summary: The following article provides information about an issue with the Dell Pro Keyboard and Mouse KM5221W. The keyboard and mouse stop working or are not detected after the Dell Peripheral Manager incorrectly update its firmware (FW). ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Dell Pro Keyboard and Mouse KM5221W stop working after an incomplete firmware update

 

The following problems may be experienced with your Dell Pro Keyboard and Mouse KM5221W:

  • The keyboard and mouse are not working
  • Dell Peripheral Manager (DPM) cannot detect the keyboard and mouse

This happens after DPM states that the peripherals update successfully. However, the firmware update shows it failed to download correctly. DPM then reports that a critical error is occurring.

Dell Peripheral Manager Update Window

Dell Peripheral Manager Update Download Failure Error Messaging

Dell Peripheral Manager Update Critical Update Error Messaging

Cause

The latest firmware update was not available to the servers globally. This is causing a download failure. The dongle firmware can end up in its bootloader state when the firmware update does not complete successfully. The dongle loses communication with the keyboard and mouse.

Resolution

Note: Administrator rights are required on the device the keyboard and mouse connect to when updating software on the peripherals.

Use the following instructions to reinstall the firmware update on your keyboard and mouse:

  1. Manually download and install the following firmware:

    1. Download this .zip file: Standalone Bootloader FW Update Utility

    2. Extract the .zip file to a temporary folder.

    3. Open the temporary folder and right-click Dongle_FWUpdateTool 0.1.2.6.exe and select Run as Administrator.

    4. Follow the on-screen instructions to complete the firmware update.

  2. Launch the Dell Peripheral Manager application.

    1. Run the Firmware update process in DPM.

    2. Go back to Step.1 and repeat them if the dongle is still having issues.

  3. Contact Us if the issue continues.

Affected Products

Dell Pro Keyboard and Mouse KM5221W
Article Properties
Article Number: 000252857
Article Type: Solution
Last Modified: 25 Jul 2025
Version:  3
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